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Getting started with Shapr3D 
Requirements, downloading, subscriptions, accounts, storage, Shapr3D Cloud 
[Section link | Table of contents | Next ] 
 

The basics 
Installation, updating, and requirements 
[Section link | Table of contents | Next ] 

Download Shapr3D 
[Article link | Table of contents | Next] 

Shapr3D Basic is free of charge, while Shapr3D Pro requires a monthly or yearly subscription. Before 
downloading and installing Shapr3D, check our Compatible devices page to ensure your device meets the 
requirements. 
 

Compatible operating systems 
 
Shapr3D is currently available on Windows, macOS, iPadOS, and visionOS. Android is not 
supported at this time. For a touch-based experience, explore Shapr3D on a Windows device that 
supports pen and touch input. Fore more information, visit our Compatible devices page. 

 

Download links 
 

Platform Installer 

iPadOS App Store installer 

macOS App Store installer 

macOS Direct installer 

Windows Direct installer 

Windows Microsoft Store installer 
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How to download and install Shapr3D 
For detailed instructions on how to download Shapr3D, follow the guide below. 

Windows 

From the installer 

Access the download link in the following ways: 

● Install directly (Recommended): Download the .appinstaller file to your computer and launch 
directly via App Installer file association. 

● Install via the command line: Download the .appinstaller file to your computer and then use the 
following command in a PowerShell console: 
Add-AppxPackage -AppInstallerFile "PATH\TO\Shapr3D.Package.appinstaller” 

Note 
 
These options require that App Installer is installed on your device. Windows versions that 
have Microsoft Store enabled ship with App Installer available, however if you opted-out of 
Microsoft Store, please make sure you have the latest version installed. 

● Go to shapr3d.com > Get started for free > click Download for Windows under Windows. 

From the Microsoft Store 

Download Shapr3D from the Microsoft Store via your browser using this link: 
apps.microsoft.com/store/detail/shapr3d/9N4K9QFV4XFC 

You can also follow these steps to download Shapr3D from the Microsoft Store: 

1. Open Microsoft Store. 
2. Sign in to the Microsoft Store with your Microsoft account. 
3. Search for Shapr3D. 
4. Select Install.  

 

iPadOS 

Download Shapr3D from the App Store: apps.apple.com/app/shapr3d-cad-modeling/id1091675654. 

macOS 

From the installer 

1. Access the download link in any of the following ways: 
● Download the installer here: https://download.shapr3d.com/mac/latest 
● Go to shapr3d.com > Get started for free > click Download for macOS under macOS. 

2. Choose a folder to save the .dmg file, then click Save. 
3. Open the downloaded file. 
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4. Follow the prompt to click and drag Shapr3D to copy it into your Applications folder. 

 

From the App Store 

Download Shapr3D from the App Store via your browser using this link: 
apps.apple.com/app/shapr3d/id1091675654. 

You can also follow these steps to download Shapr3D from the App Store: 

1. Open App Store. 
2. Sign in to the App Store with your Apple ID. 
3. Search for Shapr3D. 
4. Select Get. 

 Read more 
 
If you encounter any issues during installation, visit Installation issues. 
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Update Shapr3D 
[Article link | Table of contents | Back | Next ] 

Ensure that you have all the latest features available by keeping your Shapr3D software version up-to-date. 
Follow the guide below to learn how to update Shapr3D based on your device or installation type. 

Tip 

To learn about the latest version and updates, visit our Shapr3D release updates page or the 
Shapr3D Changelog. 

 

Windows 

From the installer 

To update Shapr3D using the installer downloaded from the Shapr3D website, follow the steps for 
downloading Shapr3D from the installer. When prompted, confirm that you want to replace the older version 
with the new version that you downloaded. 

From Microsoft Store 

To update Shapr3D, follow these steps: 

1. Open Microsoft Store. Make sure that you're signed in to your Microsoft account. 
2. At the bottom left, click Library. 
3. At the upper-right corner of the Library page, click Get updates. 
4. If an update is available, Shapr3D automatically updates in the Updates & downloads section. 

Note: If you have an older version but don't see Shapr3D in the available updates, follow the steps 
to update Shapr3D from the website. 

iPadOS 

From the App Store 

1. Open App Store. Make sure you’re signed in to your Apple ID. 
2. Search for Shapr3D. 
3. Select Shapr3D CAD modeling. 
4. Under Shapr3D CAD modeling, look for the Open or Update button. 

○ Open – This button means that Shapr3D has the latest version available on your device. Tap 
this button to open Shapr3D. 

○ Update – This button means there is a new update available. Tap this button to update 
Shapr3D. 
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macOS 

From the installer 

To update Shapr3D from the website, follow the steps for downloading Shapr3D from the installer. When 
prompted, confirm that you want to replace the older version with the new version that you’re downloading. 

From the App Store 

To update Shapr3D from the App Store, follow these steps: 

1. Open App Store. Make sure you're signed in to your Apple ID. 
2. Search for Shapr3D. 
3. Select Shapr3D CAD modeling. 
4. Under Shapr3D CAD modeling, look for the Open or Update button. 

○ Open – This button means that Shapr3D has the latest version available on your device. 
Click this button to open Shapr3D. 

○ Update – This button means there is a new update available. Click this button to update 
Shapr3D. 
 

  

 

5 



 

Shapr3D requirements and specifications 
[Article link | Table of contents | Back | Next ] 

Below are the requirements and specifications for Shapr3D on all devices. 

Requirements 

Compatible devices 

● Visit our Compatible devices page to view all recommended system requirements for all devices. 
● To learn more about different screen options for touch and pen input, visit these pages: 

○ Apple: Compare iPadOS models 
○ Microsoft: Compare Surface computers 

Shapr3D account 

● Before you start using Shapr3D, sign up for an account using a valid email address. 

Device specifications 
● Device limit: 3 devices at a time across all platforms. 

Note: When you log in to 4 or more devices, you will be automatically logged out of the device(s) 
with the oldest login date.  

● Languages: 
○ English 
○ Chinese (Simplified and Traditional) 
○ French 
○ German 
○ Italian 
○ Japanese 
○ Korean 
○ Portuguese (Brazil) 
○ Russian 
○ Spanish 

● Internet connection: 
○ Modeling: No  
○ Download Shapr3D: Yes 
○ Update Shapr3D: Yes 
○ Use Sync: Yes 
○ Access web links in the software: Yes 
○ Import from external cloud services: Yes 
○ Export to external cloud services: Yes 
○ Updating account email preferences: Yes 
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Subscription 
Plans, free licenses, cancellations, and refunds 
[Section link | Table of contents | Back | Next] 

Shapr3D subscription plans 
[Article link | Table of contents | Back | Next] 

Shapr3D is a freemium app, which means all users have access to every modeling tool and basic feature, 
forums, and help materials for free. On top of that, all users can work with Shapr3D on iPadOS, macOS, 
and Windows.  

Shapr3D offers the following subscription plans: 

● Shapr3D Basic: This is the free version. 
● Shapr3D Pro: A subscription-based version designed for professionals, offering advanced features 

including: 
○ Unlimited projects 
○ Export formats for all major CAD platforms, high-quality manufacturing, and AR 
○ Real-time product renders in Visualization 
○ Technical drawings 
○ Priority technical support 

● Shapr3D Enterprise: A subscription plan tailored for businesses, offering all Pro features plus: 
○ Enterprise-compliant security and data management 
○ Easy access with team login or single sign-on (SSO) 
○ CAD ecosystem importers and exporters (like CATIA, NX, and more) 
○ PLM integration 
○ Consolidated billing 
○ Customized training 
○ Dedicated account manager 

● Shapr3D EDU License: A free subscription granting access to Pro features for students and 
educators. 

We offer subscriptions instead of perpetual licenses because that’s the most beneficial to you:  

● You’re in charge: every month or year, you can choose to renew and keep using Shapr3D. 
● Low cost of entry  
● Flexible subscription-handling 
● The latest updates are always at your fingertips 
●  

 Tip 

Visit our Pricing page to learn about the cost for each subscription, payment plan options, and 
included offers. 
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Shapr3D Basic 
[Article link | Table of contents | Back | Next] 

Shapr3D Basic is a free version with a lot of accessible modeling essentials, making it an excellent tool for 
creating models or practicing your CAD skills. 

Shapr3D Basic features 
With Shapr3D Basic, you have access to the following: 

● Fundamentals: 
○ Access your account across Windows, iPadOS, and macOS platforms 
○ 2D sketching and constraints 
○ 3D solid modeling 
○ Augmented Reality viewer 
○ Projects 

Note: You can create a maximum of 2 projects. 
● Shapr3D Cloud: Shapr3D Sync 
● Import: All supported files. To learn more, visit Import. 
● Export: Low-resolution STL and 3MF only. To learn more, visit Export. 

Upgrading your plan 
You can upgrade your Shapr3D Basic plan to Shapr3D Pro anytime to access more advanced features 
such as Visualization and 2D Drawings. 

Visit Shapr3D Pro to learn how to subscribe, and our Pricing page to learn more about the difference 
between Shapr3D Basic and Shapr3D Pro. 

 Tip 
 
If you choose to cancel your subscription or downgrade to Shapr3D Basic, you will still have full 
access to all features until the subscription expires. 
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Shapr3D Pro 
[Article link | Table of contents | Back | Next] 

Upgrade your account to Shapr3D Pro to experience full functionality. With Shapr3D Pro, you can create 
unlimited projects and gain access to more advanced features such as Visualization and 2D drawings 
(Technical drawings).  

Visit our Pricing page to learn more about the difference between Shapr3D Basic and Shapr3D Pro. 

Website vs App Store subscription 
You can subscribe from the Shapr3D website or the App Store. Subscribing from either method will give 
you the advanced features that Shapr3D Pro offers, but we recommend subscribing via the website for 
these added benefits: 

● You have access to the teams feature. 
● You can pay with a company card. 
● You can deduct VAT by providing your company VAT number. 
● Your full subscription payment goes to Shapr3D without a commission paid out to Apple. 

Teams feature 
 
When you subscribe to Shapr3D Pro from the website, you automatically get access to Pro features, 
including teams. 
 
With teams, you can enjoy the following benefits: 
 

● Your own team 
○ By default, your account becomes a team that you own. 
○ You can choose to use your account individually or purchase additional seats to invite team 

members to collaborate. 
● Invitations to other teams 

○ Easily join other teams with a simple email invite from team owners. 
● Collaboration 

○ With teams, you and your teammates can share projects in a single space. 
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Subscribe to Shapr3D Pro 

Via the Shapr3D website 

1. If you haven't yet, create a Shapr3D account. 
2. You can access the subscription page in the following ways: 

● Go to account.shapr3d.com, and log in to your account. Under Subscription on your 
account page, select Upgrade. 
Note: You can also log in by going to shapr3d.com > Sign up. 

● Go to shapr3d.com/pricing. 
3. If prompted, choose Pro. 
4. Choose between a Yearly or Monthly payment plan, then select Subscribe now or Start 14-day 

free trial. 
5. Under Number of seats, select how many seats you want to purchase. Go to Seats to learn more. 

● A team member automatically occupies one seat. 
● If you don’t plan to invite team members, you can select just 1 seat for yourself. 
● You can still purchase additional seats after subscribing. 

6. Under Credit card details, enter your card payment details 
7. If required, enter your billing details under Billing information. 

Note: Billing information may be optional depending on your country if you don't enter a tax ID. If 
you enter a tax ID, billing information is mandatory. 

8. Optional: If you have a valid coupon code, click Add coupon code.  Go to Coupons to learn more. 
9. Select Subscribe now.  
10. Once your payment is successful, you will receive an invoice via email. 

Note: If you encounter issues subscribing from the website, contact support. 
11. To check if your subscription is successful, go back to the Subscription page in your account to 

confirm that your subscription has been updated. 
Note: By default, your subscription automatically renews. You can turn off auto-renewal by 
cancelling your subscription. 

Seats 
Team owners can add seats and invite members during checkout or purchase more seats and invite more 
members from the account page after subscribing. A team member automatically occupies one seat. 
 
To learn how to re-assign purchased seats to new members, go to the Manage your account. 
 

Auto-renewal 
 
Only team owners can turn on or turn off auto-renewal for the Shapr3D Pro subscription. 
 
If auto-renewal is turned off before the end of the billing cycle: 

● All team members are automatically removed and lose access to the team and their projects at the 
end of the billing cycle. 

● The team owner’s plan automatically downgraded to Shapr3D Basic 
 

To learn how to turn on or turn off auto-renewal, go to Manage your account. 
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Trial 
 
A team trial is free regardless of the total number of seats. 
 
During an active trial: 

● Team owners can invite members to the team during the trial period. 
● The newly invited team members will be enrolled in the team trial, which will last until the end of the 

team owner’s trial period. 
 
After a trial ends: 

● The team owner gets charged for the total amount of seats. 

Coupons and discounts 

For website subscriptions, Shapr3D occasionally offers discounts and promotions. If you have a valid 
coupon code, you can add it at checkout. 
 
Coupons you apply at checkout automatically apply to all seats you purchase during and after the 
transaction. Once the coupon expires, the seats renew at full price.  
 
To add a coupon code: 

1. From the payment details screen, click Add coupon code. 
2. In the Enter code field, enter your coupon code, then select Apply to continue. 
3. To finish subscribing, click Subscribe now.  
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Via the App Store 

Important 
 
Unlike a Shapr3D Website subscription, the teams feature is not available through an App Store 
subscription. 

1. If you haven't yet, create a Shapr3D account. 
Note: A Shapr3D account is not the same as an Apple ID. 

2. Open Shapr3D. 
3. If you use Shapr3D Basic, a prompt to start a free trial automatically appears whenever you open 

Shapr3D.  
Note: If you want to subscribe at a later time, select Skip & Use Limited Version at the top. 

4. Select Start Free Trial. Or, select See Subscription Details first to view more details and choose 
between a Yearly or Monthly payment plan. To subscribe, select Start 14-day Free Trial. 

5. Confirm your App Store payment. 
Note: Visit Apple Support to learn more about managing your App Store subscriptions. 

6. Once you see a prompt telling you that your purchase was successful, select OK. 
7. To check if your subscription is successful, log in to your account at account.shapr3d.com and go to 

Subscription to confirm that your subscription has been updated. 
8. Optional: If you decide to subscribe directly from the website, you can do so under Subscription 

by selecting Manage under Expires on, then selecting Change to a direct Shapr3D plan. 

Refunds 
How you request a refund depends on where you subscribed to Shapr3D: 

Website subscriptions 
● If you subscribed to Shapr3D Pro through our website and you’re an individual user or Team Owner, 

you may be eligible for a refund. 
● Refunds are possible within 14 days of your subscription date. 
● To request a refund, submit a support ticket. 

Enterprise licenses 
● For Enterprise subscriptions, please contact your account manager for any refund or billing 

questions. 

App Store subscriptions 
● If you subscribed through the Apple App Store, only Apple can process refunds for subscriptions 

made on their platform. 
● Shapr3D does not have access to Apple’s billing system and cannot issue refunds directly. 
● To request a refund, visit Apple Support. 

 

 Tip 
 
If you choose to cancel your subscription or downgrade to Shapr3D Basic, you will still have full 
access to all features until the subscription expires. 
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Shapr3D Enterprise 
[Article link | Table of contents | Back | Next] 

Shapr3D offers subscriptions for enterprises. 

Excluding account management, the Shapr3D Enterprise subscription works the same way as Shapr3D 
Pro. 

With Shapr3D Enterprise: 
● You can engage your team and stakeholders with immersive prototyping for more dynamic product 

design reviews on the Apple Vision Pro. To learn more, visit Shapr3D on Vision Pro. 
● Billing will be custom and managed by the Shapr3D Team. 
● All the Enterprise team members can view who is part of their team. 
● An account manager will need to approve requests for adding more seats, inviting/removing team 

members, or modifying the Enterprise subscription. 

Shapr3D offers subscriptions for enterprises as well. If you're looking for an Enterprise license, request a 
quote to kick off the discussion about the pricing.  
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Shapr3D on Vision Pro 
[Article link || Table of contents | Back | Next] 

Overview 
Apple Vision Pro is now part of Shapr3D’s multiplatform support, joining iPad, Mac, and Windows. Running 
Shap3D on visionOS allows you to model natively without any supporting devices. Shapr3D on Vision Pro 
offers the same robust features as other platforms, with the added benefit of an immersive and intuitive 
spatial CAD experience in its augmented reality (AR) environment. 
 
Note: Apple Vision Pro is available for enterprise users. Learn more.  

Immersive experience 
Vision Pro’s cutting-edge augmented reality brings 3D modeling to life, offering a seamless, immersive 
experience where you can manipulate and visualize models in a three-dimensional space around you. 

Native integration 
Shapr3D runs natively on Vision Pro, allowing you to access the full range of features directly within the 
Vision Pro environment without needing a supporting iPad, Mac, or Windows device. 

Full feature availability 
Vision Pro offers full access to all modeling features available on other platforms, providing you with the 
same comprehensive toolkit for designing, editing, and visualizing your projects. 

Enhanced team collaboration 
With Vision Pro, multiple users can simultaneously view the same model in high-quality AR, allowing you to 
engage your team and stakeholders with immersive prototyping for more dynamic product design reviews. 
Learn more how Shapr3D immersive CAD can help your team. 
 

Get started with Shapr3D on Vision Pro 
Quickly get started with Vision Pro and Shapr3D with these helpful support pages from Apple: 

● Get started with Apple Vision Pro: 
○ Adjust the fit of your Apple Vision Pro 
○ Turn on and set up Apple Vision Pro 
○ Learn basic gestures and controls on Apple Vision Pro 

● Download Shapr3D on Vision Pro 
● Open Shapr3D on Apple Vision Pro 
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Shapr3D EDU license 
[Article link | Table of contents | Back | Next] 

A Shapr3D EDU license is a free version of Shapr3D — available in certain countries — that provides you 
access to all Shapr3D Pro features. If you’re a student, teacher, or faculty member, you can apply for a 
free, 1-year educational (EDU) license. The EDU license is available for renewal as long as you're still 
part of an accredited educational institution. 

Choose a topic to learn more: 

● EDU license eligibility 
● Edu license FAQ 
● Apply for an EDU license 
● Renew your EDU license 

 

Important 
 
Unlike Shapr3D Pro, a Shapr3D EDU license does not include:: 

● Teams feature 
● Priority technical support 

 
 To learn more about the different subscriptions, visit shapr3d.com/pricing. 
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EDU license eligibility 
To be eligible for the Shapr3D EDU license for one year for free, you must meet the following requirements: 
 

● You must be an active student, teacher, or faculty member of an accredited educational institution. 
● You must have an active email address with a school email domain provided by the educational 

institution. 
● You must have a valid school ID with an expiration date issued by the educational institution. 
● You have a valid supporting document that proves you are an active member of the educational 

institution. 
Once you complete the requirements above, you can proceed to apply for an EDU license. 
 

 Tip 
 
If you've already started a Pro trial, cancel the Pro subscription before you apply for an EDU 
license. 
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EDU license availability FAQ 
Due to a recent restructuring of the EDU license, you may find that this plan is no longer available in your 
country. Get some answers below to find out more about this change. 
 
Q: I want to apply for the EDU license but I can see that it’s not available in my country anymore. 
Why is that?  
 
A: Due to some recent changes, we are currently restructuring our educational program. In the meantime, 
you can check our pricing page for other available options. 
 
Q: Will the EDU license be available for my country again in the future?  
 
A: The relaunch has no definite time at the moment, but we will be sure to announce if anything changes. In 
the meantime, you can check our pricing page for other options available for you. 
 
Q: I’m a teacher and I’ve been teaching Shapr3D for two years now. My EDU license has expired and 
I noticed that this option is no longer available in my country. I’m in the middle of a school semester 
and Shapr3D is part of the curriculum. Can you please continue my license as an exception? 
 
A: We understand how important it is to be able to continue with your lessons. As an alternative, you can 
opt to use Shapr3D Basic which includes all our foundational tools and features for free. For other available 
options, check out our pricing page. 
 
Q: I’m studying abroad and currently spending my summer in my home country. I’m unable to 
renew my EDU license from your website. Can you please help? 
 
A: The availability of the EDU license depends on your current location. If you don’t see the option while in 
your home country, we recommend that you renew once you’re back in the country of your education. 
 
Q: I have the Shapr3D EDU license and just found out that it’s no longer available in some 
countries. Should I be worried? 
 
A: Your subscription will remain active until it expires. Once your subscription expires and you still have 
access to renew your EDU license, it means that your country is not affected by the restructuring. You can 
still continue to use it while you’re part of an educational institution. If you have trouble renewing your 
subscription, you can visit our pricing page for other available options. 
 
Q: Our school uses Shapr3D and now they can’t use the EDU license. What alternatives/solutions can you 
offer? 
 
A:  As an alternative, you can opt to use Shapr3D Basic which includes all our foundational tools and 
features for free. For other available options, check out our pricing page. 
 
Q: I’ve already submitted the required documents for the EDU license. Are you able to give me a 
license until I finish university? I only have a year left. 
 
A: Unfortunately, we cannot give you a license if the EDU license is not available in your country. As an 
alternative, you can opt to use Shapr3D Basic which includes all our foundational tools and features for 
free. For other available options, check out our pricing page. 
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Q: My EDU license expired and I can’t renew it. All my projects in Shapr3D are locked and I need 
them to give presentations. How can I access them again? 
 
A: Shapr3D Basic allows you to access up to 2 projects. You can export your projects to a low-res STL, and 
then import the projects that you need for your presentation. For other available options, check out our 
pricing page. 
 
Q: Which countries are affected by this change? Will you restrict more countries in the future?  
 
A: The countries affected by this change may vary depending on the ongoing restructuring. We recommend 
that you visit our pricing page to check the options available for your country. 
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Apply for an EDU license 
To apply for the Shapr3D EDU license, follow these steps: 

1. Make sure you qualify for an EDU license. 
2. Create a Shapr3D account using the email address provided by your institution. 
3. Verify your account. 
4. Go to shapr3d.com/pricing.  
5. Select Free for Students and Educators. 
6. Log in with your Shapr3D account. 
7. Fill out all fields on the Request EDU license form. 

 Tip 
 
If you're a faculty member who wants to request to whitelist a batch of email domains, visit 
EDU license email whitelist guide. 

8. For faster processing, make sure to attach the following documents: 
● Student/faculty ID with an expiration date 
● Supporting document that proves you are an active member of the educational institution 

9. Select Send Request. 

Approval timeline 

After you apply for an EDU license, the Shapr3D team will review your application. The result will be sent to 
you via email within 3 to 4 business days. 
 
If your institution is part of the Shapr3D whitelist, your request will be automatically approved within 1 
business day. 

Approved application 
Once your application is approved, you can start using Shapr3D Pro right away. 
 
To get started, visit Shapr3D basics. 

Declined application 
An EDU application may be declined due to any of the following reasons: 

● You applied with a personal email address instead of the email address provided by the educational 
institution. 

● The valid ID you attached has already expired or doesn’t have an expiration date. 
● You didn’t attach any supporting documents to prove that you’re an active member of the 

educational institution. You can attach any of the following documents: 
○ Screenshot of your online student portal 
○ Signed and stamped document that confirms your active status as a member of the 

educational institution. 
 
Once you have the complete requirements, you can re-apply at any time. 
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Renew your EDU license 

You can renew your Shapr3D EDU license as long as you’re still an active member of an educational 
institution. 

When your EDU license expires, your account is automatically downgraded to Shapr3D Basic and you'll 
only have access to the two most recent projects you modified. Once you renew your EDU license or 
subscribe to Shapr3D Pro, you'll regain access to all your projects immediately. 

To renew your EDU license, simply apply for an EDU license again. 
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Cancellation and refunds 
[Article link | Table of contents | Back | Next] 

Depending on your method of subscription, you can cancel either from the Shapr3D website or the App 
Store. 

Cancel via the Shapr3D website 
1. Go to account.shapr3d.com and sign in. 

Note: You can also log in by going to shapr3d.com > Sign up. 
2. Go to Subscription. 
3. In the Auto-renews on section, select Manage > Cancel subscription. 
4. To confirm, select Cancel subscription.. 

Important 
 
By cancelling your subscription you disable automatic renewal when the current 
subscription expires. Your subscription plan remains active until the end of its term, and 
your plan details are updated with an expiration date. 

 
5. Optional: If you want to turn auto-renewal back on, go back to the Subscription page and then 

select Turn on auto-renewal in the Expires on section. 
 

Cancel via the App Store 
1. Open the App Store on your device. 
2. Go to your profile > Subscriptions > Shapr3D. 
3. Select Cancel Free Trial or Cancel Subscription. 

Note: For more information about managing your App Store subscriptions, visit How to switch to a 
different subscription plan. 

Get a refund 
If you you are a consumer (and not a business user) subscribed via the Shapr3D website, you can submit 
a support ticket within 14 days of purchase and the Shapr3D team will issue a refund for you. 

If you subscribed via the App Store, contact Apple to check if you are eligible for a refund. 
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Account and storage 
Account management and data security 
[Section link | Table of contents | Back | Next] 

Create a Shapr3D account 
[Article link | Table of contents | Back | Next] 

Before you can start using Shapr3D, you need to have an account. You can sign up through the website or 
directly from Shapr3D. 

Note: If you installed Shapr3D for the first time, you will be asked to create an account after the onboarding 
tutorial. 

To learn how to create an account, follow these steps: 

1. Access the sign up page in the following ways: 
○ From the website: Go to account.shapr3d.com > Sign up. 
○ From Shapr3D: Select Get Started. 

2. Fill out the required fields for Work email, Password, Re-enter password, and Your name. 
3. Toggle the switch to accept the Terms of Use and Privacy Policy, then select Sign Up. 
4. Verify your account by clicking the verification link that will be sent to your email address. If you don't 

receive a verification email, check your spam or go to your account page to resend a new link. 

 Tip 
 
After signing in to Shapr3D for the first time, you’ll be prompted to set up your devices and 
complete the onboarding tutorial. Simply choose the device you’ll use for modeling and follow the 
6-minute tutorial to get started. 
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Reset your Shapr3D account password 
[Article link | Table of contents | Back | Next] 

If you've forgotten your Shapr3D password, you can reset it through the website or directly from Shapr3D. 
Follow the steps below to learn how. 

1. Access the reset page in the following ways: 
○ From the website: Go to account.shapr3d.com. 
○ From Shapr3D: Open Shapr3D and then select Log In. If you're still logged in, log out first. 

2. From the Log In page, select Forgot password? 
3. From the Reset password page, enter your email address in the Email field. 
4. Select Send Reset Link to receive an email from the Shapr3D team (no-reply@shapr3d.com). 
5. Open the email and select Reset password to direct you back to the reset page.  

Note: If you don't receive an email or experience other issues, go to Password reset issues. 
6. Enter your new password in the Password and Re-enter password fields. 
7. To finish, select Save.  
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Manage your personal account and team settings 
[Article link | Table of contents | Back | Next] 

You can manage your personal account and team settings on your Shapr3D account page. From the 
Shapr3D account page, you can: 

● Update your email address and password 
● Subscribe or view your subscription plan 
● Manage your billing information 
● Invite members to your team 
● Manage your team settings 
● View other teams you’re a part of 

Access your account page 
You can access your account page in the following ways: 

● From the website: Go to account.shapr3d.com and then log in. 
● From Shapr3D: Go to Settings or Preferences > Manage Subscription. If prompted, log in to 

your account. 

Log in options 

Login with username and password 

From the website 

1. Go to account.shapr3d.com. 
2. Enter your email address. 
3. Select Continue. 
4. Enter your password. 
5. Select Login. 

From Shapr3D 

1. Open Shapr3D. 
2. Select Log In. 
3. Enter your email address. 
4. Select Continue. 
5. Enter your password. 
6. Select Login. 

Login with Single Sign-On (SSO) 

From the website 

1. Go to account.shapr3d.com. 
2. Enter your email address. 
3. Select Continue to access the login flow for your Identity Provider (IdP). 
4. Select Log In. 
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From Shapr3D 

1. Open Shapr3D. 
2. Select Log In. 
3. Enter your email address. 
4. Select Continue to access the login flow for your Identity Provider (IdP). 
5. Select Log In. 

Profile 
Once you're logged in, select your profile at the top-right to access the following options: 

● Resend verification email – This option appears if you still haven't verified your account from the 
verification email we sent.  

● Help Center  – Takes you to the Shapr3D Help Center. 
● Account settings – Takes you to the Accounts settings page. 
● Video tutorials – Takes you to the Video tutorials homepage. 
● Community – Takes you to the Shapr3D Community page. Here you can interact with other users 

and the Shapr3D team. Ask any questions you might have, help other users, or even share your 
projects. 
Note: You need to sign up for an account to create posts and leave comments in Shapr3D 
Community. 

● Download Shapr3D – Takes you to the Shapr3D download page. 
● Log out – Logs you out of your account. 

 
 

Verified account Unverified account 
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Manage personal account settings 
To access your personal account settings, click/tap Account settings. 

From the Account page, you can modify the following information: 

● Your Name – To update your name, select Update > Enter the updated name > Save. 
● Email – To update your email address, select Change > Enter the new email address > Send 

confirmation link, then log in to your new email address to confirm the new email. 
● Password – To update your password, select Change > Enter your current and new passwords > 

Update password. 
● Delete account – To delete your account, select Delete Account. You can also access this option 

from Shapr3D by going to Settings or Preferences. 
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Review Links 
You can keep track of all your shared projects in one place under Review Links. This section lists every 
project you have published as a review link, so you can quickly find, copy, open, or unpublish links without 
searching through individual projects. 

For each project, you can find: 

● Project name: Shows which project the link belongs to. 
● Link: Copy the published link to share it quickly. 
● Location: Shows where the project is saved. 
● Last updated: Shows when the link was last updated. 
● Updated by: Shows who last updated the project. 
● More options: Click the three dots to: 

○ Open the project 
○ Open it in a new tab 
○ Copy the link 
○ Unpublish the link if you no longer want to share it 
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Manage teams 

Teams feature 
 
When you subscribe to Shapr3D Pro from the website, you automatically get access to Pro features, 
including teams. 
 
With teams, you can enjoy the following benefits: 
 

● Your own team 
○ By default, your account becomes a team that you own. 
○ You can choose to use your account individually or purchase additional seats to invite team 

members to collaborate. 
● Invitations to other teams 

○ Easily join other teams with a simple email invite from team owners. 
● Collaboration 

○ With teams, you and your teammates can share projects in a single space. 
 

Important 
 
The teams feature is not available for Shapr3D Basic (free version), EDU subscriptions, and App 
Store-based subscriptions. 

 

Roles in teams 
In teams, you can either be an owner, an editor, or a contributor. 

Owner 
The owner role belongs to the account that initially signed up. All the data and intellectual property (IP) 
created within the team belong to the team owner. 
 
Team owners can: 

● Name the team 
● Manage the team’s billing and subscription 
● Add and remove seats 
● Invite and remove members 

 

Important 
 
Team owners can’t be re-assigned and there can’t be more than one team owner. 

 

Editor 
The team owner can purchase additional seats and invite members to become editors. 
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Members with an editor role can: 

● Access the full feature set of Shapr3D  
● Create or import new projects 
● Move projects across spaces and folders 
● Collaborate in the shared space 

 

Contributor 
The team owner can invite up-to 2 contributors to the team free of charge. 
 
Members with a contributor role can: 

● Access the full feature set of Shapr3D with the exception of Drafts 
● Create or import new projects to the shared space 
● Move projects across folders in the Teampace 
● Collaborate in the shared space 

Contributors have the following limitations: 

● Cannot create new projects 
● Cannot export designs 
● Only available for users on version 5.831 and later 

Important 
 
The contributor role is only available with company domains. Domains like @gmail.com, 
@outlook.com or @icloud.com are not supported. 
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Manage team members as a team owner 

Invite team members 
Team owners can add or remove members from the team directly. 
 
To add or invite a new member as a team owner: 

1. Go to your account page. 
2. Optional: If you’re a member of other teams, use the dropdown beside the team name to select the 

name of the team you own. 
3. Select Members. 
4. Select Invite members. 
5. From the Invite members pop-up, enter the email addresses of the members you want to invite. 
6. To finish, select Invite. 

 
Once a team owner adds a new member: 

● The team member gets contributor access. 
● A team member occupies one available contributor seat. 
● If all contributor seats are filled, the team owner can convert a contributor to an editor to free up a 

seat. 
● The team automatically gets charged for a new seat if all purchased seats are already assigned to a 

member 
 

If members are removed from the team: 
● The removed member’s seat will remain available 
● The empty seat is assignable until the end of the billing cycle 

Remove team members and reassign seats 
When you remove a member from your team, any projects stored in their Drafts will no longer be accessible 
to them. Before removing team members, advise them to back up or transfer any critical designs to prevent 
data loss. 
 
To remove a member: 
 

1. Select Members on your account page. 
2. Select … beside the team member you want to remove. 
3. Select Remove member. 
4. To finish, select Remove member from the prompt. 
5. To reassign the empty seats to a new member, simply Invite members again. 
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Joining a team 
 
If you’ve been invited to a team, you will receive an invitation email. Simply accept the invitation to join the 
team and start using Shapr3D right away. 
 
Note: If you can’t see the team for which you have accepted an invitation in the Shapr3D Dashboard, make 
sure to update Shapr3D to the latest version (the teams feature was first released in version 5.650). If the 
issue persists, contact our support team. 

 

Important 
 
Your team subscription is handled by the team owner who sent you the invitation. If you are 
removed from a team, any projects stored in your Drafts will no longer be accessible. Ensure that 
any critical designs are backed up or transferred before leaving the team to prevent data loss. For 
any issues or assistance with project access, contact Shapr3D Support. 

 

Team settings 
You can update team settings such as your team name in Team settings on your account page. 
 
To update your team settings: 

1. Select Team settings on your account page. 
2. Click Edit beside the setting you want to update and then make your edits. 
3. To finish, select Save. 
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Billing 
 
Team owners can manage the subscription billing information on the Shapr3D account page. 
 
To manage your billing information: 

1. Select Billing on your account page. 
2. Click Edit beside the setting you want to update and then make your edits. 
3. To finish, select Submit. 

Data ownership 
All the data and Intellectual Property (IP) created within a team belong to the owner. When a team member 
is removed, any projects stored in their Drafts will no longer be accessible to them. To prevent data loss, 
ensure that important designs are transferred or backed up before removing a member from the team. For 
any issues or assistance with project access, contact Shapr3D Support. 
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Manage your subscription 
 
You can view or update your subscription from the Subscription page in your account settings. 

View subscription information 
 
You can find your subscription type under Subscription and Purchased via. 

Purchase more seats 
To add or purchase more seats:  

1. Select Manage beside Seats. 
2. Add the number of seats you want to purchase and then select Buy seats. 
3. If prompted, enter the details for your card payment and then select Update & buy seat. 

Manage auto-renewal 
When a team owner cancels a subscription, all the team members will be automatically removed and lose 
access to the team and their projects at the end of the billing cycle. 
 
To turn on or turn off auto-renewal for your subscription: 

1. Select Manage beside Auto-renews on. 
2. Select Cancel subscription. 
3. In the pop-up box that appears, select Cancel subscription.  

 
After the cancellation, the subscription will remain active until the end of the billing cycle.  
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Getting started as a contributor in a Shapr3D team 
[Article link | Table of contents | Back | Next] 

If you’ve received an invitation to join a Shapr3D team as a contributor, here’s how to get started. 

Accept your invitation 
You’ll receive an invitation email from the team owner. To accept the invite: 

1. Open the invitation email. 
2. Select Accept invite. 
3. Sign up with the email address the invite was sent to. 
4. If you already have a Shapr3D account, just log in with your credentials. 

Important 
 
Contributor access is only available to company email addresses. Invitations sent to personal 
emails (such as @gmail.com, @icloud.com) or educational addresses (such as .edu) will not 
work. 

 

Download and install Shapr3D 
After signing up or logging in, install Shapr3D on your preferred device. To learn how, visit Download 
Shapr3D. 

Access a team you joined 
When you open Shapr3D, the Dashboard opens in your personal team by default. If you’ve joined another 
team, use the team switcher to access that team’s shared space. 

As a contributor or editor, you can view and collaborate on projects in any shared space you’re part of. 
Each team has its own spaces for shared projects and personal drafts, and access depends on your role. 

To learn more, visit Shapr3D Dashboard and Manage your personal account and team settings. 

What you can and can’t do as a contributor 
As a contributor, you can: 

● Access the full feature set of Shapr3D (excluding Drafts) 
● Open and work on projects in the shared space 
● Collaborate with other team members 

As a contributor, you can’t: 

● Create new projects 
● Export projects or drawings 
● Access Drafts 
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Note: Contributor access is only available for Shapr3D version 5.831 and later. If you don’t see the team or 
encounter access issues, make sure your Shapr3D version is up-to-date.  

 Read more 
 
To get started with Shapr3D, check out our Introducing Shapr3D basics tutorial series. 
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Shapr3D Cloud 
Cloud and storage 
[Section link | Table of contents | Back] 

Introduction to Shapr3D Cloud 
[Article link | Table of contents | Back | Next] 

Shapr3D Cloud is a set of optional cloud-based features that are automatically enabled when you sign up 
for Shapr3D. With Shapr3D Cloud, you can use features like Sync to make your project available on all 
your devices, and also provide backup by securely uploading your projects to the cloud.  

Using Shapr3D Cloud doesn’t mean that you can only access your projects while online. By default, all 
projects that you create on your device still exist locally and are exclusively tied to your account, allowing 
you to use Shapr3D and access your projects offline. 

Note: If you have Shapr3D Basic, you can only export your projects to low-resolution STL and 
low-resolution 3MF. 

Shapr3D Cloud offers the following features: 

● Shapr3D Sync and backup 
● Share Design Review Links 
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Shapr3D Sync 
[Article link | Table of contents | Back | Next] 

Shapr3D Sync is a Shapr3D Cloud feature that keeps your projects up to date and accessible across 
devices. Personal projects sync to your account, while team projects sync across all members of the team. 
All synced projects are backed up in Shapr3D Cloud and can be downloaded to work offline. Shapr3D 
Cloud ensures that your data is yours, giving you a secured solution following industry best practices. 

Shapr3D Sync is the solution you need if: 

● You want to access and edit your projects across multiple devices. With Shapr3D Sync, your 
projects are always up to date, so you can move between your desktop, tablet, or a newly set-up 
device and continue where you left off. 

● You want to collaborate in a shared team space. Team projects automatically sync across all 
team members, making it easy to stay aligned and work together in real time. 

● You want to keep a cloud backup of your projects. All synced projects are stored in Shapr3D 
Cloud, so your data stays safe even if something happens to your device. 

Using Shapr3D Sync 
To work with projects using Shapr3D Sync, keep the following in mind: 

● You need an active internet connection to sync or download project data. 
● Projects are stored in the cloud. You must be online to access any project that hasn’t been 

downloaded to your device. 
● Offline access is only available for projects that have already been downloaded. 
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Manage project storage 
Shapr3D automatically syncs your projects to Shapr3D Cloud so you can access the latest version from 
any device you’re signed in to. 

Each project can be in one of three states: 

● Local only – Stored only on your current device, not yet backed up to the cloud. 
● Synced – Stored in the cloud and also downloaded to your device for local access. 
● Cloud only – Stored in the cloud but not currently downloaded to your device. 

You can manage storage individually for each project in the Dashboard. 

To manage storage for a project: 

1. Right-click (secondary click) the project in your Dashboard. 
2. Select Download Now or Remove Download. 

○ Download Now – Saves a local copy of the project so you can open and edit it offline. 
○ Remove Download – Clears the local copy from your device to save storage space. The 

project stays safely in the cloud and can be downloaded again anytime. 

Tip 

Projects that aren’t stored on your device are still safely saved in the cloud. Just download them 
again whenever you’re ready to work. 
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Share Design Review Links 
[Article link | Table of contents | Back | Next] 

Design Review links are part of Shapr3D Cloud and allow you to share detailed, navigable views of your 
projects through a secure web link. Recipients can open the link in any modern browser to explore your 3D 
designs and 2D Drawings. 

2D and 3D compatibility 
Review links support both 3D models and 2D Drawings, giving stakeholders a complete view of your 
design. This flexibility makes it suitable for reviews and discussions at any project stage, with the added 
option to download 2D Drawings as PDFs for offline use. 

Interactive collaboration 
Team members can add comments directly to specific parts of the design. This keeps feedback focused 
and visible in one place, simplifying review cycles. 

Secure sharing 
You control who can view your review link. Set link access settings to limit visibility to your team, specific 
invitees, or anyone with the link. 

AR-ready previews 
When opened on supported mobile devices, review links allow you to preview your model in Augmented 
Reality (AR). This gives stakeholders a clearer understanding of scale and fit in real-world contexts. 

 Read more 
 
For details on how to generate and manage a Design Review link, visit Review Links. 
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Local storage 
[Article link | Table of contents | Back | Next] 

To ensure smooth cross-platform usage and that the software upgrades safely, Shapr3D stores projects in 
an internal database. While your projects are stored locally on your device and can be accessed offline, 
they are not accessible directly over the file system of your device. To use your projects in third-party 
applications, you need to export them first in one of the supported file formats 

Note: If you're using Shapr3D Basic, you can only export your projects to low-resolution STL and 
low-resolution 3MF. 

With Shapr3D Cloud, your projects are automatically backed up via Shapr3D Sync. 

 Read more 
 
To learn more, visit Shapr3D Cloud and Shapr3D Sync. 
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Shapr3D basics 
Basic navigation, keyboard shortcuts, peripherals, and managing projects 
[Section link | Table of contents | Back | Next] 

Modeling concepts 
3D modeling concepts overview 
[Subsection link | Table of contents | Next] 

3D CAD modeling concepts 
[Article link | Table of contents | Back | Next] 

Overview 
3D modeling is the process of creating three-dimensional representations of objects using 3D modeling 
software. With a 3D CAD modeling tool, you can create detailed designs with depth, visualize concepts with 
realism, and produce models for real-life simulations. 
 
CAD is a subset of 3D modeling which is a crucial component in manufacturing. If your goal is 
manufacturable designs, CAD provides a holistic design environment that allows for both 2D and 3D 
representations. The level of detail you can do with CAD modeling is essential for better collaboration, 
precise engineering, analysis, documentation, and visualization throughout the product development 
lifecycle. 
 
Shapr3D is a CAD software solution that offers a complete design workflow from ideation to manufacturable 
models. Seamlessly transition from concept to detailed 3D modeling and documentation with the help of 
these main benefits: 

● Integrated workflow. The multiplatform availability for Windows, macOS, and iPadOS, and Sync 
capabilities provide you the flexibility to work across various devices, giving you a much more 
integrated approach to your design process. 

● Offline use. Shapr3D is fully operational offline across all platforms, enabling you to work on your 
designs even without an internet connection. 

● Collaboration. Review Links are a quick and efficient way to share your concepts, making 
collaborative reviews effortless. 

● Software compatibility. Shapr3D works smoothly with other CAD tools. With its support for 
universal CAD file formats such as STEP and IGES, you can conveniently integrate your designs 
into other relevant software. 

History-Based Parametric Modeling 
CAD models are built up through a series of steps. History-Based Parametric Modeling, or Parametric 
Modeling, is a feature that provides you with the history of your model by recording the series of steps in a 
timeline or feature tree. As these steps are recorded, connections through dependencies are formed, 
allowing you to review or modify each step cohesively.  
 
In Shapr3D, you can access the history of your model through the History sidebar. As you continue to build 
your model, the history establishes a connection through dependencies and relationships between different 
features, dimensions, and constraints. With this existing connection, modifications or iterations you make to 
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any step automatically propagate through the entire history, making the iterative process much easier and 
faster. 
 
By keeping the History sidebar closed, you can use Shapr3D just as you would normally without the history 
feature. However, keep in mind that steps are still recorded in the background so if you want to use history 
later on, there might be broken connections that you would need to fix.  
 
To learn more about error messages in History, visit Error messages in History. 

Direct modeling 
Direct modeling, also known as push-and-pull modeling, is a 3D CAD method that focuses on directly 
manipulating models by pushing and pulling selected topologies of a geometry. With direct modeling, you 
can adjust geometry quickly without thinking about existing features and constraints. For example, if you 
want to increase the height or depth of a box, you can simply “pull” any of its faces upwards or sidewards. 
The same applies to cylindrical bodies or holes: just select the cylindrical faces and then adjust the 
diameter by pushing and pulling them.  
 
In Shapr3D, you can use a direct modeling approach by simply keeping the History sidebar closed. This 
approach can provide you the flexibility to make quick modifications without referring to the history timeline. 
 
For more in-depth information on direct modeling, visit How does direct modeling actually work? 
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Modeling in Shapr3D 
[Article link | Table of contents | Back | Next] 

When you model in Shapr3D, steps you create are recorded in the History sidebar – essentially providing 
you with a full-length undo and redo queue for all your actions. The History sidebar keeps a history tree 
timeline with details of the connections you create within your model. These connections can exist between 
dimensions, sketches, and bodies of your design-build history. With History, you have the flexibility to 
quickly review and make modifications to your previous edits. 
 
When you make modifications either directly on your model or from the History sidebar, the entire history 
tree automatically re-adjusts all applicable steps to keep the connection of edits you made in your model. 
To learn how to use the History sidebar, visit History. 
 
If you don’t need to change how the model was built originally, you can simply keep the History sidebar 
closed. To learn about the concepts of direct modeling, visit How does direct modeling actually work? 
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Sketching in Shapr3D 
[Article link | Table of contents | Back | Next] 

Sketching is the foundation of 3D modeling in Shapr3D. You can create precise 2D sketches that define the 
shape and structure of 3D bodies. With constraints, dimensions, and snapping options, you can accurately 
control your geometry and maintain design intent. 

Shapr3D’s sketching and modeling workflow follows familiar CAD principles while offering a more intuitive 
and streamlined experience. You can directly interact with geometry and apply constraints or dimensions as 
needed. This approach simplifies creating and modifying 3D bodies with tools like Extrude (commonly 
known as the Push/Pull method), Loft, and Revolve, allowing you to refine designs efficiently while keeping 
sketches adaptable for future modifications. 

Understanding sketch items 
Sketches in Shapr3D consist of various 2D items, including lines, arcs, circles, and splines. These items 
can be freely drawn or precisely defined using numerical input, constraints, and dimensions. 

When creating sketches, it's important to distinguish between: 

● Closed sketches – Fully enclosed shapes that can be extruded, revolved, or used as cut profiles. 
● Open sketches – Unenclosed shapes that can be used for sweeps, guide rails, or projected curves. 

Sketch constraints, dimensions, and sketch states 
Sketches in Shapr3D can be precisely controlled using constraints and dimensions. These tools help 
maintain relationships between sketch items and ensure accuracy in your designs. 

Constraints 
Constraints define geometric relationships between sketch items. They automatically adjust the sketch 
when modifications are made, maintaining consistent proportions and alignment. 
 
To learn more, visit Constraints overview. 

Dimensions 
Dimensions specify exact measurements for sketch items, such as lengths, angles, and distances. Adding 
dimensions allows you to define precise values, ensuring your sketches remain accurate and scalable. 
 
To learn more, visit Defining and calculating numerical values. 

Sketch states 
The state of a sketch indicates whether it is fully constrained or still has undefined elements.  
 
In Shapr3D, sketches can be in one of two states: 

● Fully defined: A fully-defined sketch has all its geometric relationships and dimensions constrained, 
preventing any sketch items from moving independently. The sketch remains fixed unless a 
constraint is removed, a dimension is modified, or a parameter is adjusted. 

● Under-defined: An under-defined sketch has sketch items that are not fully constrained, allowing 
them to move or change size. You can apply additional constraints and dimensions to control the 
geometry and fully define the sketch. 
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Tip 

To quickly check a sketch’s state, look at the color of the sketch items. Green means fully defined, 
while blue means under-defined. 

Sketching workflow 
When sketching in Shapr3D, follow these general steps: 

1. Select a sketch plane or face to draw on. 
2. Use sketch tools like Line, Circle, or Spline to create the desired geometry. 
3. Apply constraints and dimensions to define relationships. 

Tip 

You can create sketches with varying levels of definition, but fully defining them ensures stability 
and predictable parametric behavior when making adjustments. 

Using sketches to create 3D bodies 
Once a sketch is complete, you can turn it into a 3D body using Shapr3D’s modeling tools. For example, 
use Extrude to add depth to a shape, or use Revolve to create cylindrical or spherical shapes, such as 
bottle bodies, shafts, or rounded enclosures. 
Sketches also play a key role in more complex workflows: 

● Loft and Sweep: Use sketches as profiles and guide curves to create smooth, organic shapes for 
ergonomic grips or fluid containers. 

● Offset and Projection: Generate precise outlines by offsetting existing sketches or projecting 
edges onto new planes. 

● Cutouts and Details: Create cut features like vent openings, custom engravings, or embossed text 
directly from sketches. 

● Construction Geometry: Use sketches to define centerlines, reference curves, or alignment guides 
for precise feature placement. 

To learn more about the available Shapr3D tools for creating 3D bodies, visit the Tools menu. 
 

Learn more 
 
If you're new to Shapr3D, check out our video tutorials to see sketching in action. 
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Navigation 
Dashboard, Items Manager, and managing projects 
[Subsection link | Table of contents | Next | Back ] 

Shapr3D Dashboard 
[Article link | Table of contents | Back | Next] 

The Shapr3D Dashboard is the default screen of Shapr3D.  

In the Dashboard, you can: 

● Create, organize, and open projects 
● View recent Shapr3D updates 
● Switch between teams  
● Access learning content  
● Access Shapr3D settings 

Dashboard sidebar 
You can find the Dashboard sidebar at the left side of the Dashboard.  

Team name and switcher 
The team name displays the team dashboard you’re currently in. If you’re a member of multiple teams, you 
can only view the projects from the team currently selected in the sidebar. 

 

Tip 
 
To use the full feature of teams, make sure to enable Shapr3D Sync. 

 
To switch between different teams: 

1. Select the arrow beside the team name. 
2. Select the team name you want to switch to. 

 

Invite members 
Under the team name, you can click Invite Members... to start inviting members to your team. To learn 
more, visit Manage your personal account and team settings. 

Recents 
 
Under Recents, you can find the following: 

● What’s New? – Displays teasers of new features, tutorials, demos, and workflows by industry 
experts. 

● Recent Projects – Where you can easily find and open your most recent projects. 
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Review Links 
Click Review Links on the Dashboard to open the Review Links page in your account. Here you can see a 
list of all your projects with published links, copy or open a link, or unpublish it when you no longer want to 
share it. 
 
To learn more, visit Review Links. 
 

Spaces 
 
Under Spaces, you can find the library of your shared projects and drafts.  

Shared space 

Spaces are built for work and collaboration. You can name your space, organize folders, or invite others to 
create a shared project library. 

In a shared space: 

● The number of members is shown under the space name. 
● Everyone can view and edit projects. 
● Folders or projects moved into the shared space automatically sync across all team member’s 

accounts and devices. 
● Only you will retain access to a project moved to your drafts. 
● You can import your active team projects, team archive, part library, and more to the shared space 

to share with your colleagues. 

 

 Tip 
 
Projects should be opened by one person at a time. Opening a project simultaneously from two 
different devices or accounts is not recommended because it may introduce Sync conflicts. 

 

Drafts 

You can use Drafts to keep early ideas or personal work separate. 

In Drafts: 

● Only you retain access to a project moved to Drafts. 
● You can create your own projects and move ongoing projects to and from your shared space. 
● Your projects aren’t visible to your colleagues and only sync within your own devices. 
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Learn 

From the Dashboard sidebar, you can access the following: 

● Tutorials – Watch tutorials to hone your Shapr3D skills. These videos range in level of expertise, 
from beginner to advanced, so there’s something for everyone. 

● Workflows – Learn about the workflows of featured CAD professionals.  
● Stories – Check out how other Shapr3D users are implementing Shapr3D in their projects and 

workflows. 
● Manual – Directly access Shapr3D Manual to quickly search for detailed instructions and 

information. 
● Forum – Access Shapr3D Community to interact with other users and the Shapr3D team. Ask any 

questions you might have, help other users, or even share your projects. 
Note: You need to sign up for an account to create posts and leave comments in Shapr3D 
Community. 

● Settings (iPadOS and Windows only) – Manage your account details, subscription plans, and 
preferences. You can find more details in Settings or Preferences. 

Dashboard top bar 
You can create, import, and organize your projects from the top bar. To learn more, visit Manage your 
projects. 

 Read more 
 
To learn how to manage your personal account or team settings, visit Manage your personal 
account and team settings. 
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Shapr3D modeling space 
[Article link | Table of contents | Back | Next] 

This is your guide to the Shapr3D modeling space user interface.  
 
In the modeling space, you can find the following areas: 

● Top bar navigation 
● Sidebars 
● Main menu and Command Search 
● Modes 
● Views and snapping 

 
Windows 
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iPad 
 

 
 
Mac 
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Top bar navigation 
The top bar navigation is where you can access most settings and basic controls. From left to right, you can 
find the following: 

● Back to Dashboard (Windows)  – Brings you back to the Dashboard. 
● Home (iPadOS/macOS) – Brings you back to the Dashboard. 
● Project name and Sync – Where you can find and rename your project name and access Sync. 
● File menu – Opens the basic file commands such as New project, New Drawing…, and Export 

to… 
● Edit menu – Opens the basic edit commands such as Undo, Redo, Select all, Deselect all. 
● View menu – Opens the basic view commands related to your grid position field of view, and more. 
● Help menu – Opens the basic help settings such as keyboard shortcuts, tutorial videos, and link to 

Shapr3D Manual and Shapr3D Community. 

● Undo  – Shortcut to the Undo command, where you can revert your previous interaction.  

● Redo  – Shortcut to the Redo command, where you can redo your previous interaction.  

● Share  – Has a Share tab where you can create a Review Link that you can share with anyone, 
and an Export tab where you can export your projects. 

● Help  – Shortcut to the Help menu. 

● More Settings  – Contains the options for Import, Export, and Settings. 
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Sidebars 
The sidebars section is where you can access the Project Sidebar and Items Manager. The Project Sidebar 
is where you can easily jump between the different spaces and access relevant shortcuts. 

● Modeling  – What you see while in the modeling space. This opens the project sidebar where 
you can easily navigate between the modeling, Visualization, and 2D Drawings space. 

● Visualization  –  What you see while in the Visualization space. This opens the project sidebar 
where you can easily navigate between the modeling, Visualization, and 2D Drawings space. 

● Drawings  – What you see while in the 2D Drawings space. This opens the project sidebar 
where you can easily navigate between the modeling, Visualization, and 2D Drawings space. 

● Items  – Shows the Items Manager. 

Main menu and Command Search 
 
The main menu displays the Command Search and modeling tools. In the default state, only the icons are 
visible and depending on your preferred setting, you can hover your mouse over the icons to see their 
names. 
 
From top to bottom, you can find the following: 

● Search  – Opens the command search box. 

● Sketch  – Opens the sketch and constraint tools menu. To learn more about each sketch or 
constraint tool, visit Sketch menu. 

● Add  – Opens the add menu. To learn more about each tool, visit Add menu. 

● Transform   – Opens the transform menu. To learn more about each tool, visit Transform menu. 

● Tools   – Opens the tools menu. To learn more about each tool, visit Tools menu. 

Modes 
 
The selection-based mode area is where you can find modes that you can turn on or turn off. The menus in 
this area adapt to your selection so it only shows you the relevant modes that you need. 
 

● Section View  – Turns on and turns off Section View. 

● Isolate  – Turns on and turns off Isolate Mode. This mode is visible while using Items Manager 
and other relevant tools. 

● Measure  – Turns on Measure Mode where you can select items to measure. 
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Views and snapping 

● Orientation Cube – A quick way to navigate the orientation view of your project. To learn 
more, visit Orientation Cube. 

● Snaps / Guides  – Opens the snapping options for the grid, guide lines, and guide points. 

● Units  – The place to set your desired unit, lock your grid, and customize specific format settings 
with inches and degrees. This # icon also displays the current grid resolution of your modeling 
space, which changes according to the level of zoom. 
Note: For macOS, you can lock your grid from the View menu in the Mac menu bar. 

● Views/Appearance  – Opens Views and Appearance.  
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Items Manager 
[Article link | Table of contents | Back | Next] 

The Items Manager lists all items within a project and provides several functions that can keep your project 
organized and help you make selections.  

● Accessing the Items Manager 
● Items Manager icons and structure 
● Items Manager Functions 

Accessing the Items Manager 

From the sidebars, select Items  to show or hide the Items Manager. 

Items Manager icons and structure 
Every sketch, body, plane, axis, image, and 2D Drawing you create in your project is defined as an item 
and is listed in the Items Manager. You can quickly identify the different types of items in the Items 
Manager panel by the icons displayed next to the item name. See the table below for more information on 
the icons used in the Items Manager. 

  Body  

  Sketch plane  

  Construction Pplane or axis  

  MeshConstruction axis  

  Image  

  Folder  
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Items Manager functions 
In the Items Manager, you can:  

● Make selections 
● Adjust image opacity 
● Create and use folders 
● Rename an item 
● Hide/show items 
● Zoom to an item 
● Delete an item 

Make selections 

The Items Manager is another option to make selections in your project. You can define a selection set in 
the Items Manager panel and launch tools from the adaptive menu. To make selections easier, you can 
filter items in the Items Manager by selecting All Items at the top and choosing an item type. 

 Tip 
 
If you’re using a keyboard and mouse/trackpad, hold the CTRL or Command key to select more 
than one item or press the Shift key to select a range. For more information on making selections 
in Shapr3D, visit Selecting geometry. 

 

Adjust image opacity 

You can adjust the opacity of an image from the Items Manager by clicking or tapping the percentage value 
beside the image to open the Opacity slider. Use this slider to adjust the transparency of the image. 

Create and use folders 

You can create folders in the Items Manager to organize your projects and group together selection sets. 

To create a folder, select  at the bottom of the Items Manager. 

Once a folder is created, you can add items to the folder using drag and drop. 

Rename an item 

You can rename an item from the Items Manager by tapping and holding an item with a pen or secondary 
clicking (right-clicking) with a pointer to an item, then selecting Rename. 
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Hide/show items 

Each item in the Items Manager has a Visibility icon that can be toggled to identify and control the 

visibility of project elements. Select  to hide an item or  to show an item.  

 Tip 
 
You can select the Visibility icon of folders to change the visibility of all items within a folder. 

 

Zoom to an item 

You can zoom to an item from the Items Manager by tapping and holding an item with a pen or secondary 
clicking (right-clicking) with a pointer to an item, then selecting Zoom to (iPadOS or macOS) or Zoom to 
Selection (Windows). 

Delete an item 
You can rename an item from the Items Manager by tapping and holding an item with a pen or secondary 
clicking (right-clicking) with a pointer to an item, then selecting Delete. 

Reveal specific items in the sidebar 

You can use Reveal in Items to quickly locate a part of your model in the Items sidebar. 

Right-click (secondary click) a part of your model in the modeling space, then select Reveal in Items to 
highlight it in the sidebar. 

Visibility options 

Click the three dots at the bottom right corner of the Items sidebar to access visibility controls:  

● Show Hidden Items – Display all currently hidden items. 
● Invert All Item Visibility – Swap visibility states: shown items become hidden, and hidden items 

become visible. 
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History 
[Article link | Table of contents | Back | Next] 

The History sidebar provides you with the complete feature tree timeline of all edits you make to your 
model. The timeline consists of individual steps that are recorded every time you make an edit. Each step 
represents a feature or action with an expandable card that allows you to view or edit the corresponding 
parameters you defined. 
 

Explore the History sidebar 
To show or hide the History sidebar, tap History . 
 
Each recorded step has an expandable card to view the parameters you previously defined. To expand a 
history card, click/tap the arrow beside the step. 

History step settings 
You can hover over a step and select the three dots to access the step settings. The step settings give you 
the option to do the following: 

● Insert Breakpoint – Adds a breakpoint after the step. Steps after the breakpoint are temporarily 
disabled and will not be visible on your model. To remove a breakpoint, simply hover over the 
breakpoint and then select the X. 

● Suppress/Unsuppress – Suppressing a step hides the step from the history and removes it from 
your design-build history while unsuppressing a step adds the step back to your model history. 
Suppressing and unsuppressing a step is useful for instances where you want to remove a step you 
created but don’t want to temporarily delete it. 

● Zoom To – Zooms to the part of your model where you performed the specific step. 
● Rename – Updates the step name. 
● Duplicate – Duplicates the step. 
● Delete – Deletes the step. 
● Expand/Collapse – Another way to expand or collapse the history card. 
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History card parameters 
You can view or modify parameters you defined for relevant steps in their equivalent History card. 

Below are some examples of parameters you can find in the history card for Extrude, Fillet, and, Chamfer: 

Extrude 

 

Fillet 
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Chamfer 

 
 

Filter History steps 
With the design history, all your modeling steps are recorded so you can always get back and modify the 
right step. As your model gets more and more complex, finding the step to edit may take some time. To 
help with that, you can filter steps for isolated or selected items in the History sidebar. 
 

Filter by: Isolated Items 
When you filter by isolated items, the History sidebar automatically filters the history, so only those steps 
will be shown that are relevant to the isolated items. 
 
To filter items by isolation: 

1. Select any part of your model. 
2. Turn on Isolate mode. 

 

Filter by: Related to selection 
To find a step of a certain detail on your model, simply select the detail on your model. 
 
Once you select the detail on your model, Shapr3D will only show those steps that are relevant to your 
current selection. When you filter by selection, the History sidebar automatically filters out the unrelated 
items for your selection. 
 
To filter items by selection, simply select any part of your model. 
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Merge History steps 
 
You can merge the history steps for your model using the Merge option. By merging history steps: 

● All your sketches unlink or break their connections from bodies. 
● You combine all previous steps and delete all steps before and after the breakpoint. 
● You have the option to delete or keep sketches 

 

Important 
 
You cannot recover merged history steps once you quit your project. 

 
To merge history steps: 

1. Open History. 
2. From the History sidebar, select History. 
3. Choose what you want to happen to your sketches after merging: 

● Delete sketches – Deletes your sketches after merging. 
● Keep sketches – Keeps your sketches after merging. 

4. To finish, select Merge. 

Learn more by watching the video below: 

https://youtu.be/rmmizsmc1Hk 
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Manage projects and folders 
[Article link | Table of contents | Back | Next] 

You can access and organize your projects from two main sections in the  Shapr3D Dashboard: Recents 
and Spaces. Use these sections to browse, open, rename, move, and manage your designs and folders. 

Access your projects 
You can open any project directly from the Recents or Spaces section in the Shapr3D Dashboard. Just 
select the project tile to load it in the modeling space. 

Browse your projects 
Projects are shown as tiles across Spaces, Recents, and any organized folders. These tiles give you a 
quick overview of key details at a glance: 

● Preview – A thumbnail image of your model for easy identification 
● Title – The name of the project 
● Last edited by – The name of the last team member in a shared space who edited the design and 

the time of the last update 
● Storage status – A cloud icon appears if the project is stored only in the cloud. If the icon isn’t 

visible, the project is available locally on your device. 

Manage your projects 

Recent projects 

The Recent Projects under Recents shows your most recently opened or modified projects across all 
spaces. From here, you can right-click (secondary click) a project to: 

● Open the project 
● Rename the project 
● Manage storage location 
● Show project versions 
● Export the project 

For more advanced actions like organizing projects into folders or restoring project versions, switch to the 
Spaces view. 

Spaces 

Under Spaces, you can find the library of your shared projects and drafts. 

Create a new project 

You can create a new project directly from your shared space or Drafts. 

To create a new project: 

1. Go to the space you want to create a project from. 
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2. From the top bar, select New  . 

Import a new project 

To import a project into any space: 

1. Go to the space where you want to import a  project. 

2. From the top bar, select   or . 

Manage project storage location 

Choose to store your project locally or in the cloud. To learn more, visit Shapr3D Sync. 

Rename a project or space 

To rename a project: 

1. Secondary click (right-click) or long-tap on a project or folder. 
2. Select Rename. 

To rename your space: 

1. Right-click (secondary click) or long-tap on your space. 
2. Select Rename Space... 

Selecting projects 

You can select projects in the Dashboard to manage them individually or in groups.  
 
Selecting a project 

To work with a single project, select it and open the context menu: 

● Windows: Right-click on the project. 
● iPadOS: Tap and hold the project. 
● macOS: Secondary click on the project. 

Selecting multiple projects 

To manage multiple projects, select them first, then open the context menu for batch actions: 

● Windows: Click   to select the projects, then right-click to open the context menu. 
● iPadOS: Tap Select to choose the projects, then tap and hold to open the context menu. 
● macOS: On your keyboard, press and hold Shift to choose the projects, then secondary click to 

open the context menu. 

Duplicate a project 

To duplicate a project: 

1. Secondary click (right-click) or long-tap on a project or folder. 
2. Tap Select or  to select multiple projects and then select Duplicate. 
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Restore project versions 

You can view or restore previous versions of your projects by right-clicking on a project and selecting Show 
Versions. To learn more, visit Project Versions. 

Quick export to your favorite formats 

Effortlessly export your projects to your favorite formats using the Quick Export option in the Dashboard. 
With this feature, you can select multiple projects and export them all at once, making your workflow 
smoother and more efficient. 

To export your projects to your favorite formats: 

1. Select the project(s) to export. 
2. Right-click (secondary click) or long-tap on any of your selected projects. 
3. Select Quick Export to Favorite Formats. 
4. Select a folder or location to save your projects. 

Export a project to .shapr file 

To export a project to a .shapr file: 

1. Select the project(s) to export. 
2. Select Save as .shapr file.  
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Create and manage folders 

You can create folders under any of the available spaces to organize your projects more easily. You can 
find your created folders in both the main Dashboard and Dashboard sidebar. 

To create a new folder: 

1. Select New folder  in the top-right.  
2. When prompted, enter a folder name and then select Create. 

To organize projects and folders into other spaces or folders, do any of the following: 

● Drag and drop projects or folders from either the main Dashboard or Dashboard sidebar within or 
across the available spaces. 

● Secondary click (right-click) on projects and folders and then select New Folder with Selection to 
automatically move them into a new folder. 

Folder navigation 

You can navigate between folders and subfolders using any of the following options: 

● Directly from the Dashboard sidebar 
● By using the navigation arrows for iPadOS and macOS 
● By using the breadcrumbs for Windows to navigate 

To navigate between folders: 
 

● Windows: From the breadcrumb trail at the top, click a folder or subfolder name to go back to its 
location. 

● iPadOS/macOS: Click or tap any of the back or next arrow keys at the top to go to the next or 
previous folder location. 

Sort projects 

To sort projects within a space, click/tap Sort  from the top bar and then choose a sorting type: 

Windows: 

● Date modified – Sorts projects by date.  
● Name – Sorts projects by name.  
● Ascending – If Date modified is selected, projects and folders sort in ascending order. 
● Descending – If Name is selected, projects and folders  sort in descending order. 

iPadOS/macOS: 

● Date Modified (Latest to Oldest) – Sorts projects by date in descending order.  
● Date Modified (Oldest to Latest) – Sorts projects by date in ascending order.  
● Name (A to Z) – Sorts projects and folders by name in ascending order.  
● Name (Z to A) – Sorts projects and folders by name in descending order. 

 

64 



 

Delete a folder or project 

Secondary click (right-click) or long-tap on a project or folder, or tap Select or  to select multiple 
projects and then select Delete. 

Important 
 
All projects are automatically synced to the cloud. When you delete a project, it’s removed from all 
devices and can’t be recovered. To keep a backup, export the project before deleting. 
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Project Versions 
[Article link | Table of contents | Back | Next] 

The Project Versions feature in Shapr3D tracks and restores previous versions of your projects, ensuring 
no work is lost. Whether recovering from accidental changes or comparing different design stages, this 
feature provides control over your project’s revisions. 

Feature overview 
Project Versions offer several benefits that help you manage your project revisions efficiently: 

● Project safety: Restore previous versions of your project with ease, protecting your work from 
accidental changes. 

● Flexibility: Switch between versions to compare different stages of your design process. 
● Simple navigation: Access your version history directly from the dashboard, making it easy to 

manage backups. 

Access Project Versions 
To access a project’s previous version: 
 

1. Go to the Dashboard. 
2. Under the Recents or Spaces, long-tap or right-click (secondary click) on the project for which you 

want to access the versions. 
3. From the context menu, select Show Versions to open the Project Versions pop-up. 
4. Scroll down to browse through the available versions and check the version information in the 

Information section. 
● Version: The version number in the list 
● Copy of: Shows the original version number if this version was restored from a previous one 
● Edited by: The user who made changes in that version 
● Version created: The date and time the version was saved 
● Synced: Indicates if the version is synced to Shapr3D Cloud 
● Client: The device or platform where the version was created or edited 

Restore to a previous version 
To restore to a previous version: 

1. Open Project Versions for your project. 
2. Browse through the available versions and select the one you want to restore as the latest.  
3. To continue, select Restore as Latest. 
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Share project details to your team 
[Article link | Table of contents | Back | Next] 

Collaborate more effectively by sharing project details with your team through a simple link. Team members 
can view project information, download the file, or open it directly in Shapr3D from their browser. 

How to share a project 

From the modeling space 

1. Open your project in the modeling space. 
2. Select Share. 
3. In the Share dialog, locate the Share this Project section. 
4. Choose to either copy the link directly or share via messaging platforms. 

From the Dashboard 

To generate and share a link to your project details: 

1. Go to the Shapr3D Dashboard. 
2. Right-click (secondary click) on a project to share. 
3. Select Copy Link from the context menu to copy the link to your clipboard. 
4. Share the link into your team’s preferred communication tool. 

What your team can do with the link 
When you share a link to your project details, team members with permissions can view the project 
information through their browser. 

Team members with permission can: 

● View the project information – See project details and preview the design thumbnail 
● Download the design file – Save the project as a .shapr file to their device 
● Open directly in Shapr3D – Launch the project in Shapr3D for viewing or editing 
● Access the Review Link – Open the review link if available for the project 
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General settings 
Settings, peripherals, and accessories 
[Subsection link | Table of contents | Back | Next] 

Navigation Presets 
[Article link | Table of contents | Back | Next] 

You can change your Shapr3D navigation shortcuts in Navigation Presets. Choose from the different 
presets available and find the best one according to your preference.  

Access Navigation Presets 
To access your navigation presets: 

1. Go to Settings or Preferences. 
○ iPadOS: Select Navigation Preset 
○ macOS: Select Navigation Presets... 
○ Windows: Select Navigation Presets… 

2. Select your preferred preset under Shapr3D Presets or choose among the available CAD software 
presets under Popular Presets. 
Note: iPadOS only supports Shapr3D Default and Shapr3D Classic. 

3. To save the changes, select Apply (macOS) or Apply preset (Windows). 

Shapr3D presets 
Below is a list of all presets available in Shapr3D. 

Recommended 

● Shapr3D Default 
● Shapr3D Classic 

Popular presets (macOS and Windows only) 

● 3ds Max 
● AutoCAD 
● Blender 
● Cinema 4D 
● Fusion 360 
● Lego Studio 
● OnShape 
● Rhino 
● SketchUp 
● SolidWorks 
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Settings or Preferences 
[Article link | Table of contents | Back | Next] 

Settings or Preferences is where you can view your Shapr3D software version and set up or update your 
preferred settings for Shapr3D such as account settings, navigation preferences, and Sync. 

Access Settings or Preferences 
● Windows: 

○ From the Dashboard, select Settings. 
○ From the modeling space, go to File > Settings. 

● iPadOS: Tap the Settings icon at the bottom of your screen 
● macOS: To access Preferences, go to the Mac menu bar > Shapr3D > Settings...  

Shapr3D settings 
You can access the following settings: 

Note: The setting location or placement may vary depending on your device. 

Account settings 

● Email Address – Shows the email address logged in to Shapr3D. 
● Log Out – Logs you out of Shapr3D. 
● Manage Subscription – Redirects you to the Shapr3D Subscription page in your browser. 
● Restore Subscription – Restores your previous subscription. 

General settings 

● Language – Choose your preferred supported language. 
● Theme – Choose your preferred theme: System, Light, Dark. 

○ Always – Menu labels are always displayed. 
○ On Hover, On All Buttons – The menu labels only display upon hovering your pointer. 
○ Only for Hovered Buttons (Windows) – Only the hovered button displays the menu label. 

● Accent color – Choose your preferred accent color. 
● Undo/Redo Button Position (Windows) – Choose Title Bar or Bottom Bar as your preferred 

placement for the Undo and Redo buttons. 
● Interface (iPadOS) – Choose between Left or Right to switch the placement of the menus and 

tools to the left-hand or right-hand side of your screen. 
● Single Key Action 

○ Command Search – Uses Command Search as your single key action. 
○ Hotkeys – Uses Hotkeys as your single key action. 
○ Customize keyboard shortcuts – Opens the Keyboard Shortcuts settings. 

● Keyboard Shortcuts (macOS) – Select Customize… to open the keyboard shortcuts settings. 
● Selection Extension (macOS) – Choose whether you need to hold Shift to select multiple items. 

When disabled, each click adds to your selection automatically. 
● Rendering Quality (macOS) or Resolution (Windows) – Controls the overall visual fidelity when 

displaying models in both Modeling and Visualization spaces. Choose High, Medium, or Low to 
balance image quality and performance. 

● Tessellation Quality – Adjusts how detailed mesh surfaces appear when displayed or exported. 
Choose from Very High, High (default), or Low to balance visual smoothness and performance. 
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● Circular Annotations – Choose between Always Radius or Radius and Diameter as your 

preferred annotation for circular sketches and geometry. 
Note for Windows: You can change your circular annotation settings from Views and Appearance. 

Graphics  

● Anti-Aliasing (Windows) – Control how edges are smoothed in the workspace. Choose from 
Disabled, 2× MSAA, or 4× MSAA to balance visual quality and performance.  

● Rendering Quality (macOS) or Resolution (Windows) – Controls the overall visual fidelity when 
displaying models in both Modeling and Visualization spaces. Choose High, Medium, or Low to 
balance image quality and performance. 

● Tessellation Quality – Adjusts how detailed mesh surfaces appear when displayed or exported. 
Choose from Very High, High (default), or Low to balance visual smoothness and performance. 

Navigation settings 

● Navigation Presets – Opens Navigation Presets. 
● 2-Finger Rotation (iPadOS) – Toggle to enable or disable 2-Finger Rotation.  
● Zoom or Reverse Zoom Scroll Direction – Toggle to enable reverse zoom scroll direction. 

Note: If you're using a keyboard, visit Navigation Presets for more navigation controls. 
● Start Shapr3D with – Select the screen that appears when you launch Shapr3D: Recents, 

Projects. 
● Tutorial mode (macOS and Windows) 

○ Display clicks – Enable to display pointer clicks while modeling. 
○ Display keyboard presses – Enable to display keyboard presses while modeling. 

Note: Refer to Other settings below to learn how to use tutorial mode on iPadOS. 

Sync settings 

● Sync Projects – Shows you the status of when your project was last synced. You can select this 
option to manually sync your projects. 

About 

● App Version – Check your software version. 
● Terms of Use – Access the Shapr3D Terms of Use. 
● Privacy Policy – Access the Shapr3D Privacy Policy. 
● Data Setting – Open to enable or disable Send Usage Data. 

Account Deletion settings 

● Delete Account and Projects – Deletes your account and projects. 
Warning: This action cannot be undone. Once prompted, you will lose every project you worked on 
in Shapr3D. 

Other settings (iPadOS only) 

For iPaOS, open the system Settings, and find Shapr3D in the list of installed applications to access these 
additional settings: 

● Allow Shapr3D to Access – Enables access to specific device settings such as photos and 
camera. 

● Preferred Language – Another way to choose your preferred supported language. 
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● Tutorial Mode – Enables Display Pencil and touches and Display keyboard presses. Restart 

Shapr3D for these changes to apply. 
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Peripherals and accessories 
[Article link | Table of contents | Back | Next] 

You can use peripherals and accessories compatible with Shapr3D to enhance your modeling experience. 

Explore the list of compatible peripherals and accessories below to learn how to set up and configure them. 

● SpaceMouse 
● Wacom pen tablets and display 

SpaceMouse 
SpaceMouse by 3Dconnexion allows you to navigate effectively in 3D space and run various commands in 
Shapr3D. 

Windows 

To use SpaceMouse with your device: 

1. Go to 3Dconnexion’s website and download the latest version of 3Dconnexion’s driver, 3DxWare64 
or 3DxWare32. 

2. Install the driver. 
3. Once the 3Dconnexion Home program automatically opens after installing the driver, plug your 

SpaceMouse into the computer via the USB cable.  
Note: If you’re using the wireless SpaceMouse, connect the dedicated receiver and launch the 
pairing tool in the 3Dconnexion Home program. For more information on pairing the wireless 3D 
mouse, visit How do I pair a dedicated receiver with my wireless SpaceMouse?. 

4. Verify that the device works correctly using the test application installed by the driver. 
5. Optional: While using Shapr3D, you can change the navigation mode of your SpaceMouse in the 

Views tab under Views and Appearance. 
 
Note: For more information on SpaceMouse navigation modes, refer to the SpaceMouse manual. 

macOS 

To use SpaceMouse with your device: 

1. Go to 3Dconnexion’s website and download the latest version of 3Dconnexion’s driver. 
2. Install the driver. 
3. Once the 3Dconnexion Home program automatically opens after installing the driver, restart your 

Mac. 
4. Plug your SpaceMouse into the computer via the USB cable.  

Note: If you’re using the wireless SpaceMouse, connect the dedicated receiver and launch the 
pairing tool in the 3Dconnexion Home program. For more information on pairing the wireless 3D 
mouse, visit How do I pair a dedicated receiver with my wireless SpaceMouse?. 

5. Allow the program to control your Mac in any of the following ways: 
● From the Accessibility Access dialog – If this dialog automatically appears after 

connecting SpaceMouse to your computer, click Open System Preferences, then select 
3DconnexionHelper. 

● From the Mac System Settings – Go to System Settings > Privacy & Security > 
Accessibility. Look for 3DconnexionHelper, then enable it to allow access.  
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Note: To learn more about Mac system settings, visit Allow accessibility apps to access your 
Mac. 

6. You can reconfigure the mapping and view command names for Shapr3D by going to your Mac 
System Settings > 3Dconnexion, or opening 3Dconnexion Home then selecting Properties.  
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Wacom pen tablets and displays 
The compatibility of Shapr3D with digital pen input makes it a great match for Wacom devices. 

Choosing your Wacom device 

Wacom devices can be split into the following two categories: 

● Pen displays feature a built-in screen, and are sold under the brand names “Wacom One” and 
“Cintiq.” 

● Pen tablets are screenless, and are sold under brand names such as “One by Wacom” and 
“Intuos.” 

There are advantages and disadvantages to both. Pen displays are less portable and more expensive, 
while using a pen tablet takes some getting used to, as you need to look at a separate screen. 

Shapr3D works with both types of devices, but we recommend devices with a built-in screen, as they 
are more intuitive to use. 

Touch or no touch 

Wacom sells both pen displays and screen-less pen tablets with multi-touch support in addition to pen 
input. 

At the moment, we only support multi-touch input for view navigation on pen displays, but not on pen 
tablets. While you can rely on the built-in and customizable shortcuts that the Wacom driver provides for 
pen tablets, you can’t navigate the 3D space with touch input as you would on iPad. 

For the best experience, we recommend touch-enabled pen displays, but Shapr3D works without touch 
input as well. 

Which pen to use 

You can get started with the pen that was shipped with your Wacom device. For the best experience, 
a pen specifically designed for 3D applications is recommended, such as the Pro Pen 3D. Notably, its 
additional button allows you to navigate in 3D space using your pen only, which many users find more 
convenient than using keyboard shortcuts together with pen gestures. 

Navigation 

If you have a touch-enabled pen display, you can navigate in 3D space using touch gestures, the same way 
you’d navigate on an iPadOS or a Windows device with a built-in touchscreen. If you have a screenless pen 
tablet or a pen display that has no touch input, view navigation happens with the pen. 

Navigation with keyboard 

With the default settings, you can navigate the 3D space using a combination of keypresses and either 
hovering your pen over the tablet, or touching and dragging it over the surface. You can use the following 
modifiers: 

● Shift: Tumble (also called Orbit) 
● Ctrl: Pan 
● Alt: Zoom in 3D space 
● Space: Focus the view on the face under the pointer  
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Note: The Shapr3D onboarding tutorial teaches you these gestures when you get started. To revisit the 
tutorial, go to the Dashboard > Tutorials > Redo the Basics. 

To learn more about pen navigation and how to configure your Wacom device, visit this Setting Up Your 
Wacom Tablet for Shapr3D Modeling. 
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Views and snapping 
Views, appearance, and snapping options 
[Subsection link | Table of contents | Back | Next] 

Views and Appearance 
[Article link | Table of contents | Back | Next] 

You can access the View and Appearance  tabs to update your preferred view and appearance 
settings for your modeling space such as grid position, projection, and surface analysis, and save up to 
eight orientation views for quick access.  

To access the view and appearance settings: 

● Windows: Select  to access the Views and Appearance tab settings or select View from the 
menu bar. 

● iPadOS: Select  to access the Views and Appearance tab settings. 

● macOS: Select  to access the Views and Appearance tab settings or select View from the 
menu bar. 

Views 
● Default View – Select to reset your view. 
● Views – Select between Top, Bottom, Front, Back, Right, and Left as your preferred plane during 

2D modeling. 
Note: You can also use the Orientation Cube to choose a plane or reset your view. 

● Saved views – Save up to eight of your orientation views to easily get back to a specific view of 
your mode. 

○ To save a view, hover over any of the available views and then select Save. 
○ To update or replace a saved view, right-click (secondary click) on the view you want to 

replace and then select Update. 
○ To delete a view, right-click (secondary click) on the view you want to replace and then select 

Delete. 
● Grid Position – Choose between XY Plane, YZ Plane, and ZX Plane as your preferred planar 

orientation. 
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Appearance 
● Field of view – Fine-tune your view or projection by selecting your preference on a scale of 0 

(orthographic) to 90 (perspective) degrees. 
● Show Hidden Edges – Toggle to enable or disable hidden edges. This setting makes the bodies 

transparent, and highlights and selects their edges. This is useful if you have a complex geometry 
and you want to see what’s “inside.” 

● 2-Finger Rotation – Enable this option to use two fingers to rotate your view without moving the 
position of the camera. 

● Circular Annotations (Windows only) – Choose between Always Radius or Radius and 
Diameter as your preferred annotation for circular sketches and geometry. 
Note: To change circular annotations for iPadOS and macOS devices, go to Settings or 
Preferences. 

● Surface Analysis – Toggle to Show Zebra. When zebra is enabled, you can see how the surfaces 
meet and determine the surface continuity (G0, G1, and G2). Under Direction, you can specify 
whether the stripes should be horizontal or vertical. 

Additional View options for desktop 
For macOS and Windows, you can access additional view options from the View menu in the menu bar. 
The additional options available depend on your device and the space you are currently in. 

● Show Properties Sidebar – Show or hide sidebar properties for the space you are currently in 
○ Modeling space – Shows History sidebar 
○ Visualization space – Shows Properties sidebar for Visualization settings 
○ Drawings space –  Shows Properties. 

● Material Properties – Select to open the Material tab when in Visualization space. 
● Environment Properties – Select to open the Environment tab when in Visualization space. 
● Camera Properties – Select to open the Camera tab when in Visualization space. 
● Drawing Properties – Select to open the Drawing properties sidebar when in Drawings space 
● Go to Modeling – Go back to modeling space when in Visualization or Drawing space. 
● Collapse All – Collapses the expanded items in the Items Manager and steps  in the History 

sidebar. 
● Rotate View – Rotates the camera view in fixed angle increments. 
● SpaceMouse Settings – Opens settings for a connected SpaceMouse. 
● Show Items Sidebar – Shows or hides Items sidebar. 
● Show Measurements – Turns on or turns off Measure mode. 
● Enter Full Screen – Expands Shapr3D to full screen. 
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Orientation Cube 
[Article link| Table of contents | Back | Next] 

The Orientation Cube is a tool that lets you manually navigate around the modeling space while giving you 
a real-time view of your current orientation. Each face of the cube represents the sides of the planar 
surfaces which makes it useful for 2D modeling. 

Design interface 
 
The design of the Orientation Cube consists of the following: 

● Axes – Has X, Y, and Z axes identical to the modeling space.  
● Face – There are six faces: Top, Bottom, Front, Back, Right, and Left. 
● Corners – There are eight corners:  

○ Top/Front/Right 
○ Top/Right/Back 
○ Top/Back/Left 
○ Top/Left/Front 
○ Front/Right/Bottom 
○ Right/Back/Bottom 
○ Back/Left/Bottom 
○ Left/Front/Bottom 

● Edges – There are 12 edges:  
○ Top/Front 
○ Top/Right 
○ Top/Back 
○ Top/Left 
○ Right/Back 
○ Back/Left 
○ Left/Front 
○ Front/Right 
○ Front/Bottom 
○ Right/Bottom 
○ Back/Bottom 
○ Left/Bottom 

● Rotation arrows – In planar view, there are rotation arrows above the top edges of the cube that 
rotate your plane clockwise or counterclockwise. 
 

Navigation 

Set to default view 

● Keyboard and mouse/trackpad – Double-click the cube to reset it to the default view. 
● Touch and pen – Using your finger or pen, double-tap the cube to reset it to the default view. 

Rotate the cube 

● Keyboard and mouse/trackpad: Click and drag the cube to rotate it. 
● Touch and pen: Use your finger or pen to drag the cube to rotate it. 
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2D view 

Select any face of the cube to go into the 2D view of that specific planar surface. 

To rotate the plane in a clockwise or counterclockwise manner while in 2D view, select the left or right 
rotation arrows. 

Orthographic view 

Select an edge or corner of the cube to go into an orthographic view for that specific edge or corner. 
 

Views and Appearance 
Access the Views and Appearance settings for more advanced options to navigate the modeling space. 
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Snapping Options 
[Article link | Table of contents | Back | Next] 

Shapr3D sketch tools automatically snap to elements in your project and graphical elements in the user 
interface, such as the grid. You can adjust settings in Snapping Options to modify this behavior as 
desired. 

Snap To settings 
Shapr3D helps you define precise geometries by allowing you to snap to important points. These just offer 
suggestions: you can always define points between the snap points. You can control the snapping behavior 
of the following: 

● Grid  – Snap to points on the grid displayed for the active plane. 

● Sketch Guidelines  – Sketch guidelines are displayed as purple extensions from sketch 
elements. They help you identify where you can achieve constraints such as coincident and 
tangent. 

● Sketch Guidepoints  – Sketch guidepoints include endpoints, midpoints, arc center points, 
and profile center points. 

● 3D Guidepoints  – 3D guidepoints are points from a 3D body. These include vertices, 
edges, edge midpoints, and face and hole centers. 

 Show settings 

In Snapping Options, the Show settings control the visibility of guide points in the modeling space and 
allow you to turn on Snapping Hints. 

Snapping Hints provide you with visible text next to the pointer that indicates what you are snapping to. 
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Shortcuts 
Shortcuts, gestures, and UI 
[Subsection link| Table of contents | Back] 

Keyboard shortcuts, gestures, and hotkeys 
[Article link | Table of contents | Back | Next] 

You can navigate, edit, sketch, and model intuitively with your preferred input device in Shapr3D. On 
compatible hardware, using touch and pen activates basic gestures while a keyboard allows you to use 
hotkeys or do quick command searches. Follow the guidelines below to learn how to use your different 
input devices to interact with Shapr3D. 

Getting started 

Windows 

Shapr3D on Windows supports simultaneous use of all input methods without any additional configuration. 
Some elements of the UI slightly change depending on the input method you are using, but no manual 
configuration is required. 

iPadOS 

To get started using a keyboard with a mouse or trackpad,  

● connect your compatible Bluetooth devices to your iPadOS device, or 
● connect your Magic Keyboard or Smart Keyboard (Folio) to your iPad. 

If you're using a mouse,  

● enable secondary click (right-click) to make sure you have full mouse capability.  

If you're using a trackpad,  

● you can register taps as clicks if you prefer to tap instead of press.  

macOS 

Shapr3D on macOS supports keyboard and mouse usage. No manual configuration is required. 

Single Key Action setting 
You can choose between two Single Key Action settings, Hotkeys and Command Search, to quickly 
access commands and tools via the keyboard. 

Hotkeys 

Hotkeys are the default Single Key Action setting. When prioritizing hotkeys, you can select tools and 
commands with a single key press or a simple key combination.  
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On new installations of Shapr3D, hotkeys are enabled by default and accessing command search requires 
an extra hotkey (X). 

Note: If you have an older version of Shapr3D, your default setting might still be set to trigger command 
search as you start to type. 

Command Search 

When prioritizing command search, you can start typing the name of the command and select from the 
search box that pops up. This action requires more keystrokes but can be easier to learn. 

Choose a Single Key Action 
To choose between Hotkeys and Command Search: 

1. Go to Settings or Preferences > Single Key Action. 
2. Choose your preferred action. 

Customize keyboard shortcuts 
You can customize your keyboard shortcuts to modify and assign shortcuts to the actions you use most, 
allowing you to streamline your workflow and enhance productivity. 

To customize keyboard shortcuts: 

1. Go to Settings or Preferences. 
2. Open the keyboard shortcuts settings: 

○ Windows/iPadOS: Select Customize Keyboard Shortcuts… 
○ macOS: Under General, find Keyboard shortcuts and then select Customize… 

3. Choose the category where you want to create or modify a keyboard shortcut. 
4. Find the specific action, then press the keys you want to assign as the shortcut to auto-populate the 

field. 
5. To finish, select Save Changes. 
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Cheat sheet 
Below is a cheat sheet of hotkeys, shortcuts, and basic gestures for various input devices. You can also find 
this cheat sheet in the Shapr3D modeling space: 

● Windows: Select Help > Keyboard Shortcuts, or long-press the CTRL key. 
● iPadOS: Select Help > Keyboard Shortcuts, or long-press the Command key. 
● macOS: Select Help > Keyboard Shortcuts. 

Keyboard and mouse/trackpad 

 Tip 
 
Hotkeys are highlighted in blue. To use hotkeys, choose Hotkeys as your Single Key Action. 

 

Tool/Action Gesture/Shortcut/Hotkey 

Navigation 

 
Orbit (Rotate camera) Mouse/Magic Mouse: Secondary click (right-click) and drag the 

mouse 
Trackpad: 

● iPadOS/macOS: Pan with two fingers on the trackpad. 
● Windows: Hold down CTRL + Shift and pan one finger 

on the trackpad. 

Note: These controls use the Shapr3D Default navigation 
preset. To learn more, go to Navigation presets. 

 
Pan (Move camera)  Mouse: Hold down the middle mouse button and drag the 

mouse. Alternatively, hold the Shift key and use secondary click 
(right-click) to drag the mouse. 
Magic Mouse: Hold the Shift key and use secondary click 
(right-click) to drag the mouse. 
 
Trackpad: 

● iPadOS/macOS: Hold down the Shift key and pan with 
two fingers on the trackpad. 

● Windows: Hold down CTRL + ALT and pan one finger 
on the trackpad. 

Note: These controls use the Shapr3D Default navigation 
preset. To learn more, go to Navigation presets. 
 

Zoom camera Mouse: Scroll with the mouse wheel 
Magic Mouse: Hold the CTRL key and pan up/down with your 
finger on the mouse.  
Trackpad: Pinch in or out with two fingers on the trackpad 
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Tool/Action Gesture/Shortcut/Hotkey 

Note: These controls use the Shapr3D Default navigation 
preset. To learn more, go to Navigation presets. 

Zoom to face Hover over a face and press the Space bar 

Rotate 2D view by 90 degrees Click the right or left arrow above the Orientation Cube. 

 iPadOS/macOS Windows 

Reset view ⌘ 1 CTRL +1 

Switch to front view ⌘ 2 CTRL +2 

Switch to back view ⌘ 3 CTRL +3 

Switch to top view ⌘ 4 CTRL +4 

Switch to bottom view ⌘ 5 CTRL +5 

Switch to right view ⌘ 6 CTRL +6 

Switch to left view ⌘ 7 CTRL + 7 

Sketching 

Start sketch Click anywhere in the modeling space 

Remove last-placed point and finish sketch Escape or Backspace⌫ key 

Set final endpoint and finish sketch Enter key 

Add fit point to spline Long-click anywhere on the spline 

Sketch Tools Constraint Settings 

Arc A Parallel ⇧ Shift + A 

Circle C Concentric ⇧ Shift + C 

Polygon G Equal ⇧ Shift + E 

Spline I Horizontal/Vertical ⇧ Shift + V 

Line L Coincident ⇧ Shift + N 

Offset Edge O Lock/Unlock ⇧ Shift + L 

Rectangle R Midpoint ⇧ Shift + M 

Trim T Perpendicular ⇧ Shift + P 

  Symmetry ⇧ Shift + S 

  Tangent ⇧ Shift + T 

Modeling 

Tools Boolean Operations 

Extrude E Union ⌘ U or CTRL + U 

Fillet/Chamfer F Subtract ⌘ B or CTRL +B 

Shell H Intersect ⌘ I or CTRL + I 

Move/Rotate M   

Translate N   

Project P   

Scale S   

Revolve V   

Sweep W   

Edit 

 iPadOS/macOS Windows 
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Tool/Action Gesture/Shortcut/Hotkey 

Search for commands X (if hotkeys are enabled) 
or 
⌘ F 

X (if hotkeys are enabled) 
or 
CTRL + F 

Undo ⌘ Z CTRL + Z 

Redo ⇧ ⌘ Z Shift + CTRL + Z 

Delete ⌫ Backspace or Delete key 

Finish sketch ⏎ Enter key 

Selection 

Select full object Double-click the object 

Select all ⌘ A or CTRL + A 

Deselect all iPadOS/macOS: Esc or ⌘ . 
Windows: CTRL + Shift + A or Esc 

Select single item Click the item. 

Select multiple items Hold down the ⇧ Shift key and click each item. 

Select area Click anywhere in the modeling space and drag the arrow to the 
right or left. 

Cycle through selection filters ⇥ (Tab key) 

Filter selection for bodies only B 

Filter selection for edges only E 

Filter selection for faces only F 

2D Drawings 

Update 2D Drawing iPadOS/macOS: ⌘ R 
Windows: CTRL + R 

Project Sidebar 

Show/hide Project Sidebar iPadOS/macOS: ⇧⌘ \ 
Windows: CTRL + Shift + \ 

Jump to last visited document macOS:  ⇧⌘ [OR ⇧⌘ ] 
Windows: CTRL +Tab 

Close Esc key 

Show/Hide Items 
 

iPadOS/macOS: ⌘ ⌥ S 
Windows: CTRL + ALT + S 

Show/Hide History 
 

iPadOS/macOS: ⌘ ⌥ H 
Windows: CTRL + ALT + H 

Items Manager 

Select all items/folders iPadOS/macOS: ⌘ A 
Windows: CTRL +  A 

Collapse all expanded folders macOS:  ⌥ L 
Windows: CTRL + ALT + L 

Unfocus or deselect items/folders Esc key 

Delete selected items/folders iPadOS/macOS: ⌘ ⌫ 
Windows: Delete key 

History Sidebar 

Select all steps iPadOS/macOS: ⌘ A 
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Tool/Action Gesture/Shortcut/Hotkey 

Windows: CTRL + A 

Collapse all steps macOS:  ⌥ L 
Windows: CTRL + ALT + L 

Suppress selected steps iPadOS/macOS: ⌫ 
Windows: Delete or Backspace key 

Unfocus or deselect steps Esc key 

Delete selected steps iPadOS/macOS: ⌘ ⌫ 
Windows: Shift + Delete key 

Variables 

Create variables iPadOS/macOS: ⇧⌘ V 
Windows:  CTRL + Shift + V 

Screenshots 

Copy to clipboard iPadOS/macOS: ⇧⌘ C 
Windows:  CTRL + Shift + C 
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Touch and pen 
Tool/Action Gesture/Shortcut/Hotkey 

Navigation 

Pan (Move camera) iPadOS: Pan with two fingers on the screen, 
Windows: Hold down the CTRL key and drag or hover over the 
tablet with your pen. 

Orbit (Rotate camera) iPadOS: Tap the grid with one finger and drag on the screen. 
Windows: Tap the grid with one finger and drag on the screen, or 
hold down the Shift key and drag or hover over the tablet with 
your pen. 
Note: If you enable 2-Finger Rotation, you can also use two 
fingers in a twisting motion to rotate the view. 

Zoom camera iPadOS: Pinch in or out with two fingers on the screen. 
Windows: Hold down the Alt key and drag or hover over the 
tablet with your pen. 

Zoom to face iPadOS: Double-tap a face with your finger. 
Windows: Double-tap a face with your finger, or hover over a 
face with your pen and press the Space bar. 

Rotate 2D view by 90 degrees Rotate with two fingers. 

Reset view Double-tap the Orientation Cube. 

Switch to front view Tap the front face of the Orientation Cube. 

Switch to back view Tap the back face of Orientation Cube. 

Switch to top view Tap the top face of the Orientation Cube. 

Switch to bottom view Tap the bottom face of the Orientation Cube. 

Switch to right view Tap the right face of the Orientation Cube. 

Switch to left view Tap the left face of the Orientation Cube. 

Sketching 

Start sketch Use your pen to start drawing. 

Finish sketch Tap on an empty area of the grid.  

Remove last-placed point Tap the endpoint and then Delete in the menu. 

Add fit point to spline iPadOS: Long-tap anywhere on the spline. 

Edit 

Search for Commands macOS: Select Search Commands 
Windows: Select Help > Search Commands 

Undo 

iPadOS: Swipe left with three fingers or use the Undo icon on 
the screen 
Windows: Uuse the Undo icon on the screen. 

Redo iPadOS: Swipe right with three fingers or use the Redo icon on 
the screen 
Windows: use the Redo icon on the screen. 

Delete Tap once and tap Delete in the menu. 

Finish sketch Lift the pencil from the screen. 
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Tool/Action Gesture/Shortcut/Hotkey 

Selection 

Select wholefull object Tap twice with the pen. 

Select all Tap all items in the Items Manager. 

Deselect all Tap the empty space on the grid with the pen. 

Select single item Tap once with the pen. 

Select multiple items Tap the items, one by one, with the pen. 

Select area Long-tap the screen and drag the pen across the space. 
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Adaptive user interface 
[Article link | Table of contents | Back | Next] 

Shapr3D has an adaptive user interface functionality that automatically recommends tools as you make 
selections in your projects. These tailored menus allow you to easily access everything you need without 
having to browse through the default menus. Taking advantage of the adaptive user interface can 
accelerate your workflow twice or thrice as much.  

To use the adaptive user interface, pre-select elements in your project and then choose the tool you need 
from the recommended tools.  

Below are some examples of tools that get recommended based on your selections. 

  Select a face 
 Offset Face  becomes active 

  Select a sketch profile 
 Extrude  becomes active 

  Select a body 
 Move/Rotate  becomes active 

  Select a sketch line or curve  Sketch mode  becomes active 

  Select a line and a face  Rotate Around Axis  becomes active. 

  Select a sketch profile and an axis  Revolve  becomes active. 

In the example below, we select a body, and the Move/Rotate tool becomes active in the adaptive menu. 
From here, the body can be moved using the gizmo without having to interact with the menus. 

As you continue to make selections, Shapr3D will further recommend tools.  

For example, if you select two faces from different bodies, the adaptive menu provides access to tools such 
as Align and Replace Face. 

 Tip 
 
If you do not see the tool you are looking for directly in the adaptive menu, select More  to 
access additional tools that are valid for your selections. 

By taking advantage of the adaptive user interface, you can complete tasks without interacting with menus, 
significantly increasing your efficiency. You can also complete many of the tools accessed from the adaptive 
menu without having to select Done. To do this, simply select an empty area of the grid. 

 Read more 
 
For detailed information about making selections in your projects, visit Selecting geometry. 
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Context menus 
[Article link | Table of contents | Back | Next] 

When modeling with a keyboard and mouse/trackpad, you can use context menus to select commands, 
actions, or options relevant to your workflow.  

Context menus are available for the following features: 

● Orientation cube – Provides relevant options such as the Default View, Top View, and Zoom to 
Fit. 

● Sketching – Provides relevant options to the sketching tool you selected such as the option to add 
a control point spline after you select Spline. 

● Modeling – Provides relevant options to 3D modeling such as Isolate selection and Zoom to 
Selection. 

● Visualization – Provides common options for Visualization such as Set as Focus Point and 
Remove Focus Point 

● 2D Drawings – Provides 2D drawing-related options such as New Font View and Add Bodies 

To open a context menu, simply use your secondary click (right-click), and then select your preferred action. 

 Read more 
 
To learn about other quick methods to access commands, actions, or options, visit Keyboard 
shortcuts, gestures, and hotkeys. 
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Command Search 
[Article link | Table of contents | Back | Next] 

You can quickly access any command using the command search function. Command Search allows you 
to type the name of the tool you are looking for and activate it from the search results. Searching for 
commands can save you the time you might otherwise require to browse through menus.  

Note: For information on other options for accessing tools, see Accessing tools. 

Accessing Command Search 
To learn how to access the Command Search function, expand the sections below: 

Keyboard and mouse/trackpad 

There are several ways to access Command Search: 

● Hotkey or keyboard shortcut: 
○ macOS: Press X or Command + F 
○ Windows: Press X or Ctrl+F  

● Use the top bar (macOS or Windows only) 
○ Windows: Select the Magnifying Glass 
○ macOS: Type in the Search Commands field 

● From the main menu, select Search Commands 

 Read more 
 
If you have an older version of Shapr3D, your default setting might still be set to trigger command 
search as you start to type. If you are on this setting, you can’t use hotkeys or keyboard shortcuts 
for actions. For more details, visit Keyboard shortcuts, gestures, and hotkeys. 

Touch and pen 

1. Go to Help > Search Commands. 
2. Display the on-screen keyboard. 
3. Use the on-screen keyboard to begin typing the name of a command.  
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Tips for Command Search 
The search box automatically updates a list of search suggestions as you type. You can launch tools 
directly from the search field or the list of suggestions. You can also take advantage of other functionality of 
Command Search, like using it to access recent tools or pre-selecting items in your project to initiate a 
search for selection-based results. 

 Tip 
 
You don’t need to be precise with your search terms: Shapr3D automatically finds the best match 
to the letters you typed so you can even use shortcuts like “p3” for “Add Plane - 3 Points” or “snu” 
for “Scale - Non-uniform”. 

Explore the table below for more information on how to utilize these functions. 

 Touch and pen Keyboard and mouse/trackpad 

Auto-complete text  Press the right arrow 

Cycle through 
suggestions 

 Press the up and down arrows 

Run a command from 
search suggestions 

Select a suggested command in 
the list 

When a suggested command is highlighted, 
press Return or Enter 
Click a suggested command in the list 

Clear the search Tap the X icon Press Delete 
Click the X icon 

Access recent commands Clear any text from the search field Clear any text from the search field 

Search results based on 
a selection 

Pre-select items, then launch 
Command Search 

Pre-select items, then launch Command Search 

Close Command Search Tap outside of the search box Press Escape 
Click outside of the search box 
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Shapr3D modeling 
Controls, modes, menus, and tools 
[Section link | Table of contents | Back | Next ] 

Basic controls and access 
Controls, selection, accessing tools 
[Subsection link | Table of contents | Next ] 

Selecting geometry 
[Article link | Table of contents | Back | Next] 

You can use a pen, mouse, or trackpad to select any geometry. There are various methods available for 
selecting geometry based on your input device and what you need to select.  

Menus are customized based on your selection in the modeling space. For example, when you select a 
body, tools appropriate for working with bodies become available in the menu. Or when you select a sketch 
element, the sketch tools are automatically made available. For more information, visit Accessing tools. 

 Tip 
 
Fully-defined sketches appear in green, while under-defined sketches appear in blue. If a sketch 
is fully defined, it will remain fixed unless a constraint or dimension is removed. 

Basic selection 
Basic selection can be performed via the Items Manager or using simple keyboard or touch and pen 
actions. For detailed information on specific input methods, refer to our Keyboard shortcuts, gestures, and 
hotkeys article. 

Selecting sketch items and constraints 
Selecting a sketch item highlights its connected constraints and dimensions. Constraints highlight all 
affected elements, making it easier to visualize relationships between sketch elements. 
 
If a sketch is fully defined, all elements remain constrained and will not move unless a constraint or 
dimension is removed. If the sketch is underdefined, moving an element will adjust its position relative to 
the constraints applied. 
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Area Selection 
The Area Selection tool is triggered by drawing a selection box in the modeling space. The Area 
Selection tool functions differently based on the direction that the selection box is created. There are also 
filters that can be used to specify what elements you want to include in the selection. For more information, 
explore the sections below: 

● Selection box direction 
● Using filters 

Selection box direction 
You can control what is included in the area selection by modifying the direction you draw a selection box: 

● Left to right 
Creating a selection box from left to right will only select elements that are completely within the 
selection box. 

● Right to left 
Creating a selection box from right to left will select all elements that the selection box touches. 
 

Using filters 
While making your selection, you have the option to filter the selection based on item type. Options include: 

● All Items 
● Bodies Only 
● Faces Only 
● Edges Only 

Keyboard and mouse/trackpad 

1. Keep the selection box active by holding the mouse/trackpad button. 
2. Adjust the filter using these methods: 

○ Press the Tab key to cycle through the selection filters. 
○ Use the following keyboard shortcuts: 

■ B = Bodies Only 
■ F = Faces Only 
■ E = Edges Only 

Touch and pen 

1. Keep the selection box active by holding down on your touch device. 
2. Use your finger to tap the selection filters. 
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Advanced selection 
Use advanced selection options to work more precisely in complex models. These tools help you isolate 
geometry, access hidden items, and resolve overlapping selections more efficiently. 

On-top selection and hover 

Selected items remain visible even when overlapped by other geometry. This makes it easier to keep track 
of selections and navigate complex designs. 

Select from overlapping items 

When multiple items overlap in the same area, a pop-up list appears so you can select the exact sketch, 
face, or edge. 

To select items more easily: 

● Zoom in to better separate overlapping items in the pop-up list. 
● Name sketches, faces, and bodies to make them easier to identify. If an item is unnamed, the 

pop-up will display its default name. 
● You can use this method when working with dense or layered geometry for more precise selection. 

Select Through mode 

Access internal geometry without hiding or adjusting surrounding bodies. Use the context menu or 
keyboard shortcut to enable Select Through mode and select through visible geometry for faster edits. 
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Notable points 
[Article link | Table of contents | Back | Next] 

Notable points, also known as snapping points or object snaps, are points to help you identify specific 
locations within sketches or bodies. These points are particularly useful when making measurements, using 
constraints, connecting sketches, or aligning 3D bodies. You can turn on and turn off the visibility of these 
points from the Snap To settings. 
 

Types of notable points 

Endpoints 
Endpoints are found in linear, arc, and spline-based sketch elements or edges of bodies. Faces of 3D 
bodies inherit all the notable points from their bounding edges. 

Midpoints 
A midpoint is the middle point between two endpoints of a line segment. Midpoints can be found on linear 
sketch elements or edges.  

Center points 
Center points are points at the center of arc and circular edges, and planar rectangular faces. They can be 
found on cylindrical and conical faces of 3D bodies. 

Intersection points 
An intersection point is the point at which two lines meet or intersect. Intersection points can be found on 
linear sketch elements. 
 

 Tip 
 
Splines, no matter how symmetrical, don’t have midpoints or center points. If these points are 
missing an item, check if the element has a measurable radius or diameter to make sure that it is 
not a spline.  
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Accessing tools 
[Article link | Table of contents | Back | Next] 

Shapr3D has an innovative user interface that provides several methods for accessing tools. You can 
choose the method that best matches your project workflow or preference below.  

● Menus 
● Project Sidebar 
● Adaptive user interface 
● Selection-based modes 
● Items Manager 
● Keyboard shortcuts and hotkeys 
● Command Search 
● Context menus 
● Menu bar 

Menus 
You can find the menus on the sides of your modeling space, floating over the canvas, keeping your project 
front and center. The main menu is on the left side of the screen and sketch constraints appear on the right 
side. 

Sketching and modeling tools are organized into submenus, and the main menu provides convenient 
access to the Project Sidebar and Items Manager.Note for iPadOS: If you're left-handed or simply prefer to 
have the main menu on the right side, you can change the interface settings in Settings.We  

Project Sidebar 
The Project Sidebar is a quick way to navigate between the modeling, Visualization, and 2D Drawings 
space. Simply select Modeling, Visualization, or Drawing from the main menu to open the Project 
Sidebar. 

Under the Project Sidebar, you can find the following options: 

● Modeling – Opens the modeling space. 
● Visualization – Opens the Visualization space. 
● Drawings – Open existing 2D Drawings listed under it, or right-click on the 2D drawings to rename, 

duplicate, or delete them. To create a new drawing, select +. 

Adaptive User Interface 
As you make selections in your project, Shapr3D predicts what tools you want to use next and makes them 
available at the left. Using this adaptive user interface is a fast and efficient way to develop your projects. 
This method allows you to focus on your model, rather than on browsing through menus.  

To use the adaptive UI for accessing tools, make selections in the modeling space or Items Manager, then 
make use of the default tool that becomes active or choose a tool from the customized menu at the left. For 
more information, see Adaptive User Interface. 
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 Tip 
 
To access additional tools from the adaptive menu, select More. 

 

Modes 
You can find modes in the bottom-left corner of the main menu that you can easily turn on or turn off. If you 
don’t have any selections, Section View and Measurement Mode are readily available by default. As you 
make selections or access relevant tools, the modes adapt to provide you the tools you need. 

Items Manager 
The Items Manager is another quick way to trigger tools whenever you select items. For example, selecting 
a body from the available items triggers the adaptive UI with available tools you can use. To learn more, 
visit Items Manager. 

Keyboard shortcuts and hotkeys 
The most frequently used tools can also be selected via keyboard shortcuts. The shortcuts are highlighted 
next to the name of the tool in the side menu. To learn more about shortcuts, visit Keyboard shortcuts, 
gestures, and hotkeys. 

Command Search 
The Command Search function allows you to access tools by searching for the command name. As you 
type into the search field, valid commands appear in the list below. You can launch tools directly from the 
results list. 

Depending on your platform and settings, Search Commands is available via the ‘X’ or Control/Command 
+ F keyboard shortcuts, from the toolbar or the help menu.. For more information, see Command Search. 

 Tip 
 
You can pre-select elements in your design before searching for commands. When you pre-select 
items, the search results are customized based on your selection. 

 

Context menus 
If you're using a mouse or trackpad, using context menus is another quick way to access tools and 
commands. Simply secondary click (right-click) anywhere in your modeling space to open the pop-up menu 
containing commands, actions, or options relevant to your workflow. 

To learn about the different context menus available, visit Context menus. 
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Menu bar 
In Shapr3D Windows, you can access basic tools and commands from the file menu in the top navigation 
bar. Simply select File, Edit, View, and Help to find shortcuts to basic commands. 

In Shapr3D Mac, you can also access modeling tools from the Mac menu bar. Simply go to the menu bar 
and select the options for Sketch, Add, Transform, and Tools to access modeling tools, and select File, 
Edit, View, Window, and Help find shortcuts to basic commands. 

Move and copy items using the gizmo 
[Article link | Table of contents | Back | Next] 

The gizmo provides directional control for several tools within Shapr3D. The parts of the gizmo are detailed 
below. 

Gizmo center 
The gizmo center has two functions:  

● The gizmo center defines the center of any rotational movement. 
● The gizmo center controls the orientation of the gizmo.  

You can move the gizmo center by dragging. The gizmo center will snap to existing geometry such as axes, 
faces, edges, sketch profiles, and construction geometry, allowing you to define a new center for any 
rotational movement or reorient the gizmo. 

 Tip 
 
Some tools include an Auto-orientation option that can be turned on and off from the upper left 
of the modeling space. Turning off this option prevents the axes of the gizmo from aligning with 
other geometry. 

Arrows 
Gizmo arrows provide linear and rotational controls. Arrows can be used in two ways: 

● Drag an arrow to move in a direction dynamically. 
● Select an arrow to enter a precise value for movement in the selected direction.  

Note: To learn more, visit defining and calculating numerical values. 

History settings 

In the History sidebar, your linear and rotational controls are defined as a Movement/Rotation step. 

Tiles 
Gizmo tiles can be dragged for linear movements along a plane.  
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Dimension label 
Dimension labels appear next to a selected gizmo arrow and they display the current value for the 
movement. To modify the value of a dimension label: 

● Keyboard and mouse/trackpad: Hover your pointer over the arrow and click the dimension label to 
enter a value. To use the numpad, click the dimension label to select it and then click again to 
activate the numpad.  

● Touch and pen: Tap the dimension label to modify the value using the numpad.  
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Copy badge 

The Copy badge  can be used to to create a copy or multiple copies of a selected item. 

For tools that use the Copy badge, the color of the badge indicates when it is selected: 

● Unselected:  

● Selected:  

To use the Copy badge: 

1. Select the item to copy. 

2. Select the Copy badge in the gizmo. 
3. Drag the linear or rotational arrows to where you want the copied item to be. 
4. To create multiple copies, keep the Copy badge turned on and continue moving the arrows to the 

places where you want the copies to be. 

5. Optional: To unlink you copy action from History, turn off the Link badge . 
6. To finish, turn off the Copy badge or select an empty area in the grid. 

History settings 

In the History sidebar, items you copy are defined as a Movement/Rotation step. 
 
You can modify the Movement/Rotation step parameter to turn on or off your copy action. 
 
Note: For unlinked copies, History displays a step called Unlinked Copy. 
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Defining and calculating numerical values 
[Article link | Table of contents | Back | Next] 

When modeling, you can quickly define or calculate numerical values such as dimension constraints using 
the expression input field or the built-in numpad/calculator. These fields support basic arithmetic operations, 
allowing you to perform simple calculations directly in Shapr3D 

For more advanced calculations, including unit conversions and order of operations, visit Variables and 
expressions. 

Entering numerical values 
You can define values in both 2D and 3D views by entering them directly into parameter labels using the 
parameter input field or numpad/calculator. 
 
Note: Avoid commas as decimal separators to prevent errors. 
 
To define numerical values while modeling: 

Keyboard and mouse/trackpad  
1. Hover over the tool parameter label and enter a value to automatically open the input field. 
2. To finalize, press the Enter key. 

Touch and pen  
1. Tap the tool parameter label to open the input field. 
2. Tap the numpad button to open the numpad/calculator. 
3. Tap the numbers to enter a value. 
4. To finalize, select the checkmark. 

Perform basic arithmetic 
You can enter simple calculations directly in the field or use the built-in numpad/calculator when defining 
numerical values. 

Input field 
To perform a basic calculation: 

1. Enter an arithmetic expression directly in the field. 
2. Press Enter, and the evaluated result will replace the expression. 

 
Example: Entering 10 + 5 automatically displays 15. 
 
Supported operations: 

● Addition (+) 
● Subtraction (-) 
● Multiplication 
● Division (/) 
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Numpad/Calculator 
To perform calculations using the numpad/calculator: 
 

1. Enter values and calculations as you would on a standard calculator. 
2. To finalize the result, select the checkmark. 

 

 Read more 
 

● To learn more about dimension labels, visit Editing sketch dimensions. 
● For more advanced calculations, including unit conversions and order of operations, visit 

Variables and expressions. 
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Variables and Expressions 
[Article link | Table of contents | Back | Next] 

You can use variables and expressions in Shapr3D to define and calculate values dynamically in input 
fields. Expressions let you perform calculations directly within numerical fields, while variables allow you to 
assign names to values and reuse them across multiple parameters. This makes it easy to adjust 
dimensions, constraints, and transformations without manually updating each value. 
 
Note: Expressions only support decimal format. Fractional input (e.g., 2’-1 1/2”) is not accepted. You can 
use expressions to write imperial fractional values (e.g., 2 ft + (1 + 1/2) in). 
 

Variables 
Variables let you assign names to numerical values, making it easier to reuse them across multiple 
parameters. When a variable is updated, all linked values automatically adjust, streamlining modifications 
without manually updating each instance. 
 
Created variables appear in the History Sidebar, where you can rename them and update their 
references. 

Variable naming rules 

When you create variables, follow these guidelines: 

● Variable names can include English alphanumeric characters (A–Z, a–z), underscores (_), and 
digits (0–9). 

● Variable names must not start with a digit. 
● Variable names must be no longer than 100 characters. 
● Variable names must not start with double underscores (starting with a single underscore is 

allowed). 

Create and define a variable 
You can create a variable in two ways: from the Variables panel or directly from an input field. Once 
created, variables are automatically added to the History sidebar, where you can rename them, update their 
values, and manage their references. 

From the Variables Panel 
You can create variables from the Variables panel. The panel stays open, allowing you to define multiple 
variables without reopening it each time. 
 
To create variables from the Variables panel: 

1. From the main menu, select Add > Variables. 
2. Choose the variable type: 

○ Length – Distance-based values (e.g., mm, cm, in, ft). 
○ Angle – Angular values (e.g., degrees). 
○ Number – Numerical values for general calculations. 

3. In the left field, enter a variable name, and in the right field, enter the numerical value to assign, 
following the format Variable Name = Numerical Value. 

4. To finish, select Create Variable. 
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From the input field 
You can create a variable directly from any input field to store and reuse values across multiple parameters. 
 
To create a variable from the input field: 
 

1. Open the input field where you want to define a value. 
2. Enter a numerical value for the variable. 

3. Select Insert Variable  beside the input field. 
4. Choose “Create [variable_default_name] = [value]” to confirm the variable creation. 

○ Example: Entering 4 for a length will display “Create length1 = 4”. 
5. Check the History Sidebar to see the created variable. 

History updates 
Created variables appear in the History Sidebar with default variable names. From there, you can rename 
variables and update their references as needed. 
 
To rename and update references for a variable: 

1. Open the History Sidebar. 
2. Locate the variable you want to update. 
3. Right-click or long-tap on the variable name. 
4. Select Rename and Update References. 
5. Enter a new variable name and confirm. 

 
To update only the value: 

1. Tap or hover over the value in the History Sidebar. 
2. Enter a new value in the input field. 

Using variables in expressions 
 
Variables you create and define can be used in expressions to replace fixed values, making it easier to 
adjust dimensions and constraints dynamically. When updated, all linked values adjust automatically, 
eliminating manual recalculations. Variables also work with arithmetic operations and unit conversions like 
regular numerical values, making them useful for parametric design. 
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Add a variable to an expression 
To add variables to expressions:  

1. Select Insert Variable  beside the input field. 
2. Choose the variable from the list to insert it into the expression. 

Examples of variables in expressions 
 

Scenario Expression Defined Variable Result 

Adjusting box height 
based on width 

box_height = box_width * 2 box_width = 50 mm box_height = 100 mm 

Centering a hole 
inside a circular part 

hole_offset = outer_diameter 
/ 2 

outer_diameter = 40 
mm 

hole_offset = 20 mm 

Scaling a feature 
dynamically 

scaled_length = base_length 
* 1.5 

base_length = 80 mm scaled_length = 120 
mm 

 

Expressions 
You can use expressions to perform calculations directly within input fields to define numerical values 
dynamically. Expressions support basic arithmetic operations and can be combined with variables to 
automate design modifications. 

Entering expressions 
Expressions can be used in any numerical input field that appears when defining values, including 
distances, angles, quantities, sketch dimension constraints, and transformations. 
 
To enter an expression: 

1. Open the input field. 
2. Enter the expression directly in the input field.  
3. Press Enter to apply the calculated value. 
4. To use a variable, select the variable icon to insert it into the expression. 

 
If the expression is valid, the result will be applied. If invalid, an error message will be displayed. 
 

Supported Operations 
Expressions support basic arithmetic operations and variables can also be used within expressions for 
dynamic calculations: 
 

● Addition (+): 10 + 5 → 15 
● Subtraction (-): 20 - 4 → 16 
● Multiplication (*): 8 * 3 → 24 
● Division (/): 12 / 3 → 4 
● Parentheses (): (5 + 3) * 2 → 16 (used to control order of operations) 
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Supported functions 

Shapr3D supports a wide range of built-in functions that can be used within expressions to perform 
mathematical and trigonometric operations as shown in the table below. These functions make it easier to 
define dynamic relationships and automate calculations across your design. 

Before using functions, review these rules: 

● Function names are case-sensitive. 
● Functions are evaluated using Parasolid’s precision tolerance of 1e-8. For example, ceil(1e-10) will 

return 0, since the value is interpreted as zero within that range. Similarly, functions like floor() and 
ceil() may round differently depending on how close values are to whole numbers under this 
precision.  

To learn how values are calculated and prioritized, check the Order of operations and Handling errors 
sections. 

Function Description Aliases 

sqrt(n) Returns the square root of n   

sign(n) Returns 1 if positive, 0 if zero, -1 if 
negative 

sgn 

floor(n) Largest integer not greater than n   

ceil(n) Smallest integer not less than n ceiling 

round(n) Nearest integer to n   

abs(n) Returns the absolute value of n absolute 

mod(a, b) Remainder of a divided by b remainder 

min(a, b) Returns the lesser of a or b minimum 

max(a, b) Returns the greater of a or b maximum 

avg(a, b) Returns the average of a and b average, mean 

sin(x) Sine of angle x   

cos(x) Cosine of angle x   

tan(x) Tangent of angle x tg 

cotan(x) Cotangent of angle x cot, ctg 

sec(x) Secant of angle x   

cosec(x) Cosecant of angle x csc 

arcsin(x) Arcsine of x asin 

107 



 

arccos(x) Arccosine of x acos 

arctan(x) Arctangent of x atan 

arctan2(x, y) 2-argument arctangent of y and x atan2 

arccotan(x) Arccotangent of x acot, actg 

arcsec(x) Arcsecant of x asec 

arccosec(x) Arccosecant of x acsc 

pi() Returns the value of π as a scalar 
number 

 

radians(x) Returns the radians in angle x as a 
scalar number 

 

 

Important 
 
For complex expressions—such as those using operators, variables, functions, or units—use 
decimal points (.) for numbers. Commas aren’t supported in function calls or unit definitions. 

 

Supported Units 
Expressions and variables allow unit conversions by specifying different units within calculations. 
 
Examples: 
 

● 5 mm + 2 cm → 25 mm 
● 3 in * 2 → 6 in 
● 10 mm / 2 → 5 mm 

 
If no unit is specified, the workspace default unit is applied. 

Length units 
● Millimeter: mm, millimeter(s) 
● Centimeter: cm, centimeter(s) 
● Meter: m, meter(s) 
● Inch: in, inch(es) 
● Foot: ft, foot, feet 

 

Angle units 
● Degrees: deg, degree(s) 
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Unit rules 
● If you mix different length units (e.g., 10 mm + 1 in), the result is automatically converted based on 

the active workspace unit. 
● Angle units must be explicitly defined (e.g., 30 deg instead of 30°). 
● You can use expressions to write imperial fractional values (e.g., 2 ft + (1 + 1/2) in). 

Note: Expressions do not support fractional input (1 1/2 in is invalid; instead, use 1.5 in). 

Order of Operations 
Expressions follow the standard mathematical order: 

1. Parentheses () 
2. Multiplication * and Division / 
3. Addition + and Subtraction - 

 
Example: 10 + 2 * 3 results in 16, while (10 + 2) * 3 results in 36. 
 

Handling Errors 
● If an expression contains invalid characters or incorrect syntax, an error message appears. 
● Ensure all expressions use supported operators and follow the correct format. 
● Mixed unit types (e.g., 5 mm + 3 deg) are not allowed. 

 
 

 Read more 
 
For basic numerical input and calculations,, visit Defining and calculating numerical values. 
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Boolean operations 
[Article link | Table of contents | Back | Next ] 

Boolean operations in CAD, commonly known as the Union, Subtract, and Intersect commands, are a set 
of 3D modeling tools that can merge, separate, or create geometry from existing bodies. These tools allow 
you to create complex shapes and forms of your models. 
 
In Shapr3D, boolean tools have a Keep Originals option that you can use to keep the original bodies of 
your model after completing the operation. Keeping your original bodies can be useful for later use or if you 
want to keep a backup for each part. 
 
Another tool that uses boolean operations is Extrude. When creating an extrusion, the Extrude tool provides you with 
a boolean badge with the options for Union, New Body, Subtract, and Intersect to help you easily choose your 
preferred extrude type. 

 Read more 
 
To learn more about each boolean tool and the different settings for their Keep Originals option, 
visit Union, Subtract, and Intersect.  
 
To learn more about other available 3D modeling tools, visit the Tools menu. 
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Sketch controls 
Sketch states, patterns, and dimensioning 
[Subsection link | Table of contents | Back | Next ] 

Sketch states 
[Article link | Table of contents | Back | Next] 

Sketch states in Shapr3D provide a visual representation of the definition level of sketch items and points. 
These visual cues help determine whether an item is fully constrained or still has available degrees of 
freedom, ensuring better control over sketch behavior. 

Degrees of freedom 
A sketch item has degrees of freedom when it can still move in at least one direction. In Shapr3D, sketch 
items have three available degrees of freedom: 

● Rotation: Can turn clockwise or counterclockwise. 
● Horizontal movement: Can move left or right. 
● Vertical movement: Can move up or down. 

A sketch is fully-defined when all degrees of freedom are fixed by constraints or dimensions. If an item 
remains under-defined, it retains some movement until further constraints are applied. 

Sketch states 

Fully-defined sketches (Green) 

A sketch is fully-defined when: 

● All its items have constraints or dimensions applied. 
● It has no remaining degrees of freedom. 
● Its position, size, and relationships are completely determined. 

A fully-defined sketch remains fixed unless a constraint or dimension is modified or removed. 
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Under-defined sketches (Blue) 

A sketch is under-defined when: 

● It lacks constraints or dimensions. 
● It has at least one degree of freedom remaining. 
● It can still move, rotate, or resize. 

Under-defined sketches require additional constraints or dimensions to become fully-defined. 

 Tip 
 
To quickly check the state of a sketch, look at the color of the sketch items. Green means 
fully-defined, while blue means under-defined. 

 

Sketch point states 

Fully-defined points (Green) 

A sketch point is fully-defined, fixed, or locked when: 

● It has no remaining degrees of freedom. 
● It stays in place and does not move when other sketch items are adjusted. 
● It acts as an anchor for connected sketch items. 

Under-defined points (Blue) 

A sketch point is under-defined, movable or unconnected when: 

● It still has at least one degree of freedom. 
● It can be repositioned freely. 
● It is not constrained to another sketch item. 

Connected points (Shared color with sketch item) 

A connected point follows the state of the item with the greater degree of freedom: 

● If both connected items are fully-defined, the shared point is also fully-defined. 
● If one connected item is under-defined, the shared point remains under-defined until constraints or 

dimensions are applied. 

Types of connected points: 

● Coincident constraint: The point is connected to a line, curve, or their extended path , allowing it 
to move along the element, even beyond its visible endpoints. 

● Midpoint constraint: The point remains at the center of a line even if the line's length or position 
changes. 

● Point-to-point connection: The point is connected to another sketch point, and both move 
together. 
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Understanding degrees of freedom in connected sketches 
If a fully-defined item is connected to an under-defined item: 

● The fully-defined item remains fixed. 
● The under-defined item can still move within its remaining degrees of freedom. 
● The shared point between the two behaves based on the item with the highest degrees of freedom. 

 Read more 
 
Learn more about defining sketch relationships in Constraints overview and adjusting dimensions 
in Editing sketch dimensions. 
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Sketch pattern constraint 
[Article link | Table of contents | Back | Next] 

When a Pattern is created within a sketch or a sketch profile is patterned in the 3D environment, a sketch 
pattern constraint is automatically created. If your constraint visibility setting is turned on, the source sketch 
from which you created your pattern displays a sketch pattern constraint badge. 

A sketch pattern constraint maintains the relationship between the patterned elements so that changes you 
make to one element also apply to the other elements in the pattern. 

Modify pattern definition and quantity 
You can quickly modify the pattern definition, distance, and quantity of patterned elements as long as there 
is an existing constraint. 

To modify pattern definition and quantity, follow these steps: 

1. Select any sketch belonging to a sketch pattern to re-activate the pattern control badges. 
2. Use the pattern control badges to adjust the pattern definition type, distance, and quantity. 
3. To finish, select an empty area of the grid or select Exit Sketching. 

 Tip 
 
The sketch pattern constraint can only be created using the Pattern tool for sketch elements or 
sketch profiles. If a sketch pattern constraint is deleted, it will permanently break the relationship 
between pattern instances. 

Delete sketch pattern constraint 
If you want to modify elements in your sketch pattern individually, you can break the pattern by deleting the 
sketch pattern constraint. 

To delete a sketch pattern constraint, follow these steps: 

1. While in sketch mode, locate the source sketch from which you created your pattern. 
Note: If your constraint visibility setting is turned off, select or hover over the source sketch 

2. Select the sketch pattern constraint badge on the source sketch. 
3. In the Sketch menu, select Delete Constraints. 
4. Modify individual elements from the pattern. 

Learn more by watching the video below: 

 Shapr3D Manual - Using pattern constraints | Sketching

 Read more 
 
To learn more about the Sketch Pattern tool, visit Pattern (Sketch). 

 

114 

https://youtu.be/qw71mV8eo4k
https://support.shapr3d.com/hc/en-us/articles/7321295290012


 

Editing sketch dimensions 
[Article link | Table of contents | Back | Next] 

Each sketch element has a dimension label where you can view and edit the dimensions and 
measurements of sketches. 

Edit a dimension 

Keyboard and mouse/trackpad 

1. Click the element to select it. 
2. Hover your pointer over the dimension label. 
3. Use your keyboard to type the value of the new dimension or click the dimension label again to 

open the numpad. 
4. Optional: You can enter simple mathematical expressions (Example: 12+34 or 50/2) into the 

dimension label or use operators of the numpad to calculate the final value of the dimension. 

Touch and pen 

1. Tap the element to select it. 
2. Select the dimension label. 
3. Use the numpad to input the new dimension, or use the calculator to calculate the final value of the 

dimension. 
4. To apply the value, tap the check mark. 

 Read more 
 
To learn more about modifying numerical values, visit Defining and calculating numerical values. 
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Dimension types 
The types of sketch dimensions are length, diameter, radius, and angle. 

Length 

The length is the distance between two endpoints such as a line. 

You can define the length of two endpoints with the following distance types: 

● Absolute – Distance between the two endpoints of a line. 
● Horizontal – Distance between the two line endpoints relative to the horizontal axis. 
● Vertical – Distance between two line endpoints relative to the vertical axis. 

To define a distance type, select the Distance Type badge that appears beside the dimension label. 

Diameter 

The diameter is the distance between two points in a circle that passes through the center. 

You can define the diameter of circles. 

To define a circle by its diameter, your Circular Annotation in Settings or Preferences must be set to 
Radius and Diameter. 
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Radius 

The radius is the distance between the center of a circle to any endpoint. For circles, the radius is half of 
the diameter. Meanwhile, ellipses have two radii: major and minor, where the major is the larger of the two. 

You can define the radius of circles, arcs, and ellipses. 

To define a circle by its radius, your Circular Annotation in Settings or Preferences must be set to Always 
Radius.  

Angle 

The angle is formed by the common point of two intersecting lines.  

You can define the angle of the following sketch elements: 

● Between two connected or unconnected lines 
● Between two connected splines or arcs 
● Between a connected line and arc or spline 

To change the angle between two elements, select them and then enter the new value of the angle. 

Learn more by watching the video below: 

 Editing sketch dimensions | Sketching
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Using sketch planes 
[Article link | Table of contents | Back | Next] 

To sketch in 2D, you must define a sketch plane where you want to create your sketch. You can define a 
sketch plane in the following ways: 

● By selecting a plane before you start sketching 
● By selecting a planar face or construction plane 
● From the Orientation Cube  
● From Views in Views and Appearance 

How to start a sketch in different planes 

Keyboard and mouse/trackpad 

To start sketching on a plane: 

1. From the main menu, select Sketch. 
2. From the three small rectangles that appear near the origin, click on the rectangle corresponding to 

the plane you’d like to sketch on. 

To select a sketch tool right away: 

1. From the sketch menu, select a sketch tool. 
For other methods of accessing tools, visit Accessing tools. 

2. From the three small rectangles that appear near the origin, drag your pointer to hover over the 
rectangle corresponding to the plane you’d like to sketch. 

3. Press the Space bar.  

To start sketching on a different plane: 

1. Drag your pointer to hover over a planar face or construction plane. 
Note: This is also possible with your pen if the platform supports hovering with the pen. 

2. Press the Space bar. 

 Tip 
 
If you accidentally rotate your view while in sketch mode and want to continue sketching in 2D 
with a normal view on your previously selected plane, select Normal to Sketch at the top. 
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Touch and pen 

To start sketching on a world plane: 

1. From the main menu, select Sketch. 
2. From the three small rectangles that appear near the origin, tap on the rectangle corresponding to 

the world plane you’d like to sketch on.  
Note: You can also double-tap on the rectangle with your finger. 

To start sketching on the grid or an existing plane: 

● Using a finger, double-tap on the grid, a planar surface or construction plane. 
●  

 Tip 
 
If you accidentally rotate your view while in sketch mode and want to continue sketching in 2D 
with a normal view on your previously selected plane, select Normal to Sketch at the top. 

 

How Shapr3D organizes your sketches 
Sketches you create are added to the Items Manager and the History sidebar as new items. If you continue 
sketching on a plane immediately after creating a sketch on the same plane, Shapr3D will edit the previous 
sketch. In every other case, a new sketch is created. 
 
Note: For Shapr3D versions earlier than 5.590, sketches are organized by planes, so adding a new sketch 
item to a plane you previously sketched on automatically adds it to the existing Sketch plane item in the 
Items Manager. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Defining sketch planes | Sketching
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Changing a sketch plane 
[Article link | Table of contents | Back | Next] 

While in sketching mode, you can move your sketch along the planes using Move/Rotate.  

To move your sketch along the planes: 

1. Double-click/tap the Orientation Cube to set the view to default. 
Note: To learn about the different ways to change the view, visit Orientation Cube or Views and 
Appearance. 

2. Select Move/Rotate. 
3. Drag the tiles in the gizmo center to move your sketch along the planes. 

 Read more 
 
To learn more about the Move/Rotate tool, visit Move/Rotate (Sketch) and Move/Rotate (3D). 
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Project spaces 
Project environments 
[Subsection link | Table of contents | Back | Next] 

Modeling 
[Article link | Table of contents | Back | Next] 

The modeling space , also referred to as project space, design space, or workspace, is your main 
working area when creating 2D sketches and 3D models. Whenever you start a new project, you are 
automatically brought to the modeling space. From this space, you can navigate between the Visualization 
space and 2D Drawings space through the Project Sidebar. 
 

 Read more 
 
To learn more, visit Shapr3D modeling space. 
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Visualization 
[Article link | Table of contents | Back | Next] 

Visualization  lets you create custom, real-time renders of your models. With over 100 materials, 
several environment options, and a customizable camera and depth of field settings, you can give your 3D 
model a realistic look and finish that allows you to share stunning projects with anyone. 

Access the Visualization space 
To use Visualization: 

1. Make sure that you have a 3D model in your modeling space. 
2. From the main menu, select Modeling  to open the Project Sidebar. 

You can also access this tool by selecting Tools > Visualize, or by making selections and using the 
adaptive menu. For more information and additional methods, visit Accessing tools. 

3. From the Project Sidebar, select Visualization. 

4. Select  to show the properties, and choose between the Material, Environment, and Camera 
tabs to start modifying the visualization of your model. 

 Tip 
 
If you use Visualization with an empty modeling space, you can find an option to import a project 
or a sample model. 
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Material 
You can assign and change the material of your model from the Material tab. Depending on the material, 
you can also adjust the color, transparency settings, and material scaling. 

Add a material 

To add a material to your whole model: 

1. Scroll through the Material tab to choose a material to add, or use the drop-down for All Materials 
to choose a category. 

2. Drag and drop your chosen material on the whole body of your model.  
3. Select an empty space to finish or select Modeling from the menu to go back to the modeling 

space. 

To add material to parts of your model: 

1. Select a face or body to open Properties. 
2. Under Material, select Change. 
3. Drag and drop your chosen material to your selected face or body. 

Note: You can also click or tap on the material to automatically apply it to your selected face or 
body. 

4. Select an empty space to finish or select Modeling from the menu to go back to the modeling 
space. 
 

At the top part of the Material tab, you can find the Used Materials section to view the materials you 
previously chose for your model. 

Change a material 

You can change the material of your body from Properties in the Material tab. 

To change a material: 

1. In the Used Materials section, select the material you want to change (iPadOS/macOS) or click 
Edit (Windows) beside the material to open Properties. 

2. Under Material, select Change. 
3. Scroll to choose a new material to add, or use the drop-down for All Materials to find your desired 

material. 
4. Drag and drop your chosen material on your model. 

Note: You can also click or tap on the material to automatically apply it to your model. 
5. Select an empty space to finish or select Modeling from the menu to go back to the modeling 

space. 

To reset a material to default: 

● Windows/macOS: Secondary click (right-click) on a material in the Used Materials section, then 
select Reset to default material. 

● Touch and pen: Swipe the material to the left in the Used Materials section. 
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Customize your material 

You can customize a material color and adjust other settings from Properties in the Material tab. 

To access Properties, select a material (iPadOS/macOS) or select Edit (Windows) beside the material 
under Used Materials. Learn about the different fields available in Properties below. 

● Transmission – Drag the slider to adjust how much light passes through the material. Higher 
values create a more glass-like effect. 

● IOR (Index of Refraction) – Adjust how much light bends as it passes through the material. Higher 
values simulate denser materials like glass or plastic. 

● Scale – Drag the slider to change the scale of your material. 
● Roughness – Drag the slider to adjust the roughness of your material. 
● Auto Match to Body – Turn on to find the best material mapping based on the orientation of the 

body. Turn off to fix material mapping to the XYZ axes. 
● Rotate X – Rotate the material texture about the relative X (main) axes of all the bodies that this 

material is assigned to.  
● Rotate Y –  Rotate the material texture about the relative Y (secondary) axes of all the bodies that 

this material is assigned to.  
● Rotate Z – Rotate the material texture about the relative Z (normal) axes of all the bodies that this 

material is assigned to.  
● Color Field – Adjust the brightness and saturation level of the selected color.  
● Hue Slider – Pick the color you want to apply to faces and bodies. 
● Opacity – If applicable, move the handle down on the slider to change the opacity or transparency 

of a body or face. This setting allows you to show the interior of bodies. 
Note: To make a material transparent in the modeling space, apply the Default Material or Simple 
Transparent Material from the Utility material category. 

● Hexadecimal – If you know the hex value of a color you want to apply, enter the value and press 
the Return or Enter key to apply that color. 

● Color Swatches – You can store colors that you frequently use. Choose a color in the Slider or 
sample a color in your modeling space with the Pick Face Color button, and then select an empty 
slot in the Color Swatches. The chosen or sampled color will be saved. To remove a color, 
secondary click (right-click) it and select Delete. 

Note: Depending on the material, some properties may not be applicable. 

In the example below, we change the orientation of the Y-axis to better match the orientation of the material 
to the overall body of the model. 

Environment 
You can change the environment of your model from the Environment tab.  

Select an environment 

To add an environment, go to the Environment tab and select an environment. 

Customize an environment 

To customize an environment: 

1. Select the settings icon at the bottom-right corner of the current environment. 
2. From Properties, you can adjust the following: 
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○ Light Rotation – Drag the slider to change the orientation of shadows. 
○ Light Intensity – Drag the slider to adjust the light intensity of your environment. 
○ Ground Plane – This adds an infinite plane to the scene that receives shadows from your 

models. When enabled, you can choose between Snap to Model or XY Plane. 
3. Select Done to finish. 

Camera and Depth of Field 
You can select a surface point on a body to add a realistic depth of field effect to your visualizations. 

Add Depth of Field 

When you apply a depth of field effect, parts of the screen at a similar distance from the camera will remain 
sharp, while areas closer or further away will become increasingly blurred. 

To add a depth of field effect to your model: 

● Keyboard and mouse/trackpad: Secondary click (right-click) on a part of a body to open the 
context menu. Use Set as Focus Point to bring it into focus. Use the visual indicator that pops up to 
help you bring a part into focus. Use Remove Focus Point to turn off Depth of Field. 

● Touch and pen: Tap on a part of a body to bring it into focus. Use the visual indicator that pops up 
to help you bring a part into focus. To turn off Depth of Field, select a focus point anywhere outside 
a body. 

Adjust Camera and Depth of Field properties 

You can adjust the following Depth of Field properties in the Camera tab: 

● Field of View – Adjust the field of view angle of the camera. 
● Aperture – Define the depth range where the image remains sharp in the depth of field effect. 
● Blur Intensity – Adjust the overall intensity of the depth of field effect. 

Sharing your projects 
● Capture your projects using the Capture tool 

○ You can capture screenshots in Visualization to share with anyone. To learn how, visit 
Capture your projects via Visualization. 

● Export your projects 
○ iPadOS and macOS users: you can export your workspace contents to a textured USDZ 

file via the export menu. To learn how, visit Export. 
● Augmented Reality 

○ iPadOS users: If you want to see your model represented in a physical environment via 
augmented reality, select AR at the top left corner of the screen to export your model in 
USDZ format. For more details on using augmented reality with Shapr3D, visit Augmented 
Reality. 
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2D Drawings 
[Article link | Table of contents | Back | Next] 

The 2D Drawings is where you create detailed technical drawings from your 3D models. These drawings 
provide precise dimensions, annotations, and views to communicate design intent for manufacturing, 
engineering, or documentation purposes. All drawings are saved in the Project Sidebar, where you can 
access, organize, and manage them efficiently. 

Add a 2D Drawing 
To add a new 2D Drawing: 

1. From the Project Sidebar, select  beside Drawings. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the 3D body for which you want to create a 2D drawing. 
3. Select Next. 
4. In the Drawing Preferences dialog, specify the following settings: 

● Drawing Title – Enter a name for your 2D Drawing. 
● Orientation – Choose between portrait and landscape. 
● Sheet Size – Choose from ISO or ANSI standards. 
● View-to-Sheet Scale – Choose your preferred scale. 
● Include 4 Views – Enable to automatically add the front, left, top, and isometric views of 

your model in the drawing sheet. 
Note: The front view is the base view by default, while the other views are the projection 
views. 

5. Select Continue to generate the drawing sheet. 
6. Optional: Adjust the following details according to your preference: 

● Scale of a drawing – Double-click/tap on a drawing and select the scale dimension label 

 to choose a different scale. 

● Show hidden lines – Double-click/tap on a drawing and select . 
● Title block information – Double-click any text in the title block to change it to your preferred 

text.  

● Drawing Properties – Select or  to update your sheet settings. 
■ Sheet 

● Orientation – Choose between portrait and landscape. 
● Sheet Size – Choose from ISO or ANSI standards. 
● View Scale – Choose for preferred view-to-sheet scale. 
● Projection – Choose your preferred projection angle. 
● Title Block – Choose your preferred layout. To learn more, see the Title block 

layouts section below. 
■ Dimensions 

● Units – Choose your preferred unit. 
● Angle Format – Choose your preferred angle format. 
● Length Precision – Choose your length precision format. 
● Angle Precision – Choose an angle precision format. 
● Decimal Separator – Choose between a comma and period for your 

preferred decimal separator. 
■ Line Widths – Choose your preferred line width for any of the following: 

● Visible Outlines 
● Hidden Lines  
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● Dimension Lines  
● Center Lines  
● Section Lines 
● Detail Marks 

Learn more by watching the video below: 

 Shapr3D Manual - Create new drawings | 2D Drawings

Open or manage existing 2D Drawings 
All 2D Drawings are saved in the Project Sidebar, where you can access and manage them at any time. 

To open or manage an existing 2D drawing: 

1. Open the Project Sidebar. 
2. Under Drawings, find the 2D drawing to open. 
3. Select the 2D drawing to automatically open it, or right-click on the drawing to rename, duplicate, or 

delete it. 

Title block layouts 
A title block is a table that you can usually find at the bottom-right corner of 2D Drawing sheets. The main 
purpose of a title block is to provide important information that can help readers understand your 2D 
Drawing better.  
 
In Shapr3D, you can choose from a variety of predefined title block layouts to personalize your drawing 
sheet. You can also update the fields in your title block with any information you need. 
 
By default, title block layouts contain the following information: 
 

● Title 
● Units 
● Scale 
● Projection Angle 
● Size 
● Last Updated Date 
● Sheet Size 

 

 
To choose a layout, go to Properties > Title Block, then choose any of the following: 

● Simple – This is the default layout when creating a 2D Drawing. The general information is 
displayed in the bottom-right of the sheet. 

● Empty Sheet – This layout completely removes the title block and border. 
● Border Only – This layout removes the title block and only displays the default border. 
● Horizontal – The general information is displayed horizontally at the bottom of your sheet. 
● Vertical – Displays your title block vertically on the right side of your sheet. This layout provides an 

additional table where you can record Revision, Name, and Date information. 
● Block – Displays your title block in the bottom-right of your sheet. Similar to the vertical layout, this 

layout provides an additional table where you can record Revision, Name, and Date information. 
● Block with Table – Displays the block layout with an additional table to the left that you can 

customize with information you want such as details about model parts or important features that 
you want to highlight. 
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Learn more by watching the video below: 

 Shapr3D Manual - Title block layouts | 2D Drawings
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Views 
You can add multiple projections in 2D Drawings to highlight every detail of your model. These projections 
are created from any of the following view types:  

● Base view 
● Projection view 
● Section view 
● Detail view 

Base View 

The base view is the main building block of your 2D drawing. Additional views you create always reference 
back to your base view.  

In Shapr3D, projected 2D views align automatically with their base view. When you move a 2D base view, 
all its 2D projected views also move in alignment. The same applies to 2D projected views: when you move 
a 2D projected view, its 2D base view also move in alignment. 

You can add a new base view with any of the following orientation: front, top, right, back, left, bottom, 
isometric. 

2D base views 

To add a 2D base view of your model: 

1. From the 2D Drawings menu, select Views > Front. 
2. Optional: From the Base View popup, select Custom base view… to change the projection angle 

from which your drawing is created 
3. Choose a 2D orientation for your base view. 
4. Optional: To update your reference bodies, select Bodies… > Select your new reference bodies > 

Done. 
5. Select + to add your base view. 
6. From the projection previews that pop up, select + on a projection view you want to add. 
7. To finish, select Done. 
8. To move your base views and projections, double-click/tap on any of them, then use the arrows to 

drag them to your desired position. 

Isometric views 

To add an isometric view of your model: 

1. From the 2D Drawings menu, select Views > Front. 
2. Optional: From the Base View popup, select Custom base view…to change the projection angle 

from which your drawing is created 
3. ,Choose an isometric orientation for your base view. 
4. Optional: To update your reference bodies, select Bodies… > Select your new reference bodies > 

Done. 
5. Select + to add your isometric view. 
6. Use the arrows to drag your isometric view to your desired position. 
7. To finish, select an empty space, or select Deselect All from the menu. 
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Add a new projection 

To add more projections to your drawings: 

1. From the 2D Drawings menu, select Views > Projection. 
2. Select a view from which you want to create a projection. 

Note: If you only have one view, the projection previews automatically pop up. 
3. From the projection previews that pops up, select + on a projection view you want to add. 
4. To finish, select Done. 

Section views 

You can create section views from base or projection views to visualize the interior of the model.  

To create section views of your model: 

1. From the 2D Drawings menu, select Views. 
2. Select Section View.  
3. Use the reference points as guides to precisely place your section line. This section line defines the 

plane that cuts through the object.  
Note: If you'd like to replace the section line with a different one, simply draw a new line. The 
previous section line will be removed automatically.  

4. Drag one of the arrows next to the section line to where you want to place your section view. 
5. Select an empty space to finish, or select Close from the menu. 

Detail View 

You can add detail views to your 2D Drawings to highlight and annotate your dimensions in a magnified 
view. 
 
To create detail views of your 2D Drawings: 

1. From the 2D Drawings menu, select Views. 
2. Select Detail View. 
3. Draw a circle around the area you want to magnify. 

● Keyboard and mouse/trackpad: Click on a guide point, then move or drag your pointer to 
form the circle. 

● Touch and pen: Tap on a guide point then drag your pointer to form the circle. 
4. Click or lift your pen to finalize the circle. 

Note: Make sure to include the full geometry of the drawings you want to highlight with dimensions. 
5. Select Next to automatically generate the detail view. 
6. Click or tap to place your detail view anywhere in the drawing sheet. 
7. Use the arrows or center point to adjust the placement of your detail view. 

8. Optional: Select  or  to choose a different scale or show/hide hidden lines for your detail 
view. 

9. Dimension or annotate your detail view as how you would in a regular 2D drawing. Refer to 
Dimensions or Geometries sections below for more information. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Add views to drawings | 2D Drawings
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Dimensions 
You can select from different dimension types to add to your 2D Drawings such as line length, point-to-point 
distance, and arc angle. 

To add dimensions to your 2D Drawing: 

1. Select Dimensions in the drawings menu. 
You can directly select an item in your drawing and the adaptive menu automatically dimensions the 
item. Select the check mark to confirm the dimension. If there is more than one available dimension, 
select the dimension before selecting the check mark. 

2. Select a dimensioning tool.  

○  Line Length – Measures the length of a straight line.  

○  Point-to-Point Distance – Measures the distance between two selected points. These 
points can be endpoints, intersections, quadrant points, and center marks.  

○  Point-to-Line Distance – Measures the distance between any point and a line. These 
points can be endpoints, intersections, quadrant points, and center marks.  

○  Line-to-Line Distance – Measures the distance between two parallel lines. 

○  Arc Angle – Measures the included angle of an arc. 

○  3-Point Angle – Measures the inner or outer angle between two virtual lines defined by 
one joint vertex and two other points on the legs. These points can be endpoints, 
intersections, quadrant points, or center marks. 

○  Line-to-Line Angle – Measures the angle between two non-parallel lines.   

○  Radius – Measures the distance between an arc or circle’s circumference and center. 

○  Diameter – Measures the length of a line that would cross a circle or arc’s center and 
two points on the shape’s circumference. 

○  Min-Max Distance – Measures the minimum or maximum distance between a circle or 
arc and another circle, arc, or line. Curves that are not part of a section of a virtual circle or 
arc are not included.  

3. Select the items that need to be dimensioned. 
4. Drag the dimension on the sheet to reposition it anywhere you want. 

Note: Dimensions you create snap at equal increments, allowing you to easily match your new 
dimensions to existing ones, or place them symmetrically at a new location. 

5. After you finish adding dimensions, select Done. 
6. Tap the dimension editor badge that appears beside the dimension to edit any of the following: 

○ Prefix Text – Enable to enter a prefix text for your dimension. For easy access, you can 
select any of the commonly used symbols available in the Prefix text field below. 

○ Tolerances – Enable to enter a size tolerance applicable to your dimension. To choose a 
tolerance type, select the drop-down menu and choose between Symmetrical, Deviation, 
Limits, and Basic. 

○ Suffix Text – Enable to enter a suffix text for your dimension. For easy access, you can 
select any of the available commonly used symbols below the Suffix text field. 

7. Optional: To remove a dimension, select it > Delete Selection. 

Note: To specify the precise decimal measurement of linear and angular dimensions, select  or  to 
open Properties > Dimensions and then choose Length Precision or Angle Precision. 

Learn more by watching the video below:  
 Shapr3D Manual - Add dimensions to drawings | 2D Drawings
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Geometries 
You can annotate the non-isometric views in 2D Drawings with geometries using the following geometry 
types: 

● Centerline 
● Center mark 
● Intersection mark 

Centerline 

Centerlines are dashed lines that run between two reference points or lines. You can use them in 2D 
Drawings to:  

● Show the axes of circular or cylindrical features such as holes and discs 
● Dimension circular features 
● Point out features that share the same central axis 

Note: Centerlines can’t be dimensioned with the Line length tool. 

To add a centerline, follow these steps:  

1. From the 2D Drawings menu, select Geometries. 
2. Select one of the centerline geometry tools:  

● 2-Point Centerline – Select two points as your reference in the drawing. 
● 2-Line Centerline –  Select two lines as your reference in the drawing. 
● 3-Point Circular Centerline – Select two points as your reference in the drawing. 
● 3-Point Centerline – Select three points on a circumference. 

3. To adjust the centerline, select it and then drag the arrows or points to extend the centerlines 
created between the reference points or lines. 

4. To finish, select Done. 

Center mark 

Center marks are cross-shaped annotations that indicate the centers of circles, arcs, and circular edges. 
You can also mark these centers as reference points for dimensioning.  

To add a center mark:  

1. From the 2D Drawings menu, select Geometries > Center Mark.  
2. Select the center of circular edges. 
3. To finish, select Done. 

Intersection mark 

Intersection marks are cross-shaped annotations that indicate where two non-parallel lines intersect. You 
can also mark these points as references for dimensioning.  

To add an intersection mark:  

1. From the 2D Drawings menu, select Geometries > Intersection Mark.  
2. Select two non-parallel lines. 
3. To finish, select Done. 
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Learn more by watching the video below: 

 Shapr3D Manual - Add geometries to drawings | 2D Drawings

Note 
You can annotate parts of your 2D Drawing with the Note option. 

To add an annotation: 

1. From the 2D Drawings menu, select Note. 
2. Select an item to add an annotation, or select an empty space to add a note. 
3. Enter your annotation in the textbox that appears. 

Note: The character limit is 1200. 
4. Drag and drop the notes anywhere you want. 
5. To finish, select Done. 

To edit an annotation: 

1. Double-tap or double-click on the text.  
2. Enter your new annotation. 
3. To finish, select an empty area. 

To delete an annotation, select it and press the Backspace or Delete key, or select Delete Selection. 

Learn more by watching the video below: 

 Shapr3D Manual - Add notes to drawings | 2D Drawings
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Image 
You can add images to your 2D Drawings such as screenshots of your visualized model, logos, or any kind 
of image that helps communicate your project. 
 
To add an image, follow these steps: 

1. From the 2D Drawings menu, select Add Image. 
2. Select the image you want to import > Open. 
3. Use the guide points to adjust the size of your image. 
4. Drag and drop your image anywhere you want. 
5. To finish, select an empty area in the sheet. 

To delete an image, select it and press the Backspace or Delete key, or select Delete Selection. 

Learn more by watching the video below: 

 Shapr3D Manual - Add images to drawings | 2D Drawings
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Sketch menu 
Sketching tools 
[Subsection link | Table of contents | Back | Next] 

Automatic line/arc 
[Article link | Table of contents | Back | Next] 

The automatic Line/Arc tool is a feature specific to using a pen. In Automatic mode, Shapr3D 
automatically switches your sketch to a line or arc depending on your pen gesture. 

To start sketching using automatic Line/Arc: 

1. Start drawing a line or arc. Notice that Shapr3D automatically enters sketch mode and detects what 
you're drawing. 

2. To switch from arc to line and vice versa while sketching, wiggle your pen. 

If you want to override the automatic behavior, follow these steps: 

1. Go to Sketch > Line/Arc. 
For other methods of accessing this tool, visit Accessing tools. 

2. Tap the Line Type menu below Line/Arc. 
3. Change Automatic to Line or Arc. 
4. Use your pen to draw a line or arc. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 
 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing lines and arcs with a pen | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Line 
[Article link | Table of contents | Back | Next] 

Use the Line tool under the Sketch menu to create lines. 

To create lines using specific input devices, expand the sections below. 

Keyboard and mouse/trackpad 
By default, you can create connecting lines through a series of endpoints. Follow these steps to learn how: 

1. Define your sketch plane. 
2. Select Sketch > Line. 

For other methods of accessing this tool, visit Accessing tools. 
3. To draw a line, click to add an endpoint. 
4. Drag your pointer to construct your line. 
5. Click to add another endpoint. 
6. To draw connecting lines, continue to click and drag your pointer to add more endpoints. 
7. To finish drawing lines you can do either of the following: 

○ Press Escape to cancel or exit an active endpoint. 
○ Press Enter to set your final endpoint. 

Note: Your drawing will automatically finish if you draw a closed shape by connecting the last 
endpoint to your initial endpoint. 

Touch and pen 
1. Define your sketch plane. 
2. Go to Sketch > Line/Arc. 

For other methods of accessing this tool, visit Accessing tools. 
3. Tap the Line Type menu below Line/Arc. 
4. Select Line. 
5. Use your pencil to start drawing a line, just like you would on paper. 
6. To finish the line, lift your pencil. 
7. To draw connecting lines, start drawing from the endpoint of the previous line. 
8. endpoint to your initial endpoint. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

 
Learn more by watching the video below: 

  Shapr3D Manual - Drawing lines | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Arc 
[Article link | Table of contents | Back | Next] 

Use the Arc tool under the Sketch menu to create arcs.  

Keyboard and mouse/trackpad 
1. Select Sketch > Arc. 
2. Click and drag your pointer to add two endpoints. 
3. Drag your pointer to adjust the curve of the arc. 
4. Click to finalize the curve.  
5. To finish, press Escape.  
6. To exit sketching, select Exit Sketching. 

Touch and pen 
1. Define your sketch plane, go to Sketch > Line/Arc. 

For other methods of accessing this tool, visit Accessing tools. 
2. Tap the Line Type menu below Line/Arc. 
3. Select Arc. 
4. Use your pen to draw an arc. 
5. To complete the Arc tool, select outside of the sketch. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing arcs | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Spline 
[Article link | Table of contents | Back | Next] 

The Spline tool creates a curve by marking specific points of curvature. This creates a polynomial 
curve, or curve with multiple points. With splines, you can construct curves and create organic shapes. 
Splines have two different types: 

● Fit Point Splines 
● Control Point Splines 

Fit Point Splines 
Use Fit Point Splines to create a curve by marking the specific location of each point through which 
the curve should pass. Fit Point Splines give you more flexibility to set the spline path, but controlling 
the whole curve can be challenging because any change to a point impacts other parts of the spline. 

Keyboard and mouse/trackpad 

To create Fit Point Splines, follow these steps: 

1. Define your sketch plane, go to Sketch > Spline, then choose Fit. 
For other methods of accessing this tool, visit Accessing tools. 

2. Draw a line segment, then click to add points through which the curve should pass. 
3. Continue to add points to define the shape of the curve segments. 
4. To finish, press Escape or Backspace. 
5. To move the curve points, exit Spline by pressing Escape, then click and drag the points. 
6. To adjust the curvature at a point, select it and drag the handles. 
7. To add points to the spline, secondary click (right-click) on a curve to open the context menu, 

and select New Spline Point.  
8. To remove a point, select it and then click Delete. 

 

Touch and pen 

To create Fit Point Splines, follow these steps: 

1. Define your sketch plane, go to Sketch > Spline, then choose Fit. 
For other methods of accessing this tool, visit Accessing tools. 

2. Draw a curve segment, then lift the pen. 
3. Draw more connecting curve segments. 
4. To move the curve points, select and drag them directly. 
5. To adjust the curvature at a point, drag the handles. 
6. To add points to the spline, select the curve and long-tap it. 
7. To remove a point, select it and then tap Delete. 
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Control Point Splines 
Use Control Point Splines to draw and shape a curve indirectly. As you draw each section, a polyline 
appears to guide the curve. Each point that you mark is a vertex of an imaginary polyline that you can 
click/tap and move to adjust the shape of the curve. This approach gives you less direct manipulation, 
but more control over the full curve’s smoothness. 

Keyboard and trackpad 

To create Control Point Splines, follow these steps: 

1. Define your sketch plane, go to Sketch > Spline, then choose Control. 
For other methods of accessing this tool, visit Accessing tools. 

2. Draw connecting lines. This creates a polyline that guides the shape of the curve. 
3. To finish, press Escape or Backspace. 
4. To move the curve points, exit Spline by pressing Escape, then click and drag the control 

points, not the curve itself. 
5. To add a control point, secondary click (right-click) on a curve to open the context menu, and 

select New Spline Point.  
6. To remove a point, select it and click Delete. 

Touch and pen 

To create Control Point Splines, follow these steps: 

1. Define your sketch plane, go to Sketch > Spline, then choose Control. 
For other methods of accessing this tool, visit Accessing tools. 

2. Draw connecting lines. This creates a polyline that guides the shape of the curve. 
3. To adjust the curve, select and drag the control points, not the curve itself. 
4. To add a control point, select the curve and long-tap it. 
5. To remove a point, select it and tap Delete. 

 

 Tip 
 
Constraints allow you to break or join splines at any point. To break or join splines at any point, 
select it and then click the Break/Join badge. To connect straight lines with a tangent curve, 
make sure the spline’s control polyline is in line with the neighboring lines. This will create the 
curve tangent at these points. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing splines | Sketching

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Rectangle 
[Article link | Table of contents | Back | Next] 

Use the Rectangle tool under the Sketch menu to create rectangles.  

Rectangle types can either be: Center, Diagonal, or Three-point. 

To select the type of rectangle you want to create, follow these steps: 

1. Define your sketch plane, go to Sketch > Rectangle. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the menu below Rectangle to access the Rectangle type options. 
● Center rectangle – A center rectangle is defined by its center point. When you select 

somewhere on the grid, that point becomes the center of the rectangle (and an anchor point, 
which is indicated by the X-mark) and you can drag the shape to create the sides of the 
rectangle.  

● Diagonal rectangle – A diagonal rectangle is defined by its two opposite corners. When you 
select somewhere on the grid, you need to drag an imaginary diagonal line. This line 
becomes the diagonal length of the rectangle, and the initial point becomes the anchor point. 

● Three-point rectangle – A three-point rectangle is defined by three points by first drawing a 
baseline, and then drawing the height. The remaining sides of the rectangle are 
automatically created based on the two sides, or three points you specified. The first point 
you create becomes the anchor point. 

3. Select the type of rectangle you want to create. 

Keyboard and mouse/trackpad 
To create a Center Rectangle: 

1. Click to place the center of the rectangle 
2. Drag your cursor and click to place an outer vertex for the rectangle. 

To create a Diagonal Rectangle : 

1. Click to place the starting diagonal point of the rectangle. 
2. Drag your cursor diagonally and click to place an outer vertex for the rectangle. 

To create a Three-Point Rectangle: 

1. Click to place the starting point of the rectangle, then move your pointer to draw a line. This will be 
the length of your baseline. Click to finalize the length of the baseline. 

2. Move your pointer perpendicular to the baseline to define the shape of the rectangle. Click to finalize 
the shape of the rectangle 

Touch and pen 
To create a Center Rectangle: 

Select a point on the grid for the center of the rectangle and drag to position an outer vertex 
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To create a Diagonal Rectangle : 

Select a point on the grid for the starting diagonal point of the rectangle and drag diagonally to position an 
outer vertex. 

To create a Three-Point Rectangle : 

1. Select a point on the grid for the starting point of the rectangle, then drag your pen to create a line. 
This will be the length of your baseline. 

2. Drag your pen perpendicular to your baseline to define the shape of the rectangle. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 
 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing rectangles | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Circle 
[Article link | Table of contents | Back | Next] 

The Circle tool creates a closed sketch profile with a constant radius. 

To create a circle: 

1. Define your sketch plane, go to Sketch > Circle. 
For other methods of accessing this tool, visit Accessing tools. 

2. Place the center point and diameter of the circle in the sketch.  
○ Touch and pen: Select a point on the grid for the center of the circle and drag to position the 

circumference. 
○ Keyboard and mouse/trackpad: Click to place the center of the circle, then move your 

pointer to define the diameter. Click to finalize the diameter. 
Note: You can specify the value for the circle annotation by entering it on the keyboard 
before placing the diameter. 

When drawing the circle or selecting an existing circle, you will see either a radius or diameter dimension 
label, depending on your Circular Annotations setting. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing circles

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Ellipse 
[Article link | Table of contents | Back | Next] 

The Ellipse tool creates a closed sketch profile that is defined by a major and minor axis.  

To create an ellipse: 

1. Define your sketch plane, go to Sketch > Ellipse. 
For other methods of accessing this tool, visit Accessing tools. 

2. Place the center point and circumference of the ellipse in the sketch. 
○ Touch and pen: Select a point on the grid for the center of the ellipse and drag to position 

the circumference. 
○ Keyboard and mouse/trackpad:  

1. Click to place a point, then move your pointer to draw a line. This will be the length of 
your first axis. Click to finalize the diameter of the first axis. 

2. Move your pointer perpendicular to your first axis to define the second axis. Click to 
finalize the diameter of the second axis. 

Note: You can specify the values for the major and minor axes before placing the endpoints 
by typing the values using a keyboard. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 
 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing ellipses | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Polygon 
[Article link | Table of contents | Back | Next] 

The Polygon tool creates a closed sketch profile with a specified number of equal sides. There are several 
pre-defined polygon types available. Once a polygon is created, you can customize the number of sides.  

To create a Polygon: 

1. Define your sketch plane, go to Sketch > Polygon. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the menu below Polygon to access the Polygon type options. 
3. Select the type of polygon you want to create. The types of pre-defined polygons include: 

○ Triangle  
○ Pentagon  
○ Hexagon  
○ Octagon 

Note: You can adjust the number of sides for the polygon after you place it in the sketch. 
4. Place the center point and a vertex of the polygon in the sketch. For using specific input devices, 

click the sections below. 
○ Touch and pen: Select a point on the grid for the center of the polygon and drag to position 

an outer vertex. 
○ Keyboard and mouse/trackpad: Click to place the center of the polygon, then move your 

pointer to define the radius. Click to place the outer vertex. 
Note: You can specify the radius for the polygon before placing the vertex by typing the 
value using a keyboard. 

5. Use the dimension labels to adjust the number of polygon sides and define the radius. 
Note: The label for adjusting the number of sides will only be available immediately after creating 
the polygon. If you need to adjust this parameter, select the sides label first. Once another selection 
is made, the sides label will disappear. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 

 Shapr3D Manual - Drawing polygons | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Offset Edge (Sketch) 
[Article link | Table of contents | Back | Next] 

The Offset Edge tool creates new sketch elements that are offset from existing elements by a specified 
distance. You can use the Offset Edge tool within a sketch, with sketch profiles, or with the edges and 
faces of a 3D body.  

Note: For information on using Offset Edge with sketch profiles and edges of 3D bodies, visit Offset Edge 
(3D). 

To offset from a sketch element: 

1. Within an existing sketch, go to Sketch > Offset Edge. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type to access the Offset Edge Type menu. 
3. Choose an offset type: 

○ Loop – Offsets a single edge from a sketch element. 
○ Single – Offsets a loop of edges from a sketch element. 

4. Select the sketch element you want to offset. 
5. Use the gizmo to specify the offset direction and distance. 

Note: If you select a sketch item that is shared by multiple loops, arrows will be displayed for each 
loop. Select the appropriate arrow for the loop you want to offset. 

6. To finish, select Exit Sketching. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 

 Shapr3D Manual - Offsetting sketches | Sketching

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Move/Rotate (Sketch) 
[Article link | Table of contents | Back | Next] 

Use the Move/Rotate tool in sketch mode to move or rotate sketch elements. This tool also includes a 
Copy function that allows for selected elements to be duplicated. The Move/Rotate tool uses the gizmo, 
which provides arrows and tiles for directional control, can be aligned with other geometry, and includes 
dimension labels for defining precise movements.  

Note: To move, rotate, and copy bodies and sketch profiles in the 3D environment, see Move/Rotate (3D). 

Using the Move/Rotate tool 
To use the Move/Rotate tool to move or rotate sketch elements: 

1. Within an existing sketch, go to Sketch > Move/Rotate. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the sketch element(s) you want to move. 
Note: To select a group of connected sketch elements, double-click or double-tap one of the sketch 
elements in the group. 

3. If you want to move or rotate a copy of your selection rather than the original, select the Copy 
badge. 
Note: The Copy badge appears as blue when selected . 

4. Use the gizmo to specify the new location. 
5. Complete the Move/Rotate tool by selecting an empty area of the grid, or pressing Escape. 

 Tip 
 
For simple movements within a sketch, you can select sketch elements and drag them to a new 
position. For more complex movements, the Move/Rotate tool includes the additional functionality 
provided by the gizmo. 

 

Moving planes 
While in sketching mode, you can move your sketch along the planes using the Move/Rotate tool.  

To move your sketch along the planes: 

1. Set the view to default. 
To learn about the different ways to change the view, visit Orientation Cube or Views and 
Appearance. 

2. Select Move/Rotate. 
3. Drag the tiles in the gizmo center to move your sketch along the planes. 
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Moving and adjusting selections 
While in sketch mode, you can directly move and adjust selected sketch elements without using the 
Move/Rotate tool. This specific functionality is useful for adjusting certain sketch elements and constraints.  

To move and adjust your selections, simply select sketch profiles, edges, or points, then drag or adjust 
them accordingly. 

History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 
 

Learn more by watching the video below: 
 

 Shapr3D Manual - Moving and rotating sketches | Sketching
 

 Tip 
 
To find more video tutorials, visit our Shapr3D Manual YouTube Playlist. 

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Pattern (Sketch) 
[Article link | Table of contents | Back | Next] 

The Pattern tool within the Sketch menu creates patterns of sketch elements such as lines, arcs, and 
curves. Patterns are multiple copies of selected elements, evenly spaced in the modeling space.  

The Pattern tool within in sketch mode can generate two types of patterns:  

● Linear pattern 
● Circular pattern 

Note: For information on patterning 3D bodies or sketch profiles in 3D, visit Pattern (3D). 

 Tip 
 
Sketch patterns include a default pattern constraint feature that maintains the relationship 
between the pattern instances. For more information on this constraint, visit Sketch pattern 
constraint. 

Linear pattern 
A linear sketch pattern can be distributed along one or two straight axes. Follow these steps to create a 
linear pattern within a sketch: 

1. Within an existing sketch, go to Sketch > Pattern. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the menu below Pattern to access the Pattern type menu. 
3. Set the pattern type to Linear. 
4. Select the sketch elements that you want to pattern. 
5. Customize the pattern using the pattern control badges: 

○ Pattern Definition: Use the first pattern control badge to select how you want to define the 
pattern. The options include: 

■ Total Distance [Total]: Select this option to define the pattern using an overall 
dimension. Copies of the selected sketch elements will be equally spaced across the 
dimension specified.  

■ Spacing Distance [Spacing]: Select this option to define the pattern by specifying 
the distance between each copied instance.  

○ Quantity: Use this pattern control badge to enter the number of copies required for the 
pattern. 

6. Drag a gizmo arrow in the direction you wish to create the pattern.  
7. Select the dimension label beside Total or Spacing to enter a value. 
8. To define a second direction for the pattern, repeat steps 5 & 6 with the second gizmo arrow. 
9. Complete the Pattern tool by selecting an empty area of the grid, or pressing Escape. 
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Circular pattern 
A circular sketch pattern distributes copies of selected elements around a specified center point. Follow 
these steps to create a circular pattern within a sketch:  

1. Within an existing sketch, go to Sketch > Pattern. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the menu below Pattern to access the Pattern type menu. 
3. Set the pattern type to Circular. 
4. Select the sketch elements that you want to pattern.  
5. Move the gizmo center to where you want the pattern center to be. 
6. Customize the pattern using the pattern control badges: 

○ Pattern Definition: Use the first pattern control badge to select how you want to define the 
pattern. The options include: 

■ Total Angle [Total]: Select this option to define a pattern using an overall angle. 
Copies of the selected sketch elements will be equally spaced across the angle 
specified.  

■ Spacing Angle [Spacing]: Select this option to define the pattern by specifying the 
angle between each copied instance.  

○ Quantity: Use this pattern control badge  required for the pattern. 
○ Circular Orientation: Use this pattern control badge to define how the pattern instances will 

be rotated. The options include: 
■ Uniform: Select this option to maintain the original item’s orientation for each copy.  
■ Rotated: Select this option to rotate each copy’s orientation relative to the gizmo 

center. 
7. Drag a gizmo arrow in a circular motion to create the pattern. 
8. Select the dimension label beside Total or Spacing to enter a value. 
9. Complete the Pattern tool by selecting an empty area of the grid, or pressing Escape. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 

 Shapr3D Manual - Creating sketch patterns | Sketching

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Text 
[Article link | Table of contents | Back | Next] 

The Text tool lets you add text to your projects. You can add text to a default plane, a face, or a 
construction plane. Text is created as sketch profiles and can be used for solid features in the same way as 
any other sketch. 

To add text a sketch or model: 

1. Determine how you want the text to be added to your model. 
● To add text to a default plane (Front, Top, Right): 

1. Adjust your view to look normal to the desired plane. 
2. Go to Sketch > Text. 

● To add text to an existing face or construction plane: 
1. Pre-select an existing planar face or construction plane. 
2. In the Adaptive User Interface menu at the left, select Add Text. 

Note: You may need to select More to access the Add Text tool. 
2. Use the Add Text dialog to define the text. You can also check your model to see how the text looks 

in proportion to your intended destination. 
● Enter the text into the Content field. 
● Adjust the Font, Height, and Alignment settings. 

Note: Shapr3D recognizes all fonts installed on your device. 
3. Select Continue. 
4. Position the text using the gizmo. 
5. Select Done. 

Note: Once the Text tool is completed, the text can only be edited as sketch elements. 

 Tip 
 
If you have chosen a font that produces discontinuous sections, you may need to adjust the 
sketch before the text can be used for a solid feature. 
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History settings 
To manage history settings for the automatic Line/Arc action, find the step for your specific sketch and then 
view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – If applicable, click/tap Edit… to modify any existing projections to your sketch. 
Note: To learn more about sketch projections, visit Project. 

Learn more by watching the video below: 
 

 Shapr3D Manual - Adding text | Sketching
 

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Project - Sketches 
[Article link | Table of contents | Back | Next] 

The Project - Sketches tool from the Sketch menu is another way to access the Sketches projection type in 
the Project tool. To learn about this tool, go to Project.  
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Trim 
[Article link | Table of contents | Back | Next] 

The Trim tool removes sketch segments between two points or from within a boundary. 

To use the Trim tool: 

1. Within an existing sketch, go to Sketch > Trim. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select unwanted sketch segments. 
3. Complete the Trim tool by selecting an empty area of the grid, or pressing Escape. 

Learn more by watching the video below: 

 Shapr3D Manual - Trimming sketches | Sketching

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Delete (Sketch) 
[Article link | Table of contents | Back | Next] 

The Delete tool lets you delete sketch elements. 

To delete a sketch: 

1. Within an existing sketch, select the sketch elements you want to delete. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Delete. 
3. To finish, press Escape or select Exit sketching. 

Learn more by watching the video below: 

 Shapr3D Manual - Deleting sketches | Sketching

 

 Read more 
 

● Accessing tools – Understand how tools appear based on what you select in the modeling 
space. 

● Selecting geometry – Master selection techniques for edges, faces, sketches, and bodies. 
● Defining and calculating numerical values – Learn how to apply dimensions, enter precise 

values, and use formulas. 
● Keyboard shortcuts, gestures, and hotkeys – View keyboard shortcuts you can use to access 

tools and speed up actions. 
● Variables and expressions – Set up reusable values and expressions to control your design 

parametrically. 
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Constraints menu 
Constraint overview, settings, and types 
[Subsection link | Table of contents | Back | Next] 

Constraints overview 
[Article link | Table of contents | Back | Next] 

Constraints are essential tools that define geometric relationships between sketch elements on the same 
plane, providing precise control over their behavior. In Shapr3D, Constraints  helps maintain these 
relationships, allowing you to dictate how sketch elements respond to modifications. For example, you can 
add a Horizontal/Vertical constraint to a line to ensure it remains aligned with the axes of the sketch plane. 

When working in a sketch, valid constraints for selected elements are highlighted in the menu at the right. 
You can also choose to have constraints created automatically for you while sketching by adjusting options 
in Constraint Settings. 

Learn more by watching the video below: 

 Shapr3D Manual - Introduction to constraints | Sketching
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Constraints Settings 
[Article link | Table of contents | Back | Next] 

The Constraint Settings option is where you can adjust options related to constraints. You can find this 
option in the constraints menu opposite the sketch menu whenever you're working in sketch mode. 

Auto-constraining 
The Auto-constraining option can be adjusted to control if constraints are added to your sketch 
automatically or manually.  

When turned off, the only constraints that are automatically created are between connected endpoints or 
midpoints. To create additional constraints, select sketch elements and choose your preferred constraint 
from the constraints menu. 

When turned on, as you create sketch elements, constraints for connected endpoints and midpoints are 
automatically created including Horizontal/Vertical, Perpendicular, Tangent (when an arc is created at an 
endpoint), and Coincident. 

 Tip 
 
Use Sketch Guide Lines to align geometry and automate these constraints. For more 
information on Sketch Guide Lines, visit Snapping Options.  

Constraint & Locked Dimension Visibility 
The Constraint & Locked Dimension Visibility setting controls how constraint icons for the active sketch 
are shown.  

● Always Show Constraints – When turned on, constraint icons are only shown for selected sketch 
elements. 

● Always Show Dimensions – When turned on, all locked dimensions for the active sketch are 
shown in the modeling space. 

Anchored Sketch Entity 
The Anchored Sketch Entity setting allows you to specify whether the first or last selected sketch entity 
stays in place when applying constraints, making it easier to control which part of your sketch moves or 
stays fixed. 

● First Selected – When you choose this option, all sketch entities will be moved relative to the one 
you selected first. 

● Last Selected – When you choose this option, all sketch entities will be moved relative to the one 
your selected last. 

Note: Existing constraints override this setting. 

Learn more by watching the video below: 

 Shapr3D Manual - Introduction to constraints | Sketching
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Adding and removing constraints 
[Article link | Table of contents | Back | Next] 

You can add and remove constraints in a sketch by using options in the constraints menu and 
constraint icons in the modeling space. 

Adding constraints 
You will add most constraints by using the constraints menu. However, some constraints can be created 
directly in the modeling space by using drag and drop or the Lock icon. To learn more, explore the sections 
below. 

 Tip 
 
You can automate some constraint types by turning on the Auto-constraining settings. For more 
information on Auto-constraining, visit Constraint Settings. 

 

Using the constraints menu 

The constraints menu automatically opens while in sketching mode. This menu adapts to show applicable 
constraints based on your selections. 

To add a constraint from the menu: 

1. Choose a plane with the sketch elements you want to constrain. 
2. Select the sketch element(s) you want to constrain. 
3. Select the constraint type from the menu. 

Note: Some constraint types require selecting more than one sketch element. For information on how to 
select multiple items, see Selecting geometry. 

Using keyboard shortcuts 

Constraints also have keyboard shortcuts, combining the Shift key with an additional letter. You can see the 
shortcuts for each constraint next to its name in the side menu when using Shapr3D with a keyboard. You 
can use the shortcuts the same way as the menu: select the element(s) you want to constrain and then 
press the right key combination. For more information about keyboard shortcuts, visit Keyboard shortcuts, 
gestures, and hotkeys.  
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Drag and drop 

You can create the following constraints using drag and drop within a sketch: 

● Connected points – Create connected points by dragging one point onto another point. 
● Coincident – Create a Coincident constraint by dragging a point onto a line or curve.  
● Midpoint – Create a Midpoint constraint by dragging a point onto a line's midpoint (indicated in 

purple) 

Note: Points that are connected, coincident, or have a Midpoint constraint are shown with a filled center. 
For more information, see States of sketch points.  

Lock 

The Lock constraint fixes a selected element in its current position. Visit Lock/Unlock to learn more. 

Removing constraints 
You can remove constraints by using Disconnect, Unlock, or by selecting and deleting constraint icons in 
the modeling space.  

 Tip 
 
You can control how constraint icons are shown in the modeling space by adjusting the Constraint 
Settings.  

 

Learn more by watching the video below: 

 Shapr3D Manual - Adding and removing constraints | Sketching
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Parallel 
[Article link | Table of contents | Back | Next] 

Parallel lines have the same distance continuously between them. The Parallel  constraint creates 
a parallel relationship between sketch line elements. 

To create a Parallel constraint,  

1. Select two or more sketch lines on the same plane. 
2. From the constraints menu,  select Parallel. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Perpendicular 
[Article link | Table of contents | Back | Next] 

Perpendicular lines have a right angle (90°) between them. You can use the Perpendicular  constraint 
between sketch elements. 

To create a Perpendicular constraint: 

1. Select two lines on the same plane. 
2. From the constraints menu, select Perpendicular. 

 Tip 
 
Lines do not need to share a common point or intersect with each other to be made 
perpendicular. Guide curves are shown to indicate a perpendicularity between disconnected lines. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Tangent 
[Article link | Table of contents | Back | Next] 

You can use the Tangent  constraint to create a tangent relationship between sketch elements. A line is 
tangent to a curve and perpendicular to the radius when it touches it at exactly one point. A line that is 
tangent to an arc (or circle) will be perpendicular to the arc's radius. Arcs and circles can also be tangent to 
each other. When curves are tangent to each other, they touch at exactly one point. 

To create a Tangent constraint: 

1. On the same sketch plane, select two sketch elements, either a line and a curve, or two curves. 
2. Select two sketch elements, either a line and a curve, or two curves. 
3. From the constraints menu, select Tangent. 

 Tip 
 
Tangent elements do not need to be in contact with each other. When tangent elements are 
separated, guide curves are shown to indicate where the tangency applies. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Coincident 
[Article link | Table of contents | Back | Next] 

When geometric elements are coincident, it means they are overlapping. You can use the Coincident  
constraint to make sketch endpoints coincident with other elements to make them connected.  

To create a Coincident constraint: 

1. On the same sketch plane, select an endpoint and another element. 
2. Select Coincident from the constraints menu or drag an endpoint onto the element you want to 

connect to. 
Note: Endpoints can be made Coincident to other endpoints, lines, curves, and edges. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching

 Read more 
 
Endpoints that are connected to elements with a Coincident constraint are shown with a filled 
center. For more information, visit States of sketch points. 
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Midpoint 
[Article link | Table of contents | Back | Next] 

You can use the Midpoint  constraint to connect an endpoint with the center of a line. This constraint 
ensures that the connected endpoint remains at the center of the line even if the length of the line changes. 

To create a Midpoint constraint: 

1. On the same plane, select an endpoint and a line.  
2. Select Midpoint from the constraints menu or drag an endpoint onto the center of a line. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching

 Read more 
 
Endpoints that are connected to elements with a Midpoint constraint are shown with a filled 
center. For more information, visit States of sketch points. 
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Concentric 
[Article link | Table of contents | Back | Next] 

Concentric arcs share the same center point. You can use the Concentric  constraint to create a 
concentric relationship between sketch arc elements. 

To create a Concentric constraint: 

1. On the same plane, select arc or circle elements. 
2. From the constraints menu, select Concentric. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Horizontal/Vertical 
[Article link | Table of contents | Back | Next] 

You can use the Horizontal/Vertical  constraint to create a horizontal or vertical relationship between 
linear sketch elements. Horizontal and vertical directions in a sketch are aligned with the axes of the sketch 
plane.  

To create a Horizontal/Vertical constraint:  

1. Select a single or multiple lines on the same sketch plane. 
2. From the constraints menu, select Horizontal/Vertical.  

Note: The line(s) will be aligned with the axis closest to their original direction.  

You can automatically create Horizontal/Vertical constraints while sketching when the constraint setting for 
Auto-constraining is turned on. For more information, visit Constraint settings. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Equal 
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The Equal  constraint creates an equal length for selected lines and an equal radius for selected arcs 
and circles. 

To create an Equal constraint: 

1. Select similar elements on the same sketch plane, such as multiple lines or multiple arcs. 
2. Select Equal from the constraints menu. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Symmetry 
[Article link | Table of contents | Back | Next] 

Symmetrical elements lie on opposite sides of an axis of symmetry and behave as mirror images of each 

other. You can use the Symmetry  constraint to create a symmetrical relationship between sketch 
elements. 

To create a Symmetry constraint: 

1. On the same sketch plane, select two similar elements, such as two arcs or two lines. 
2. Select Symmetry from the constraints menu. 
3. Select a line or an edge for the axis of symmetry. 

Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching
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Disconnect 
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The Disconnect  constraint is used to break the connection between connected points.  
 
To use Disconnect: 

1. Select a connected line, arc, endpoint, or center point on the same sketch plane. 

2. From the constraints menu, select Disconnect  or directly select  for sketch points. 
Note: Disconnect will delete any Coincident or Midpoint constraints for a selected point. 

 
Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching

 Read more 
 
Connected sketch points are shown with a filled center. For more information, visit States of 
sketch points. 
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Lock/Unlock 
[Article link | Table of contents | Back | Next] 

The Lock/Unlock   constraint fixes a selected sketch element in its current position and the Unlock 
constraint removes any locked constraint. 
 
To use the Lock or Unlock constraint: 

1. Select an endpoint or center point in the sketch. 

2. From the constraints menu, select Lock  or  Unlock . 

Note: You can also directly select or on sketch points. 
 
Learn more by watching the video below: 

 Shapr3D Manual - Types of constraints | Sketching

 Read more 
 
Locked sketch points are shown as a solid blue color. For more information, visit States of sketch 
points. 
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Make construction 
[Article link | Table of contents | Back | Next] 

Use Make Construction to convert your sketch elements into construction geometry.  

Construction sketch geometry is indicated with a dashed line. 

Construction geometry is used for reference in a sketch. Some examples of sketch elements used for 
reference include: 

● A sketch line you create as an axis of symmetry. 
● A sketch line you create as an axis for using Revolve. 
● Sketch geometry that you use to align other sketch elements, such as a horizontal line between arc 

centers. 
● Sketch geometry that you will reference in a future sketch or feature. 
● Sketch geometry that you will not use for 3D geometry. 

Construction geometry will not create a filled sketch. 

There is no requirement for reference sketch elements to be converted to construction geometry, but it can 
be a good way to keep your sketches clean and organized.  

To use the Make Construction option: 

1. Select one or multiple existing sketch elements. 
2. Click Make Construction from the constraints menu. 

You can convert construction geometry back to regular sketch elements by selecting it and clicking Make 
Regular from the constraints menu. 

 Tip 
 
When exporting projects, construction geometry is only visible in the Shapr3D native format. For 
exported sketches, X_T, STEP, or IGES files, all sketch elements, including construction lines, are 
skipped. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Making construction geometries | Sketching
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Add menu 
Tools under the Add menu 
[Subsection link | Table of contents | Back | Next ] 

Understanding construction geometry 
[Article link | Table of contents | Back | Next] 

Construction geometry refers to geometry that is used for reference in a project. The types of construction 
geometry are: 

● Construction planes 
● Construction axes 
● Construction sketch elements 

Construction geometry is sometimes required to properly position elements of a project. It is often created 
when there isn't an existing project element to reference at a desired location. Some examples of 
construction geometry include: 

● Creating a Construction Plane at the desired location for a new sketch. 
● Creating a Construction Plane to use as a mirroring plane. 
● Creating a Construction Axis at the center location for a circular pattern. 
● Sketching a horizontal construction line between arc centers to keep them in alignment. 

 Tip 
 
When exporting projects, construction geometry is only visible in the Shapr3D native format. For 
exported sketches, X_T, STEP, or IGES files, all sketch elements, including construction lines, are 
skipped. 
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Construction Axis 
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Use the Construction Axis tool to create an axis for reference in your project. Some examples of creating 
construction axes include: 

● Creating an axis for a circular pattern. 
● Creating a reference point or snapping point. 
● Creating a virtual intersection at a filleted corner. 
● Creating an axis for a revolved body. 

 Tip 
 
Axes are infinite in length but are represented in the design space with a size based on how they 
are defined. For general information regarding construction geometry, visit Understanding 
construction geometry. 

Creating a Construction Axis 
To create a Construction Axis: 

1. Go to Add > Construction Axis. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type then choose a construction axis type. 
3. Select appropriate references for the type of axis you chose (for details, see Construction Axis 

types). 
4. Select Done. 

 Tip 
 
You can use the Adaptive User Interface as a shortcut for creating construction axes. To make 
use of this shortcut, pre-select an element in your design that will be used to define the axis, then 
select Add Axis from the customized menu at the left. After defining the axis, click in an empty 
area of the design space to complete the command. 
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Construction Axis types 
You can define a Construction Axis in several different ways. Select the type of construction axis you want 
to define from the Type menu. The tooltip at the top of the modeling space will provide you with directions 
on what you need to do to create the type of axis you have chosen. 

Between 2 Points 

Use the Between 2 points type of construction axis to create an axis between two selected reference 
points. You can select sketch points and vertices, or you can select anywhere in the modeling space to 
define a new point. Follow these steps to create this type of axis: 

1. Select the first point the axis will run through. 
2. Select the second point the axis will run through. 
3. Optional: Drag the automatically generated points to reposition the axis. The points snap to the 

grid, sketch geometry, or body geometry. 
4. To finish, select Done. 

History settings 
To manage history settings for the Construction Axis action, find the step for your specific construction axis 
through 2 points and then view or modify the following: 

● Point #1 – Click/tap Edit… or Select… to choose a different first point and then select Done to 
finish. 

● Point #2 –  Click/tap Edit… or Select… to choose a different second point and then select Done to 
finish. 
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2-Plane Intersection 

Use the 2-Plane Intersection type of construction axis to create an axis at the intersection of two selected 
planar elements. To create this type of axis: 

1. Select two intersecting planes, faces, or sketch profiles. 
2. To finish, select Done.  

History settings 

To manage history settings for the Construction Axis action, find the step for your specific construction axis 
through 2 planes and then view or modify the following: 

● Plane #1 – Click/tap Edit… or Select… to choose a different first plane and then select Done to 
finish. 

● Plane #2 – Click/tap Edit… or Select… to choose a different second plane and then select Done to 
finish. 

● Length – Enter a new value for your preferred construction axis length.  
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Cylindrical/Conical 

Use the Cylindrical/Conical type of construction axis to create an axis at the axis of symmetry/rotation of a 
cylindrical or conical face. To create this type of axis: 

1. Select a cylindrical or conical surface. 
2. To finish, select Done. 

History settings 

To manage history settings for the Construction Axis action, find the step for your specific construction axis 
through cylinder or cone and then view or modify the following: 

● Face – Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Length – Enter a new value for your preferred construction axis length. 
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Along Edge 

Use the Along edge type of construction axis to create an axis at a selected edge or line. To create this 
type of axis: 

1. Select a linear edge of a body or a sketch line. 
2. To finish, select Done.   

History settings 

To manage history settings for the Construction Axis action, find the step for your specific construction axis 
through edge and then view or modify the following: 

● Edge – Click/tap Edit… or Select… to choose a different edge and then select Done to finish.  
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Perpendicular to Face 

Use the Perpendicular to Face type of construction axis to create an axis that is perpendicular to a 
selected planar element and through a selected point. Follow these steps to create this type of axis: 

1. Select a face, plane, or sketch profile. 
2. Select Next. 
3. Select an existing point or select anywhere in the modeling space to define the point the axis will run 

through. 
4. Optional: Drag the points to reposition the axis. The points snap to the grid, sketch geometry, or 

body geometry.  
5. To finish, select Done. 

History settings 

To manage history settings for the Construction Axis action, find the step for your specific construction axis 
perpendicular to face at point and then view or modify the following: 

● Face – Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Point – Click/tap Edit… or Select… to choose a different point and then select Done to finish. 
● Length – Enter a new value for your preferred construction axis length. 
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Construction Plane 
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Use the Construction Plane tool to create custom reference planes. Some examples of creating 
construction planes include: 

● Creating a plane at the desired location for a new sketch. 
● Creating a plane that can be used as a mirroring plane. 
● Creating a cutting plane for splitting bodies or making sectioned views. 

 Tip 
 
Planes are infinite but are represented in the modeling space with a size based on how they are 
defined. For general information regarding construction geometry, visit Understanding 
construction geometry. 

 

Creating a Construction Plane 
To create a Construction Plane: 

1. Go to Add > Construction Plane. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type and choose a construction plane type. 
3. Select appropriate references for the type of plane you chose (for details, see Construction Plane 

types). 
4. Select Done. 

You can use Shapr3D's adaptive user interface as a shortcut for creating some construction plane types. 
To make use of this shortcut, pre-select an element in your project that will be used to define the plane, 
then select Add Plane from the customized menu at the left. After defining the plane, click in an empty area 
of the modeling space to complete the command. 
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Construction Plane types 
You can define a Construction Plane in several different ways. Select the type of construction plane you 
want to define from the Type menu. The tooltip at the top of the modeling space will provide you with 
directions on what you need to do to create the type of plane you have chosen. 

Offset 

Use the Offset construction plane type to create a plane that is offset from an existing planar element. 
Follow these steps to create this type of plane: 

1. Select a face, plane, or sketch profile. 
2. Select Next. 
3. Drag the arrows to define the offset distance or use the dimension label to enter a value. 
4. To finish, select Done. 

History settings 
To manage history settings for the Construction Plane action, find the step for your specific construction 
plane offset from face and then view or modify the following: 

● Face –  Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Offset –  Enter a new value for your preferred offset distance. 
● Size – Enter a new value for your preferred construction plane size. 
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Midplane 

Use the Midplane construction plane type to create a plane that is centered between two selected planar 
elements. To create this type of plane: 

1. Select faces, planes, or sketch profiles. 
2. To finish, select Done. 

History settings 
To manage history settings for the Construction Plane action, find the step for your specific midplane 
construction plane and then view or modify the following: 

● Face –  Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Offset –  Enter a new value for your preferred offset distance. 
● Size – Enter a new value for your preferred construction plane size.  
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3 Points 

Use the Through 3 Points construction plane type to create a plane that is defined by three selected 
points. Follow these steps to create this type of plane: 

1. Select existing points or select anywhere in the modeling space to define the three points for the 
plane. 

2. Optional: Drag the automatically generated points to reposition the plane. The points will snap to 
the grid, sketch geometry, or body geometry. 

3. To finish, select Done. 

History settings 

To manage history settings for the Construction Plane action, find the step for your specific construction 
plane through 3 points and then view or modify the following: 

● Point #1 – Click/tap Edit… or Select… to choose a different first point and then select Done to 
finish. 

● Point #2 – Click/tap Edit… or Select… to choose a different second point and then select Done to 
finish. 

● Point #3 – Click/tap Edit… or Select… to choose a different third point and then select Done to 
finish. 

● Size – Enter a new value for your preferred construction plane size. 
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On Curve at Point 

Use the On Curve at Point construction plane type to create a plane that is normal to a curve at a selected 
point. Follow these steps to create this type of plane: 

1. Select an existing curve, such as a curved edge or sketch curve. 
2. Drag the point that is generated to position the plane as desired. 
3. To finish, select Done. 

History settings 

To manage history settings for the Construction Plane action, find the step for your specific construction 
plane perpendicular to curve at point and then view or modify the following: 

● Curve – Click/tap Edit… or Select… to choose a different curve and then select Done to finish. 
● Point – Click/tap Edit… or Select… to choose a different point and then select Done to finish. 
● Size – Enter a new value for your preferred construction plane size. 
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Perpendicular to Edge 

Use the Perpendicular to Edge construction plane type to create a plane that is perpendicular to a linear 
element located at a selected point. Follow these steps to create this type of plane: 

1. Select a linear edge, axis, or sketch line. 
2. Select Next. 
3. Select an existing point or select anywhere in the modeling space to define a point where the plane 

will be located. 
4. Optional: Drag the automatically generated point to reposition the plane. The point will snap to the 

grid, sketch geometry, or body geometry.  
5. To finish, select Done. 

History settings 

To manage history settings for the Construction Plane action, find the step for your specific construction 
plane perpendicular to edge at point and then view or modify the following: 

● Edge – Click/tap Edit… or Select… to choose a different edge and then select Done to finish. 
● Point – Click/tap Edit… or Select… to choose a different point and then select Done to finish. 
● Size – Enter a new value for your preferred construction plane size. 
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Along Edge at Angle 

Use the Along Edge at Angle construction plane type to create a plane that is rotated about a selected 
linear element. Follow these steps to create this type of plane: 

1. Select a linear edge, axis, or sketch line. 
2. Select Next. 
3. Select a face, plane, or sketch profile. 
4. Select Next. 
5. Drag the arrows to define the angle or use the dimension label to enter a value. 
6. To finish, select Done. 

History settings 

To manage history settings for the Construction Plane action, find the step for your specific construction 
plane through edge at angle and then view or modify the following: 

● Edge – Click/tap Edit… or Select… to choose a different edge and then select Done to finish. 
● Face –  Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Angle – Enter a new value for your preferred angle. 
● Size – Enter a new value for your preferred construction plane size. 
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Parallel to Face 

Use the Parallel to Face construction plane type  to create a plane that is parallel from an existing planar 
element and located at a selected point. Follow these steps to create this type of plane: 

1. Select a face, plane, or sketch profile. 
2. Select Next. 
3. Select an existing point or select anywhere in the modeling space to define a point where the plane 

will be located. 
4. Optional: Drag the automatically generated point to reposition the plane. The point will snap to the 

grid, sketch geometry, or body geometry. 
5. To finish, select Done. 

History settings 

To manage history settings for the Construction Plane action, find the step for your specific construction 
plane parallel to face at point and then view or modify the following: 

● Face –  Click/tap Edit… or Select… to choose a different face and then select Done to finish. 
● Point – Click/tap Edit… or Select… to choose a different point and then select Done to finish. 
● Size – Enter a new value for your preferred construction plane size. 
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Image 
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The Image tool under the Add menu is another way to access Import. To learn more about importing 
images, go to Import. 

File 
[Article link | Table of contents | Back | Next] 

The File tool under the Add menu is another way to access Import. To learn more about importing files, go 
to Import. 

 

192 

https://support.shapr3d.com/hc/en-us/articles/7874365409948
https://support.shapr3d.com/hc/en-us/articles/7874366592796


 

Transform menu 
Transformation tools 
[Subsection link | Table of contents | Back | Next ] 

Copying items 
[Article link | Table of contents | Back | Next] 

Depending on the tool you use, you will see a Copy badge or a checkbox option to make a copy of your 
sketch or body. Choose the appropriate tool based on the summary below: 

● Move/Rotate –  Use this tool to create a copy of a body using the gizmo. 
Note: For creating copies of sketch elements, use Move/Rotate (Sketch). 

● Translate – Use this tool to create a copy at a selected point. 
● Scale – Use this tool to create a copy at a different scale. 
● Rotate Around Axis – Use this tool to create a copy that is rotated about an axis. 

For tools that use the Copy badge, the color of the badge indicates when it is selected: 

● Unselected Copy badge:  

● Selected Copy badge:  

Learn more by watching the video below: 

 Shapr3D Manual - Copying items | Transform
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Move/Rotate (3D) 
[Article link | Table of contents | Back | Next] 

Use the Move/Rotate tool in the 3D environment to move or rotate sketches, edges, faces, and 3D bodies. 
This tool also includes a Copy function that allows for selected elements to be duplicated. The 
Move/Rotate tool uses the gizmo, which provides arrows and tiles for directional control, can be aligned 
with other geometry, and includes dimension labels for defining precise movements. 

Note: To move, rotate and copy sketch elements, visit Move/Rotate (Sketch). To move objects by a vector 
defined by two points, rather than using the gizmo, visit Translate. 

To use the Move/Rotate tool in the 3D environment: 

1. Go to Transform > Move/Rotate. 
Note: The Move/Rotate tool automatically becomes active when a body is selected. You can select 
an entire body by double-clicking any face of the body.  

2. Select the elements you want to reposition. 

3. If you want to move or rotate a copy of your selection rather than the original, select . 

Note: The Copy badge appears as blue when selected . 
4. Use the gizmo to specify the new location. 

Note: Use the Auto-orientation option at the top left to control whether or not the gizmo aligns with 
other geometry when moving the gizmo center. This option is only available when accessing the 
Move/Rotate tool from the Transform menu. 

5. Complete the Move/Rotate tool by selecting Done. 

 Tip 
 
You can create new edges to use with the Move/Rotate tool by projecting sketch elements onto 
faces. For more information, visit Project. 

History settings 
To manage history settings for the Move/Rotate action, find the step for your specific movement/rotation 
and then view or modify the following: 

● Start Center – Click/tap Edit… or Select… to choose a different starting center and then select 
Done to finish. 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces –  Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Target Edges –  Click/tap Edit… or Select… to choose a different target edge and then select 
Done to finish. 

● Copy – Toggle the slider to turn on or off the original copy. 

Learn more by watching the video below: 

 Shapr3D Manual - Move/Rotate | Transform
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Scale 
[Article link | Table of contents | Back | Next] 

The Scale tool can scale or adjust the size of items. This tool includes a Copy option which allows you to 
create a copy of the item to be scaled while keeping the original element unchanged.  

To scale items: 

1. Go To Transform > Scale. 
2. Select Type to access the Scale Mode menu. 
3. Choose a uniform type: 

○ Uniform – Scales an object with a center point adjustment handle in all directions 
proportionally.  

○ Non-uniform – Scales an object in any direction with different proportions along axes. You 
can define a center point for the scale by adjusting the gizmo center location. 

4. Select the item you want to scale. 

5. If applicable, drag the gizmo center  to your preferred location. 
Note: The gizmo center is the center point of the scale. 

6. Optional: To scale a copy of your selection rather than the original, select Copy  . 

Note: The Copy badge  appears as blue when selected . 
7. Use the gizmo to adjust the scale of the selection. 
8. To finish, select an empty area of the grid. 

History settings 
To manage history settings for the Scale action, find the step for your specific scale and then view or modify 
the following: 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces –  Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Target Edges –  Click/tap Edit… or Select… to choose a different target edge and then select 
Done to finish. 

● Uniform – Turn on for a uniform scale or turn off for a non-uniform scale. 
● Scale X – Enter a new scale value for the X-axis. 
● Scale Y – Enter a new scale value for the Y-axis. 
● Scale Z – Enter a new scale value for the Z-axis. 
● Copy – Toggle the slider to turn on or off the original copy. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Scale  | Transform
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Translate 
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The Translate tool moves an object by a vector defined by two points. This tool can reposition sketches, 
sketch profiles, or bodies.  

To translate geometry:  

1. Go to Transform > Translate. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the sketches, sketch profiles, or bodies you want to translate.  
3. Select Next. 
4. If you want to translate a copy of your selection rather than the original, select Copy. 
5. Select the start and end points of the desired movement. Both points snap to the grid, edges, or 

vertices. 
6. Select Done. 

History settings 
To manage history settings for the Translate action, find the step for your specific translation and then view 
or modify the following: 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces – Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Target Edges – Click/tap Edit… or Select… to choose a different target edge and then select Done 
to finish. 

● Start Point – Click/tap Edit… or Select… to choose a different start point and then select Done to 
finish. 

● End Point – Click/tap Edit… or Select… to choose a different end point and then select Done to 
finish. 

● Copy – Toggle the slider to turn on or off the original copy. 

Learn more by watching the video below: 

 Shapr3D Manual - Translate | Transform
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Pattern (3D) 
[Article link | Table of contents | Back | Next] 

The Pattern tool within the Transform menu creates linear or circular patterns of 3D bodies, sketch 
profiles, or entire sketches. In 3D modeling, a pattern is the arrangement of elements derived from the 
same source object.  

Note: Unlike sketch patterns, patterning bodies will have no connection between them, but patterned 
bodies are automatically placed in a folder in the items manager to make selections easier. For information 
on patterning within a sketch, visit Pattern (Sketch).  

Linear pattern 
A linear pattern can be distributed along one, two, or three straight axes. Follow these steps to create a 
linear pattern within the 3D environment:  

1. Go to Transform > Pattern. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type to access the Pattern type menu. 
3. Choose Linear as the pattern type.  
4. Select the bodies or sketch profiles you want to pattern. 

Note: Double-click/double-tap on a face to select a body.  
5. Customize the pattern using the pattern control badges: 

○ Pattern Definition – Use the first pattern control badge to select how you want to define the 
pattern. The options include: 

■ Total Distance [Total] –  Select this option to define the pattern using an overall 
dimension for the pattern. Copies of the selected sketch elements will be equally 
spaced across the dimension specified. 

■ Spacing Distance [Spacing] –  Select this option to define the pattern by specifying 
the distance between each copied instance. 

○ Quantity – Use this pattern control badge to enter the number of copies required for the 
pattern. 

6. Drag a gizmo arrow in the direction you wish to create the pattern.  
7. Select the dimension label beside Total or Spacing to enter a value. 
8. To define a second or third direction for the pattern, repeat steps 5 & 6 with the other available 

gizmo arrows. 
9. Complete the Pattern tool by selecting Done. 
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Circular pattern 
A circular pattern distributes copies of selected elements around a specified center point. Follow these 
steps to create a circular pattern within the 3D environment: 

1. Go to Transform > Pattern 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type to access the Pattern type menu. 
3. Choose Circular as the pattern type.  
4. Select the bodies or sketch profiles you want to pattern. 

Note: Double-click/double-tap on a face to select a body.  
5. Move the gizmo center to where you want the pattern center to be. 
6. Customize the pattern using the pattern control badges: 

○ Pattern Definition –  Use the first pattern control badge to select how you want to define the 
pattern. The options include: 

■ Total Angle [Total – Select this option to define a pattern using an overall angle for 
the pattern. Copies of the selected sketch elements will be equally spaced across the 
angle specified.  

■ Spacing Angle [Spacing] –  Select this option to define the pattern by specifying the 
angle between each copied instance.  

○ Quantity – Use this pattern control badge to enter the number of copies required for the 
pattern. 

○ Circular Orientation: Use this pattern control badge to define how the pattern instances will 
be rotated. The options include: 

■ Uniform – Select this option to maintain the original item’s orientation for each copy.  
■ Rotated – Select this option to rotate each copy’s orientation relative to the gizmo 

center.  
7. Drag a gizmo arrow in a circular motion to create the pattern. 
8. Select the dimension label beside Total or Spacing to enter a value. 
9. Complete the Pattern tool by selecting Done. 

History settings 
To manage history settings for the Pattern action, find the step for your specific pattern and then view or 
modify the following: 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces – Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Definition – Click/tap the dropdown to choose between Spacing Distance and Total Distance. 
● Quantity – Enter your preferred quantity for the pattern. 
● Distance – Enter your preferred pattern distance. 

Learn more by watching the video below: 

 Shapr3D Manual - Pattern | Transform
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Rotate Around Axis 
[Article link | Table of contents | Back | Next] 

The Rotate Around Axis tool can rotate sketches, sketch profiles, edges, faces, or bodies around a 
selected axis. Use the following steps to use the Rotate Around Axis tool: 

1. Go to Transform > Rotate Around Axis. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the sketches, sketch profiles, edges, faces, or bodies you want to rotate. 
Select Next.  

3. Select an axis, line, or edge you want to revolve around. 
4. If you want to rotate a copy of your selection rather than the original, select the Copy badge. 

Note: The Copy badge appears as blue when selected. 
5. Use the gizmo to rotate around the axis. 
6. Select Done. 

History settings 
To manage history settings for the Rotate Around Axis action, find the step for your specific rotation around 
an axis and then view or modify the following: 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces – Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Target Edges – Click/tap Edit… or Select… to choose a different target edge and then select Done 
to finish. 

● Axis – Click/tap Edit… or Select… to choose a different axis and then select Done to finish. 
● Angle – Enter a new value for your preferred angle. 
● Copy – Toggle the slider to turn on or off the original copy. 

Learn more by watching the video below: 

 Shapr3D Manual - Rotate Around Axis | Transform
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Align 
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You can use the Align tool to align 3D bodies.  

Making selections 
Selections for the Align tool include:  

● Planar faces 
● Spherical faces 
● Conical faces 
● Sketches 
● Construction planes 
● Construction axes 
● Circular edges and sketches 
● Linear sketches and edges 

Using the Align tool 
To use the Align tool: 

1. Go to Transform > Align. 
For other methods of accessing this tool, visit Accesing tools. 

2. Select the body or bodies that you want to align. This defines the bodies that will be moving in the 
modeling space.  
Note: If you pre-select a body and select Align from the adaptive menu, this step is not necessary. 

3. Click Next. 
4. Select a face or edge from the bodies you want to align. If the body has snap points, they are shown 

in purple. 
5. Select the target that you want to align with. This selection could be any of the valid selections 

mentioned in the table above. Alternatively, you can select the body’s snap point and drag it to a 
target body’s snap point. 

6. If necessary, adjust the alignment using the gizmo and the Flip badge . For more information, 
see Adjusting alignment. 

7. Select Done.  
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Adjusting alignment 
You can adjust the position of an aligned body using the gizmo and Flip badge. These on-screen tools can 
help you rotate, offset, and re-orient the body. Here are some examples of how to use these tools to 
manipulate a bodies alignment: Note: For more detailed information, visit Using the gizmo. 

● Rotating around the gizmo center 
● Moving linearly along the gizmo axes 
● Moving on a plane 
● Flipping 180 degrees 

Snapping into alignment 

When you adjust alignment using the gizmo, the body will snap into likely positions based on your 
selections and movements. Examples include: 

● Aligned vertices 
● Collinear edges 
● Coplanar arcs 
● Coplanar faces 
● Parallel edges 

History settings 
To manage history settings for the Align action, find the step for your specific alignment and then view or 
modify the following: 

● Target – Click/tap Edit… or Select… to choose a different target and then select Done to finish. 

Learn more by watching the video below: 

 Shapr3D Manual - Align | Transform
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Mirror 
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You can use the Mirror tool to mirror any sketch, face, or body over a selected plane. 

To use the Mirror tool: 

1. Go to Transform > Mirror.  
For other methods of accessing this tool, visit Accesing tools. 

2. Select the elements that you want to mirror.  
Note: Selected elements to be mirrored will be highlighted in blue and labeled with the Mirror tool 
badge. You can select the Mirror tool badge to toggle off a selection.  

3. Select a base plane, face, sketch profile, axis, sketch line, or construction plane to use as a mirror 
plane. 
Note: The selected mirror plane will be highlighted in purple and labeled with the target badge. You 
can select the target badge to toggle off a selection. 

4. If you want to remove the original element once the mirror is complete, turn off the Keep Originals 
switch at the left.  

5. Select Done. 

History settings 
To manage history settings for the Mirror action, find the step for your specific mirror and then view or 
modify the following: 

● Target Bodies – Click/tap Edit… or Select… to choose a different target body and then select 
Done to finish. 

● Target Faces – Click/tap Edit… or Select… to choose a different target face and then select Done 
to finish. 

● Plane – Click/tap Edit… or Select… to choose a different plane and then select Done to finish. 
● Keep Originals – Toggle the slider to turn on or off the original body. 

Learn more by watching the video tutorial below: 

 Shapr3D Manual - Mirror | Transform
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Tools menu 
Modeling tools 
[Subsection link | Table of contents | Back | Next] 

Offset Face 
[Article link | Table of contents | Back | Next] 

You can use the Offset Face tool to adjust the thickness of faces or bodies by offsetting them. When you 
offset a face, tangent faces are automatically included in the offset action. 

Offsetting faces allows you to: 

● Modify thickness by adding or removing material. 
● Resize features like holes by expanding or contracting their boundaries. 
● Make precise adjustments to isolated parts within patterned designs. 

Using the Offset Face tool 
To use the Offset Face tool:  

1. Access the Offset Face tool. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the face or faces you want to offset. 
3. Use the gizmo  to offset the selected face or enter your preferred offset face distance. 
4. Optional: If you select only one flat face, you can select the gizmo to choose a Distance Type. 
5. Select Done. 

Note: When using Offset Face from the adaptive menu, select an empty area of the grid to 
complete the tool. 

Offset Face Distance Type 
When using the Offset Face tool, you can choose a Distance Type to determine how the offset is applied. 
This option is available only when a single face is selected, allowing for precise control over the offset 
operation. 

● Radius/Diameter: Adjusts circular faces based on their type. For full circular faces, the diameter is 
expanded or contracted symmetrically around the center. For partial circular faces, the radius is 
adjusted. 

● Total: Sets the overall thickness by offsetting the face and its opposite face (if available) to match 
the specified total distance. 

● Offset: Moves the face by a specific distance relative to its original position. When multiple faces 
are selected, Offset is the only available option. 
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Comparing tool functions 
  When familiarizing yourself with Shapr3D tools, Offset Face and Extrude may appear similar, but each has 
a unique role: 

● Offset Face  
○ Adjusts the thickness or position of faces, modifying a body by extending or trimming 

adjacent faces without creating new geometry.  
○ Unlike Extrude, Offset Face works on both planar and non-planar faces, making it versatile 

for refining shapes. 
● Extrude 

○ Creates a 3D body from a 2D sketch or extends extrusions, adding geometry to a feature. 
○ Limited to planar faces for creating new bodies. 

 

Practical applications 
The Offset Face tool offers flexibility across various design scenarios. Here are a few examples of how it 
can be applied: 
 

● Adjusting wall thickness: Offset Face is ideal for modifying wall thickness in a model. For 
instance, in a hollow box, you can select and offset an inner wall face inward to reduce thickness 
without affecting the outer dimensions. 

● Customizing patterned features: When working with patterned bodies or holes, you can use 
Offset Face to modify individual instances within the pattern without altering the others. This is 
helpful if a specific feature within the pattern needs to differ from the rest. 

● Offsetting adjacent faces: Offset Face can adjust multiple connected faces at once, applying 
consistent modifications across adjacent surfaces. This is useful when you need to make uniform 
adjustments across a feature with several connected faces, such as tapering or expanding a portion 
of a part. 

● Quickly adjusting prototypes: In prototyping, Offset Face enables rapid adjustments to 
dimensions without needing to redraw sketches. This is especially useful for iterating on models 
when refining designs based on physical tests or feedback. 
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History settings 
To manage history settings for the Offset Face action, find the step for your specific face offset and then 
view or modify the following: 

Multiple face offsets 

● Face – Click/tap Edit… or Select… to choose a different face to offset and then select Done to 
finish. 

● Offset Distance – Enter the offset distance for a single offset or Offset distance type.  
 

Single face offset 

● Face – Click/tap Edit… or Select… to choose a different face to offset and then select Done to 
finish. 

● Distance Type – Choose how the offset is applied by selecting one of the following: 
○ Radius/Diameter – Adjusts the dimensions of circular faces. Selecting this type reveals the 

following field(s): 
■ Radius/Diameter – Enter the radius or diameter value for your selection. 

Note:  When switching from Radius/Diameter to Offset, the radius/diameter value is 
applied as the offset distance, which may lead to unexpected results. 

○ Total – Sets the overall thickness across the face and its opposite face. Selecting this type 
reveals the following field(s): 

■ Total Distance –  Enter the total thickness for your selection. 
■ Opposite Face – Select Edit to adjust or change the opposite face. 

○ Offset – Sets a specific distance from the original face position, adjusting the face 
independently. Selecting this type reveals the following field(s): 

■ Offset Distance – Enter the offset distance for a single offset or Offset distance 
type. 
Note: For multiple face selections, Offset Distance is the only available option. 
 

Learn more by watching the video below: 

 Shapr3D Manual - Offset Face | Tools
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Chamfer/Fillet 
[Article link | Table of contents | Back | Next] 

You can use the Chamfer/Fillet  tool to add an angled face or radius at the edges of your model. The type 
of geometry created from a chamfer or fillet is based on how you manipulate the arrows for the tool and the 
settings you select. The basic method is to select an edge and use the arrows as described below. 

● Chamfer: Drag the arrows toward the body. 
● Fillet: Drag the arrows away from the body. 

 

Chamfer 
The Chamfer tool creates beveled edges by cutting off the edge at an angle, rather than rounding it like a 
fillet. Chamfers are useful for removing sharp edges or for functional and aesthetic purposes in your 
designs. 

Chamfer types 

You can create the following chamfer types in Shapr3D: 

● Auto – Creates an angled face that is setback equal distances from the selected edge. For an edge 
at the intersection of perpendicular faces (90°), the chamfer produces a 45° bevel. The dimension 
that you define for a chamfer is the distance the chamfer is set back from the original edge.  

● 2-distance –  A chamfer set back at different distances from the selected edge, giving you even 
more control over how the chamfer is applied. This is useful when the chamfer needs to taper in a 
specific way. 

Create a chamfer 

To create a chamfer: 

1. Go to Tools > Chamfer/Fillet. 
For other methods of accessing this tool, visit Accessing tools. 

2. Click Chamfer/Fillet again to choose a chamfer type. 
3. Select the edge(s) to chamfer. 
4. Drag the arrow(s) to chamfer the selected edges. 
5. To finish, select Done. 

Note: When using Chamfer/Fillet from the adaptive menu, select an empty area of the grid to 
complete the tool. 
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Fillet 
The Fillet tool creates smooth transitions between edges by rounding them off. The default fillet settings 
result in a face with a circular cross-section that is tangent (G1 continuity) to adjacent faces. When three or 
more filleted edges meet at a corner, the default Corner setting uses Rolling Ball. These settings can be 
adjusted to fine-tune a fille (see Understanding fillet settings).  

Fillet types 

You can create the following fillet types in Shapr3D: 

● Radius – Rounds the edge by defining the curvature with a specific radius. This type of fillet is ideal 
when you want to ensure a consistent, circular transition along the edge. 

● Chordal – Chord width, or chord, is the straight-line distance between two points on a curve, such 
as a circle or arc. A chordal fillet specifies the distance between the endpoints of the fillet, rather 
than the radius. This gives you greater control over how the edge transitions, especially in cases 
where the exact distance between endpoints is critical. 

Understanding fillet settings 

Fillets can be modified to adjust their profile, corner type, and continuity conditions. You can use the 
on-screen elements shown below to make these adjustments: 

Radius dimension label 

This dimension label defines the radius for a default circular fillet. If you make changes to the profile or 
continuity type, this value represents the setback distance from the original edge, rather than a true radius 
value. 

Settings badge 

Select the Settings badge to access the menu with the Corners and Continuity options. 

Corners 

    Rolling Ball This type of corner has a constant radius. This is 
the default corner type. 

 

207 



 

    Setback   This type of corner sets back the edges where the 
fillets begin blending into the corner. The blended 
face has a variable radius.  

 

Continuity 

   G1 Use this continuity type to maintain tangency between the 
fillet and adjacent faces. This is the default continuity type. 

 

    G2 Use this continuity type to create a fillet that matches the 
curvature of adjacent faces. This produces a smoother 
transition between the fillet and adjacent faces than G1 
continuity. Fillets with G2 continuity will have a 
non-circular cross-sectional profile. 

 

 

 Tip 
 
Zebra stripes are shown in the images above to help visualize curvature conditions. For more 
information on this tool, see Views and Appearance. 

Profile slider 

The profile slider can change the cross-sectional profile of the fillet. Sliding toward the right will produce a 
sharper profile and sliding to the left will produce a flatter profile. 

Note: Setting a different value than the default will result in losing the radial dimension of the fillet.  

Magnitude dimension label 

You can use this dimension label to define the magnitude of change for the profile slider. The value can be 
between -1 and 1. A value of -1 would be a completely flat face and positions the slider all the way to the 
left. A value of 1 would result in a sharp corner and positions the slider all the way to the right. 
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Create a fillet 

To create a default circular fillet: 

1. Go to Tools > Chamfer/Fillet. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the edg(s) you want to fillet. 
3. Use the gizmo to fillet the selected edge(s). 

Note: A radius fillet is created by default. You can change the fillet type in your fillet settings in 
History. 

4. To finish, select Done. 
Note: When using Chamfer/Fillet from the adaptive menu, select an empty area of the grid to 
complete the tool. 
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History settings 

Chamfer 
To manage history settings for the Chamfer action, find the step for your specific chamfer and then view or 
modify the following: 

● Edge – Click/tap Edit… or Select… to choose a different edge to chamfer and then select Done to 
finish. 

● Distance #1 – Enter your preferred first distance for a 2-distance chamfer.  
● Distance #2 – Enter your preferred second distance for a 2-distance chamfer.  
● Include Tangent Edges – Turn on to include tangent edges for the chamfer. 

Fillet 
To manage history settings for the Fillet action, find the step for your specific fillet and then view or modify 
the following: 

● Edge – Click/tap Edit… or Select… to choose a different edge to fillet and then select Done to 
finish. 

● Size Type  – Select the dropdown to choose between a Radius or Chord Width fillet. 
● Radius – For radius fillets, enter your preferred radius. 
● Width – For chordal fillets, enter your preferred width. 
● Continuity – Select the dropdown to choose between a G1 and G2 continuity. 
● Corner – Select the dropdown to choose between a Rolling Ball or Setback corner. 
● Overflow – Select the dropdown to choose between an Auto, Cliff, Smooth, and Notch overflow. 
● Curvature – Enter your preferred curvature value for the fillet. 
● Include Tangent Edges – Turn on to include tangent edges for the chamfer. 
● Y-Shaped Blend – Toggle the slider to turn on or turn off Y-shaped blend. 

Learn more by watching the video below: 

 Shapr3D Manual - Chamfer/Fillet | Tools
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Extrude 
[Article link | Table of contents | Back | Next] 

You can use the Extrude tool to create 3D geometry by pushing or pulling a face or closed sketch in a 
linear direction. If necessary, you can specify a draft angle, which adds a taper to the side faces of the 
geometry. 

The Extrude tool can result in geometry that is: 

● A new body. 
● Added to an existing body. 
● Removed from an existing body, creating a hole. 
● The intersection of the extruded profile with an existing body. 

The type of extrude created is automated based on geometric conditions, but it can be modified if 
necessary.  

Using the Extrude tool 
To use the Extrude tool: 

1. Go to Tools > Extrude tool. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the face(s) or sketch profile(s) you want to extrude. 
3. Use the gizmo to extrude the selected items to your desired distance. 
4. If necessary, adjust the Extrude type using the boolean badge next to the dimension label. 

Note: For more information, see Understanding default Extrude types. 
5. Optional: Use the gizmo to define a draft angle. 
6. Select Done. 

Note: When using Extrude from the adaptive menu, select an empty area of the grid to complete 
the tool. 
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History settings 
To manage history settings for the Extrude action, find the step for your specific extrusion and then view or 
modify the following: 

● Profile – Click/tap Edit… or Select… to choose a different sketch profile for the Extrude action.  
● Sides – Select the dropdown to choose between One-Sided and Symmetric for your extrude 

extension. 
● Extent – Select the dropdown to choose between Distance, To Object, and Through All as the 

extent type for the extrusion. 
○ Distance – Enter your preferred distance. 
○ To Object –  Click/tap Select… beside To Object to select the object where you want to 

extend the extrusion. 
○ Through All – Choose whether to turn on or turn off Flip Direction. 

● Draft Angle – Enter your preferred draft angle for the extrusion. 
● Start – To choose from where you want to start your extrusion, select the dropdown to choose 

between From Profile, Offset, and From Plane. 
○ From Profile – Starts your extrusion from the selected profile. 
○ Offset – Enter values for the Start Offset and End Offset fields. 
○ From Plane – Select Edit… beside Start Plane to choose from which plane you want the 

extrusion to start. 
● Result – Select the dropdown to choose between New Body, Union, Intersect, and Subtract as 

your preferred extrude type and select Selec… beside Target to select the target bodies for your 
extrude type. 

  Learn more by watching the video below: 

 Shapr3D Manual - Extrude | Tools
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Understanding default Extrude types 
The default type of extrude that is created is based on geometric conditions. Here is a summary of the 
types of extrudes and when they are triggered: 

  Description: The default type when: 

New Body  Creates a new standalone body. 
A sketch profile is extruded that is not in 
contact with any existing body. 

Union  
The extruded geometry will be 
added to an existing body. The 
edges where the extruded faces 
and the existing body meet will 
become shared edges. 

● A face is selected for the extrude 
and pulled away from the existing 
body. 

● A sketch profile that is attached 
to a face is selected and pulled 
away from the existing body. 

Subtract  

The extruded geometry will be 
removed from an existing body, 
producing a hole or void. 

● A face is selected for the extrude 
and pushed into the existing 
body. 

● A sketch profile is selected and 
pushed into an existing body. 

Intersect  

The result of the extrude will be the 
volume where the profile overlaps 
existing body geometry. 

This type of extrude must be selected 
from the badge menu. 

Extrude vs Offset Face 
While the tools look similar, Offset Face cannot be used to create a body from a closed sketch, while 
Extrude created a 3D body from a 2D sketch by linearly extending a face on a body.  

● Offset Face: Adjacent faces are extended or trimmed. 
● Extrude: Creates a new prismatic shape from a face, while offset modifies a body. 

Additionally, you can only Extrude planar faces, but this is not a limitation of the Offset Face tool. 
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Shell 
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You can use the Shell tool to create models with a uniform wall thickness. This tool allows you to convert a 
face of any solid geometry into a hollow shell with a defined wall thickness. 

To use the Shell tool: 

1. Go to Tool > Shell. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the face or faces to remove.  
3. Use the gizmo to define the wall thickness for the shell. 
4. Select Done.  

Note: When using Shell from the adaptive menu, select an empty area of the grid to complete the 
tool. 

History settings 
To manage history settings for the Shell action, find the step for your specific shell and then view or modify 
the following: 

● Target – Click/tap Edit… or Select… to choose a different target for the face you want to shell and 
then select Done to finish. 

● Thickness – Enter your preferred shell thickness. 

Learn more by watching the video below: 
 

 Shapr3D Manual - Shell | Tools
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Loft 
[Article link | Table of contents | Back | Next] 

You can use the Loft tool to create complex shapes defined by cross-sectional profiles. This tool 
interpolates the shape of the body between the cross-sections you specify. For more control over the shape 
in between the profiles, you can create guide curves and make use of connection points.  

To learn more, explore the sections below. 

● Understanding Loft elements 
● Using the Loft tool 

Understanding Loft elements 
Elements of a loft include cross-sectional profiles, optional guide curves, and control points. Learn about 
the different loft elements below. 

Loft profiles 

Profiles can be faces or sketch profiles that represent cross-sections of the completed shape. There must 
be a minimum of two loft profiles — one located at the beginning of the shape, and one at the end of the 
shape. Additional profiles can be defined between the start and end profiles as necessary. 

Note: Loft profiles can only be single closed cross-sections. Two cross sections from the same plane or 
intersecting cross sections cannot be used. 

Connection Points 

Connection points are automatically generated between loft profile vertices. They help identify how the 
vertices from one profile are mapped to the vertices in the next profile. Connection points can be dragged to 
modify how the vertices are mapped. Making changes to connection points will often introduce twist into the 
loft feature, or can remove twist. Connection points will not be available if guide curves are specified for a 
loft. 

Guide Curves 

Guide curves are an optional loft element. They can be used to control the shape of the loft in between the 
loft profiles. You can use sketch curves or edges as loft guide curves. 

Note: Make sure to connect the guides to the cross sections. If the guides are not intersecting with the 
cross section curve or they are inside the cross section, the loft will fail. 
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Using the Loft tool 
Follow these steps to use the Loft tool.  

1. Create the necessary loft elements: 
○ For the loft profiles, draw closed sketches on separate planes. 
○ Optionally, sketch guide curves that intersect every cross-section.  

2. Go to Tools > Loft. 
For other methods of accessing this tool, visit Accessing tools. 

3. Select the loft profiles. If more than two profiles are being used, select them in the order they should 
be connected. 

4. If necessary, adjust the loft connection points. 
5. If necessary, select the loft guide curves. 
6. Optional: For lofts with periodicity, you can blend or smoothen the first and last profile by turning on 

Periodic Loft in the History sidebar. 
7. Select Done.  

Note: When using Loft from the adaptive menu, select an empty area of the grid to complete the 
tool. 

History settings 
To manage history settings for the Loft action, find the step for your specific loft and then view or modify the 
following: 

● Profiles – Click or tap Edit... or Select... to choose different loft profiles. 
● Periodic Loft – For curved lofts, turn on to blend or smoothen the first and last profile. 
● Guides – Click or tap Edit... or Select... to choose different loft guides. 
● Start Tangent Continuity – Select the dropdown to choose between a None, G1, and G2 start 

tangent continuity. 
● Start Tangent Magnitude – Enter a value for the start tangent magnitude. 
● End Tangent Continuity – Select the dropdown to choose between a None, G1, and G2 end 

tangent continuity. 
● End Tangent Magnitude – Enter a value for the end tangent magnitude. 

Learn more by watching the video below: 

 Shapr3D Manual - Loft | Tools
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Union 
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In CAD modeling, you can use boolean operations to create complex shapes and forms of your models. 

The Union tool is one of the boolean operations in Shapr3D that you can use to merge separate bodies 
into a single, united body. Bodies must be overlapping to be valid for this tool. 

To use the Union tool: 

1. Go to Tools > Union. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the bodies you want to merge. 
Note: In History, the last body you select becomes your default Target parameter while the 
remaining bodies will be your default Tool parameters. 

3. If necessary, adjust the Keep Originals setting with any of the following options: 
○ Keep Originals: Off: The default Off setting for Keep Originals results in the original 

bodies being absorbed into the merged body. 
○ Keep Originals: On: By turning On the setting for Keep Originals, the results of the Union 

will be created as a new merged body, and the original separate bodies will still be available 
within the project. 

4. Select Done. 

History settings 
To manage history settings for the Union action, find the step for your specific union and then view or 
modify the following: 

● Target – Click/tap Edit… or Select… to choose a different target for the bodies you want to union 
and then select Done to finish. 

● Tool – Click/tap Edit… or Select… to choose a different tool for the bodies you want to union and 
then select Done to finish. 

● Type – Select the dropdown to update the boolean type to either Union, Subtract, or Intersect. 
Note: Make sure to update the Target and Tool settings that apply to your selected boolean type. 

● Keep Target Bodies – Turn on to keep target bodies. 
● Keep Tool Bodies – Turn on to keep tool bodies. 

Learn more by watching the video below: 

 Shapr3D Manual - Union | Tools
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Subtract 
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In CAD modeling, you can use boolean operations to create complex shapes and forms of your models. 

Subtract  is one of the boolean operations in Shapr3D that you can use on overlapping bodies to remove 
or subtract the volume of a selected body from another body. To use this tool, you must have at least two 
overlapping bodies. 

To use the Subtract tool: 

1. Go to Tools > Subtract. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the target body or bodies that you want to remove from. Target bodies are highlighted in 
purple and marked with a target badge (+). 
Note: In History, this body will be your Target parameter. You can select the badge to toggle the 
desired state of the selected body.  

3. Select the bodies that you want to subtract from the target body. These bodies are highlighted in 
blue and marked with a subtract badge (-). 
Note: In History, this body will be your Tool parameter. You can select the badge to toggle the 
desired state of the selected body. 

4. If necessary, adjust the Keep Originals settings at the left. You can keep the original of the 
following: 

○ All - With this option selected, the results of the Subtract tool are created as a new body, 
and the original bodies will still be available. 

○ Modified Bodies - The bodies being modified are the target bodies (highlighted in purple). 
With this option selected, the results of the Subtract are created as a new body and the 
original target bodies will still be available.  

○ Removed Bodies - The bodies being removed. With this option selected, the results of the 
Subtract tool are created as a new body and the original bodies will still be available. The 
target bodies will be removed. 

○ None - With this option selected, only the results of the Subtract tool remain. The original 
bodies will be removed. 

5. Select Done.  

History settings 
To manage history settings for the Subtract action, find the step for your specific subtractiont and then view 
or modify the following: 

● Target – Click/tap Edit… or Select… to choose a different body you want to subtract from and then 
select Done to finish. 

● Tool – Click/tap Edit… or Select… to choose a different body you want to subtract and then select 
Done to finish. 

● Type – Select the dropdown to update the boolean type to either Union, Subtract, or Intersect. 
Note: Make sure to update the Target and Tool settings that apply to your selected boolean type. 

● Keep Target Bodies – Turn on to keep target bodies. 
● Keep Tool Bodies – Turn on to keep tool bodies. 

Learn more by watching the video below: 

 Shapr3D Manual - Subtract | Tools
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Intersect 
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In CAD modeling, you can use boolean operations to create complex shapes and forms of your models. 

Intersect  is one of the boolean operations in Shapr3D that you can use to create new bodies from the 
intersection of overlapping bodies. To use this tool, you must have at least two overlapping bodies. 

To use the Intersect tool: 

1. Go to Tools > Intersect. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the target body or bodies that you want to modify. Target bodies will be highlighted in purple 
and marked with a target badge. 
Note: In History, this body will be your Target parameter. You can select the badge to toggle the 
desired state of the selected body. 

3. Select the intersecting body or bodies. These bodies are highlighted in blue and marked with a tool 
badge. 
Note: In History, this body will be your Tool parameter. You can select the badge to toggle the 
desired state of the selected body. 

4. If necessary, adjust the Keep Originals setting at the left with any of the following: 
○ Keep Originals: Off - When set to Off, only the body resulting from the Intersect remains. 

The original bodies will be removed. This is the default setting. 
○ Keep Originals: On - When set to On, the results of the Intersect are created as a new 

body and the original bodies will still be available.  
5.  Select Done. 

History settings 
To manage history settings for the Intersect action, find the step for your specific intersection and then view 
or modify the following: 

● Target – Click/tap Edit… or Select… to choose a different body you want to intersect and then 
select Done to finish. 

● Tool – Click/tap Edit… or Select… to choose a different body you want to modify/intersect with and 
then select Done to finish. 

● Type – Select the dropdown to update the boolean type to either Union, Subtract, or Intersect. 
Note: Make sure to update the Target and Tool settings that apply to your selected boolean type. 

● Keep Target Bodies – Turn on to keep target bodies. 
● Keep Tool Bodies – Turn on to keep tool bodies. 

Learn more by watching the video below: 

 Shapr3D Manual - Intersect | Tools
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Split Body 
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You can use the Split Body tool to cut apart 3D bodies with construction planes, grid planes, sketch 
profiles, faces, or images. This allows you to split a body into multiple bodies without removing any 
material. 

To use the Split Body tool: 

1. Go to Tools > Split Body. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the bodies that you want to split. Bodies to split will be highlighted in blue and marked with 
the Split Body badge. 

3. Select a construction plane, grid plane, sketch profile, face, or image for the splitting tool. The 
splitting tool will be highlighted in purple and marked with a target badge. 
Splitting tools are projected through the body being split. Therefore, the splitting tool does not need 
to be in direct contact with the body. 
Note: You can select the badges to redefine selections and toggle them on and off. 

4. If necessary, adjust the Keep Originals setting at the left with any of the following: 
○ Keep Originals: Off: When set to Off, only the bodies resulting from the Split Body tool will 

remain. The original body will be removed. This is the default setting. 
○ Keep Originals: On: When set to On, the results of the Split Body tool will be created as 

new bodies and the original body will still be available. 
5. Select Done. 

History settings 
To manage history settings for the Split Body action, find the step for your specific split body and then view 
or modify the following: 

● Target – Click/tap Edit… or Select… to choose a different body you want to split and then select 
Done to finish. 

● Surface – Click/tap Edit… or Select… to choose a different surface you want to use as the splitting 
tool and then select Done to finish. 

● Keep Originals – Toggle the slider to turn on or off the original body. 

Learn more by watching the video below: 

 Shapr3D Manual - Split Body | Tools
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Revolve 
[Article link | Table of contents | Back | Next] 

You can use the Revolve tool to create solid bodies that are symmetrical about an axis. Some shapes that 
are commonly created using Revolve include cylinders, cones, spheres, or any axial symmetry, round 
shapes. The Revolve tool also includes a height parameter that allows you to generate shapes such as 
coils, springs, and threads. 

Using the Revolve tool 
To create a Revolve, you will need a profile and an axis of revolution. The profile can be a closed sketch or 
a face. The axis can be an axis of the grid, a construction axis, a sketch line, or a linear edge. The Revolve 
tool rotates the profile about the axis to generate the solid geometry. By default, the profile is revolved by 
360°, but you can modify the angle value as necessary. To generate a helical shape, you can specify a 
height for the revolve action. 

To use the Revolve tool:  

1. Ensure you have the elements necessary for the Revolve, including: 
○ Profile: A sketch profile or face representing half of the finished body's cross-section.  
○ Axis: An axis, line, or linear edge element at the center of rotation for the body. 

2. Go to Tools > Revolve. 
For other methods of accessing this tool, visit Accessing tools. 

3. Select the profile. 
4. Select the axis. 
5. Optional: Use the gizmo to adjust the angle for the revolve. 
6. If necessary, adjust the height for the revolve to create a helical shape (see Creating helical bodies). 
7. Select Done. 

Note: When using Revolve from the adaptive menu, select an empty area of the grid to complete 
the tool. 

Creating helical bodies 
Helical bodies are created by defining a height value within the Revolve tool.  

To create a helical body:  

1. Ensure you have the elements necessary for the Revolve, including: 
○ Profile: A sketch profile or face representing half of the finished body's cross-section.  
○ Axis: An axis, line, or linear edge element at the center of rotation for the body. 

2. Go to Tools > Revolve. 
For other methods of accessing this tool, visit Accessing tools. 

3. Select the profile. 
4. Select the axis. 
5. Use the gizmo to adjust the angle for the revolve action. 

Note: Every 360° equals a complete revolution of the helix. You can use the calculator functionality 
to multiply 360 by the number of revolutions. 

6. Use the gizmo to adjust the height for the revolve action. 
7. Select Done. 

Note: When using Revolve from the adaptive menu, select an empty area of the grid to complete 
the tool. 
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History settings 
To manage history settings for the Revolve action, find the step for your specific revolution and then view or 
modify the following: 

● Profile – Click/tap Edit… or Select… to choose a different sketch profile for the Revolve action and 
then select Done to finish. 

● Axis –  Click/tap Edit… or Select… to choose a different reference axis for the Revolve action and 
then select Done to finish.   

● Angle – Enter your preferred angle. 
● Elevation – Enter your preferred elevation distance. 

Learn more by watching the video below: 

 Shapr3D Manual - Revolve | Tools
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Sweep 
[Article link | Table of contents | Back | Next] 

The Sweep tool can extrude a profile along a selected path. The profile can be a closed sketch or face. The 
path, or spine, can be sketch elements or edges of a body. This tool is useful for creating complex bodies 
such as pipe systems, cables, wires, and other shapes with a uniform cross-section. For shapes that have 
varying cross-sections, use the Loft tool. 

To use the Sweep tool: 

1. Ensure you have the elements necessary for the Sweep, including: 
○ Profile: A sketch profile or face that you will extrude. 
○ Spine: Sketch elements or edges that the profile will follow. 

2. Go to Tools > Sweep tool. 
For other methods of accessing this tool, visit Accessing tools. 

3. Select the profile or profiles.  
4. Select Next. 
5. Select the spine or spines. 
6. Select Done. 

 Tip 
 
When using Sweep from the adaptive menu, select the profile and all spines before activating the 
tool. 

History settings 
To manage history settings for the Sweep action, find the step for your specific sweep and then view or 
modify the following: 

● Profile – Click/tap Edit… or Select… to choose a different sketch profile for the Sweep action and 
then select Done to finish. 

● Path – Click/tap Edit… or Select… to choose a different path for the Sweep action and then select 
Done to finish.  
 

Learn more by watching the video below: 

 Shapr3D Manual - Sweep | Tools
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Replace Face 
[Article link | Table of contents | Back | Next] 

You can use the Replace Face tool to extend or trim a selected face to match another face. Replace Face 
can be a useful tool to modify flat planar faces generated by tools such as extrude. It can also be an 
effective method for matching the faces of connected bodies.  

To use the Replace Face tool: 

1. Go to Tools > Replace Face. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select the face or faces you want to replace. Faces to replace will be highlighted in blue and marked 
with the Replace Face badge. 
Note: You can select the badge to redefine a face as a face to be replaced or a target face.  

3. Select the replacement face. This face will be highlighted in purple and marked with the target 
badge. The face you are replacing will be extended or trimmed to meet the target face. 
Note: You can select the badge to redefine a face as a face to be replaced or a target face.  

4. If necessary, adjust the Other Side setting at the left.  
5. Select Done. 

History settings 
To manage history settings for the Replace Face action, find the step for your specific replacement face and 
then view or modify the following: 

● Faces to Replace – Click/tap Edit… or Select… to choose a different face to replace and then 
select Done to finish. 

● Replacing Face – Click/tap Edit… or Select… to choose a different replacing face and then select 
Done to finish. 

● Other Side – Turn on to extend the face replacement to the other side of the replacing face. 

Learn more by watching the video below: 

 Shapr3D Manual - Replace Face | Tools
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Offset Edge (3D) 
[Article link | Table of contents | Back | Next] 

The Offset Edge tool creates new sketch elements that are offset from existing elements by a specified 
distance. You can use the Offset Edge tool within a sketch, with sketch profiles, or with the edges and 
faces of a 3D body.  

To offset from a 3D body: 

1. Go to Tools > Offset Edge. 
For other methods of accessing this tool, visit Accessing tools. 

2. Select Type to access the Offset Edge Type menu. 
3. Choose an offset type: 

● Loop – Offsets a loop of edges from a 3D body. 
● Single – Offsets a single edge from a 3D body. 

4. Select the edge you want to offset. 
5. Use the gizmo to specify the offset direction and distance. 
6. To finish, select Done. 

History settings 
To manage history settings for the automatic Offset Edge action, find the step for your specific sketch and 
then view or modify the following: 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

Learn more by watching the video below: 

 Shapr3D Manual - Offset Edge (3D) | Tools

 Read more 
 
For information on using Offset Edge within a sketch, visit Offset Edge (Sketch). 
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Project 
[Article link | Table of contents | Back | Next] 

You can use the Project tool to cast or project sketches, edges, or faces onto another face or sketch. 

Projections create a relation or connection with the projected items that allows you to:  

● Project different types of items onto complex, non-planar faces. 
● Create sketches on faces based on existing 3D geometry. 
● Create reference geometry that you can use for other operations. 
● Merge sketches that are on the same plane but belong to separate sketches. 

Create projections of items 
To use the Project tool: 

1. Go to Tools > Project. 
For other methods of accessing this tool, visit Accessing tools. 

2. Choose a Projection Type. 
● Edges – The resulting projection will create new edges. 
● Sketches – The resulting projection will create new sketches. 

Note: You can also access this option while on sketch mode under Sketch > Project - 
Sketches. 

3. Select the item you want to project. In History, this selection becomes your Items to Project 
parameter. 
Note: Each selection is indicated with a blue badge. You can click/tap the badge to change or 
cancel the selection. 

4. Select the surface that you want to project on. In History, this selection becomes your Projection 
surface parameter. 
Note: The target surface will be colored purple, and you’ll see a preview of your projection. You can 
click/tap the badge to change or cancel the selection. 

5. To finish, select Done. 

Edge projections 

Unlike sketch projections, edge projections are created like geometrical properties of the body. 
 
When you project your items as edges to a surface of a body, the resulting edge projection: 

● splits the surface into different sections 
● is always visible with the body even if sketches are hidden 
● automatically follows any changes or adjustments you make to the shape or size of the original item 

you projected 
 
Check out some examples below to learn how you can use edge projections  in your modeling workflow. 
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Example 1 
In the example model, we have a bottle with groove designs on the cap. 
 

 
 
To achieve these grooves, we can use the Project tool to project a rectangular-shaped edge onto a 
cylindrical body and then use the Chamfer/Fillet tool to create the desired shape and curves: 
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Lastly, you can use the Pattern tool to create a circular pattern around the cylinder. 
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Example 2 
In the example model below, we have a circular ridge on a non-planar surface of the body. 
 

 
 
To create this kind of ridge on this particular surface, we can use the Project tool to create a circular 
projection onto the applicable surfaces. 
 

 
 

229 



 
 
We can then use the Sweep tool to create the ridge by using the circular projection as the spine or path. To 
create the sketch profile, we can simply add an On Curve at Point construction plane to the circular 
projection. 
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Sketch projections 
Sketch projections are useful for creating references or visualizing aspects of your design such as when 
you need a reference to better understand spatial relationships between different parts of your  model. You 
can also use the Project tool to merge sketches that are on the same plane but exist in separate sketches, 
combining them into a single unified sketch for easier management and editing. 
 
When you project your items as sketches to a surface of a body, the resulting sketch projection: 

● is treated like a regular sketch item that can be hidden in the Items Manager 
● can be used a reference sketches similar to how you treat sketches when directly sketching on a 

face 
 
Check out the example below to learn how you can use sketch projections in your modeling workflow. 
 

Example  

In the example model below, we have an elliptical hole going through the rounded corners of the body. 
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To make a hole that perfectly fits the rounder corners, we can create a sketch projection of the curved 
edges onto a sketch plane. 

 

We can then draw the ellipse on the sketch plane while using the sketch projections as guides and then use 
the Extrude tool to cut the hole shape we want. 
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Items to project 
Items you can project onto another surface can be sketches, edges, faces, or entire bodies. 
 

Items to project Sample scenario 

Sketches You want to create the same sketch on a specific planar surface of your 
model. 

Edges You need a reference for the distance between edges when you need to 
create a sketch that fits the edge dimensions.  

Faces You want to create an engraving of a specific face onto a surface of your 
model. 

Entire bodies You want to create a 2D symbol for the shape of the entire body. 

 

Projection surface 
Surfaces you can project onto can be planar or non-planar surfaces: 

● Planar – You can create both edge and sketch projections. 
● Non-planar – You can only create edge projections. Sketch projections aren’t possible similar to 

how you can’t create sketches directly on non-planar surfaces. 
 

Projection surface Sample scenario 

Planar You want to project a complex shape onto a specific surface of your model. 

Non-planar You want a complex shape to conform to the curvature and contour of a 
specific surface of your model. 

Relation between projections and projected items 
When you create projections, a relation or connection is formed between the original item and the resulting 
projection. 
 
Similar to the sketch pattern constraint concept, your projections will automatically follow any adjustments 
you make to the size or shape of the original item you projected. 
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History settings 
To manage history settings for the Project action, find the step for your specific projection and then view or 
modify the following: 

Edge projections 
The default name for edge projections is Projection. 

● Projection Surface – Click/tap Edit… or Select… to modify the projection surface and then select 
Done to finish. 

● Items to Project –  Click/tap Edit… or Select… to modify the items to project and then select Done 
to finish. 
 

Sketch projections 
Just like regular sketch items, the default name for sketch projections is Sketch. 

● Plane – Click/tap Edit… or Select… to modify the plane or face where you want the sketch to be 
and then select Done. 

● Projection – Click/tap Edit… or Select… to modify any existing projections for your sketch. 

Learn more by watching the video below: 

 Shapr3D Manual - Project | Tools
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Visualize 
[Article link | Table of contents | Back | Next] 

The Visualize tool from the Tools menu is another way to access the Visualization tool. To learn about 
this tool, go to Visualization. 
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Modes 
Quick-toggle modes 
[Subsection link | Table of contents | Back ] 

Isolate 
[Article link | Table of contents | Back | Next] 

You can isolate items in your model to easily work on specific parts or bodies without distractions. 
 
To isolate an item: 

1. Select the item or items you want to isolate. 

2. From the selection-based modes, select Isolate  to turn it on. 

3. To turn off Isolate, select . 
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Section View 
[Article link | Table of contents | Back | Next] 

The Section View tool lets you look inside your 3D model by cutting through it along a selected plane or 
face. This is useful when analyzing internal details or checking cross-sections for fit and function. 

When you turn on Section View, the visible part of your model is clipped based on the active plane, and 
cross-sections are rendered with clear fill patterns and colors to help you distinguish bodies more easily. 

Create a section view 
To create a section view in the modeling space: 

1. Select a plane or planar face to define the clipping direction. or example, choose the Top plane to 
view a top-down cross-section. 

2. From the modeling space modes, select  to turn on Section view. 
Note: You can also turn on Section View first and then select a plane to get the same result.  

3. Once Section View is on and a plane is selected, you can analyze the internal details and work 
directly with the geometry in the sectioned view. 

4. Optional: Adjust the cut using the gizmo on the plane: 
a. Drag the arrows to move the plane deeper or shallower through the body. 
b. Rotate the gizmo handles to tilt the cut at an angle. 
c. Select the Flip badge to switch which side of the model is visible. 

5. To turn off Section View, select .  

You can also turn on Section View after selecting a plane or face to immediately generate a cross-section 
along that reference. 

Section View visuals 
When Section View is active, Shapr3D automatically applies section fills and contrasting colors to clipped 
bodies. This makes it easier to interpret cross-sections and inspect internal geometry. 

● Cut areas are filled based on body properties for better contrast 
● Intersections and overlaps between parts are easier to identify 
● Useful for reviewing complex assemblies or multi-body designs 
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Work with geometry in Section View 
Beyond inspection, Section View also allows you to interact directly with your model, making it easier to 
work on complex designs without needing to isolate or hide parts. When Section View is active, you can: 

● Sketch on the datum plane (e.g. a construction plane) used to define the section cut 
Note: Moving or adjusting the plane will currently prevent further sketching on the updated cut. 

● Measure internal features without hiding geometry 
● Select and edit items more easily inside complex areas 
● Modify bodies and features that are otherwise hard to access 

 Tip 
 
To change the active section plane, select a different face or plane and turn on Section View 
again. This is a quick way to inspect your model from different orientations. 
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Measure 
[Article link | Table of contents | Back | Next] 

Every sketch, face, and body in Shapr3D is built with precise parameters. Measure lets you view the 
exact dimensions of elements in your model. When you turn on Measure mode, a panel appears 
where you can view and pin measurements for selected elements. The panel stays open while you 
work and can be moved anywhere on your screen. 

View measurements 

From the Measure Panel 
Turn on Measure mode to display dimensions for selected bodies, faces, edges, or sketches. 
 

1. From the modes in the main menu, select Measure to turn on Measure mode. 
2. Make measurements of items you want to measure. 
3. View the measurement of the selected items under Pin to Always Show. 
4. Pin measurements you want to keep. 
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From the modeling space 
For quick reference, you can select items in the modeling space to view the selection information at the 
bottom of the screen. The selection information includes the measurement details of the selected items. 

Depending on the type of object you select, you can view the following quantitative data: 

● Length  – Length of a line. If you select multiple lines, the sum is shown. 

● Area – Area of a face. If you select multiple faces, the sum is shown. 

● Volume  – The volume of a body. If you select multiple bodies, the sum is shown. 

● Radius  – The radius of an arc, circle, sphere, cone, or cylinder. 

● Diameter  – The diameter of an arc, circle, sphere, cone, or cylinder. 

● Angle – The angle between any two lines or two faces. If you select an arc, its central 
angle is shown. 

● Perpendicular angle  – A perpendicular angle between two lines or two faces. 

● Minimum distance – The shortest distance between two lines, arcs, circles, non-parallel 
faces, or bodies. It can also be the shortest distance between any combination of two of the 
following: circle, arc, line, face, or body. 

● Central distance  – The central distance between a center point or central axis and any 
of the following: line, arc, circle, parallel face, or body. Center points are calculated for 
circles, cones, and spheres. For bodies, the distance from the center of gravity is calculated. 

● Parallel distance  – The distance between two parallel items such as sketches, edges, 
and faces. Note that it is possible to calculate the distance between an edge and a parallel 
face. This also shows the radial difference of concentric arcs, circles, spheres, and cylinders. 

● X-axis  – The distance on the X-axis between two lines, arcs, circles, non-parallel faces, 
or bodies. It can also be the distance between a combination of two of the following: circle, 
arc, line, face, and body. 

● Y-axis – The distance on the Y-axis between two lines, arcs, circles, non-parallel faces, 
or bodies. It can also be the distance between a combination of two of the following: circle, 
arc, line, face, and body. 

● Z-axis  –  The distance on the Z-axis between two lines, arcs, circles, non-parallel faces, 
or bodies. It can also be the distance between a combination of two of the following: circle, 
arc, line, face, and body. 
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Make measurements 
To make measurements, select Measure from the available modes and then choose a measurement mode 
from the menu. 
 

Object measurements 
Use Object Measurements to measure the size or dimensions of a single body, face, or edge: 
 

1. From the available modes, select Measure. 
2. Open the Measure menu and then select Object Measurements. 
3. Select the body, face, or edge you want to measure. 
4. In the Measure pop-up panel,verify that the measurements have been added under Pin to Always 

Show.  
5. Optional: Turn on Include X, Y, Z Deltas to display the distances along each axis in addition to the 

overall measurement. 
6. Optional: Pin measurements that you want to keep. 
7. To exit Measure mode, select Measure or close the Measure panel. 

Point-to-point measurements 
Use Point-to-Point Measurements to measure the distance between notable points: 

1. From the available modes, select Measure. 
2. Open the Measure menu and then select Point-to-Point measurement. 
3. Optional: Select a face or hover over a face to find notable points. 
4. Select the notable points you want to measure. 
5. Optional: Move already placed points to new notable points. 
6. Optional: Turn on Include X, Y, Z Deltas to display the distances along each axis in addition to the 

overall measurement. 
7. Optional: Pin measurements that you want to keep. 
8. To exit Measure mode, select Measure or close the Measure panel. 

3-Point Angle 
Use 3-Point Angle to measure the subtended angle of three notable points: 

1. From the available modes, select Measure. 
2. Open the Measure menu and then select 3-Point Angle. 
3. Optional: Select a face or hover over a face to find notable points. 
4. Select three notable points you want to measure. 
5. Optional: Move already placed points to new notable points. 
6. Optional: Turn on Include X, Y, Z Deltas to display the distances along each axis in addition to the 

overall measurement. 
7. Optional: Pin measurements that you want to keep. 
8. To exit Measure mode, select Measure or close the Measure panel. 
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Highlight measurements 
You can highlight measurements to see visual feedback in the modeling space and easily identify the edge, 
face, or point the measurement refers to. The highlight disappears when you move the cursor or tap 
elsewhere. 

To highlight measurements: 

● Keyboard and mouse/trackpad: Hover over a measurement in the Measure panel. 
● Touch and pen: Tap a measurement in the panel. 

Pin measurements 
Pin measurements to keep them visible as annotations in your model. You can pin both active 
measurements you're currently taking and any existing measurements from the panel. 
 
Pinned measurements stay visible while you work, making it easier to reference dimensions and 
communicate with others. 
 
To pin a measurement: 

1. While in Measure mode, select the Pin  beside a measurement in the Measure panel. 
2. View your pinned measurements anytime under Pinned in the panel and in your model. 
3. Optional: To delete or unpin a pinned measurement go back to the pop-up panel and select Delete 

 beside the pinned measurement. 

Learn more by watching the video below: 
 

 Shapr3D Manual - Measure your models | Modes
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Collaboration 
Tools and features for sharing projects, reviewing designs, and working with your team in Shapr3D 
[Section link | Table of contents | Back | Next] 

Team Collaboration 
[Article link | Table of contents | Back | Next] 

Shapr3D supports team collaboration with built-in tools for sharing, reviewing, and presenting designs 
across devices and workflows. You can work on shared projects with teammates, track design progress, 
and present models in a browser or real-world scale. 

Team projects 
Projects stored in a shared space are automatically shared with your team. You can organize these projects 
into folders, assign access levels, and collaborate across devices with contributors and editors. 

To learn more, visit Shapr3D Dashboard. 

Project Versions 
Project Versions lets you restore earlier versions of your work, making it easy to test changes or revisit past 
design decisions without losing progress. 

To learn more, visit Project Versions. 

Saved Views 
Use Saved Views to bookmark specific angles or features of your design. You can return to these views 
instantly during presentations or model reviews for consistent context. 

To adjust how your model is displayed, visit Views and Appearance. 

Review Links 
A Review Link allows you to share a 3D preview of your model with others. Individuals with access can 
open the link in a browser to view 3D and 2D models, and leave comments if commenting is enabled. 

To learn more, visit Review Links. 

Augmented Reality (AR) 
Opening a Review Link on a supported mobile device lets you see your design in Augmented Reality. This 
helps you evaluate scale, placement, and proportions in a real-world setting. 

To learn more, visit Augmented Reality. 
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Vision Pro (Enterprise only) 
Enterprise users can review designs using Vision Pro. Invite collaborators into an immersive workspace to 
explore your model in room-scale. 

To learn more, explore our Vision Pro articles. 

Capture tool via Visualization 
Use the Capture tool  to get snapshots of your model without the grid and other unwanted project 
elements. This is ideal for reviews, presentations, or marketing material. Saved images can be annotated 
using your device’s built-in tools to highlight feedback or areas of interest. 

To learn more, visit Capture images of your visualized model. 

Screenshot tool 
The Screenshot tool allows you to take quick snapshots of your model with adjustable visibility and 
appearance settings. Saved screenshots can be annotated directly on your device, making it easy to add 
notes and share feedback visually. 

To learn more, visit Screenshot tool. 
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Review Links 
[Article link | Table of contents | Back | Next] 

Review Links let you share your 3D models and 2D Drawings through a secure web link. Viewers can open 
your project in any modern browser without installing Shapr3D. You can control access by sharing the link 
publicly, restricting it to your team, or inviting specific individuals for a more private review. 

Generate a Review Link 
To create a Review Link: 

1. From the top bar, select Share to open the Share This Project modal. 
2. To generate your Review Link, select Share beside Share Design Review Link. 

Note: Select  beside Share to manage Privacy and Access Settings before generating the 
link. 

3. Select Create Link. If Sync is disabled, you’ll be prompted to enable it before continuing. 
Note: If Sync is disabled, a prompt will appear when you create a link. Enable Sync to continue. 

Manage privacy and access settings 
Once the Review Link is created, you can manage its settings under Share: 

● Review Link – Copy the link to share it with selected users. 
● Link Settings – Choose who can view the link and whether to make them a Viewer or Commenter. 

○ Anyone with the link – Anyone can view your project. 
○ Only the people invited – Only people invited to view your Review Link can view the 

project. 
○ Members of this team – Only team members logged into Shapr3D can access the project. 

● Include Visualization Materials – Disable this setting to speed up link creation and improve 
viewing performance on mobile devices. 

● Include 2D Drawings – Enable this setting to include 2D Drawings in the Review Link. 
● Comments– Shows the number of comments in your Review Link. Select Open to quickly view the 

link and its comments. 
● Export as a File – Another way to Export your project. 

Note: After making any changes to the Review Link settings, select Publish Changes to apply them. To 
deactivate the Review Link, select Unpublish. 
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View projects via the Review Link 
View shared projects by opening the Review Link in any modern web browser. You can explore 3D models, 
review 2D drawings, and leave comments directly for fast, focused feedback. 

3D Models 
Explore shared 3D models directly in your browser with intuitive navigation and feedback tools. 
 

● Interact with models: Move, rotate, and zoom in or out to explore every detail. 
● Use Augmented Reality (AR): Click the AR button to visualize your models in a physical 

environment. To learn more, visit Augmented Reality. 
● Collaborate with comments: Team members can view and add comments directly to specific parts 

of the model. To learn more, go to Collaborate with comments. 

2D Drawings 
When 2D Drawings are included in a Review Link, a sidebar provides quick access to these 2D Drawings, 
making it easy to review detailed views alongside your 3D models. Here’s how you can interact with and 
save 2D Drawings: 

● Show or hide drawings: Click the sidebar to toggle the visibility of available 2D Drawings. 
● Interact with drawings: Move, zoom in, or zoom out while viewing the 2D drawing. 
● Save or copy the drawing: Right-click (secondary click) the drawing and select Save Image As… 

or Copy Image. 
● Download as PDF: Click the Download PDF button to save a PDF copy of the drawing. 
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Invite users and manage access 
You can control who can view or comment on your Review Link by managing access permissions. Use the 
Share button to invite users, assign roles, adjust access settings, or copy the link as needed. 
 

Invite users to view a Review Link 
You can invite specific users to access your Review Link without making the link public. Invited users will 
receive an email with a link to view the project. If they don’t have a Shapr3D account, they’ll need to sign up 
before accessing the Review Link. 
 
To invite a new user: 

1. Select the Share. 
2. In the Emails field under People with access, enter the email address(es) of the person/people 

you want to invite. 
3. From the dropdown beside, select their role: 

○ Viewer – Can view the project but cannot comment. 
○ Commenter – Can view and leave comments. 

4. Select Invite. 
5. To save the changes, select Done. 

Manage Review Link access 
You can control who can view or comment on your Review Link by adjusting General access settings. 
Choose between allowing anyone with the link to access the project or restricting it to team members only. 
 
To manage access settings: 

1. Select Share. 
2. Under General access, choose who can access the Review Link: 

○ Anyone with the link – Grants access to anyone who has the link. 
○ Members of this team – Restricts access to team members only. 

3. From the dropdown beside the selected option, choose a role: 
○ Viewer – Can view the project but cannot comment. 
○ Commenter – Can view and leave comments. 

4. To save the changes, select Done. 
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Collaborate with comments 
Review Links let team members and invited commenters leave context-specific comments directly on your 
design. Commenting is enabled by default and works in desktop browsers when signed into a Shapr3D 
account. 

Add comments 
Team members and invited commenters can add comments directly when viewing the Review Link on a 
desktop browser while signed in to a Shapr3D account. 
 
 
To add comments: 

1. Open the Review Link from a desktop web browser. 
2. If you haven’t yet, log in to your Shapr3D account. 

3. Click the Add comment . 
4. Select any part of the model you want to comment on. 
5. Enter your comment in the comment field. 
6. To finish, select Send. 

View comments 
Collaborate seamlessly by viewing comments directly on the Review Link page. 

● Show or hide comments: Click to toggle comment visibility. 
● Open specific comments: Click on a comment to navigate to the part of the model where it was 

added. 
● Refresh for updates: Reload the page to view the latest comments added by your team. 
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Augmented Reality 
[Article link | Table of contents | Back | Next] 

Shapr3D supports augmented reality (AR) which allows you to visualize your 3D model in the real world on 
your camera-equipped device by creating a virtual prototype of your project. With AR technology, you can 
see exactly how your project will look in its intended place. 

This kind of visualization provides great feedback on different project aspects, from dimensions to 
aesthetics, giving you more insight into your prototype project at any point in your workflow. If you see 
something that could be tweaked or doesn’t quite match up with what you imagined, you can make the 
required adjustments immediately. 

Requirements 
To use the AR feature, you need a device with a rear-facing camera that supports Augmented Reality. This 
includes most modern smartphones, all iPadOS, and a few Windows tablets. 

Accessing AR 
There are three main ways to use AR: 

1. On iPadOS devices, you can launch an AR preview directly from the app. 
2. Generate a Review link and open the link with your smartphone. 
3. Export your project in a suitable format and use a 3rd party application. 
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AR previews on iPads 

If you are on an iPad, AR preview can be accessed in multiple ways: 

● While in Visualization, select the AR icon at the top. 
● From the modeling space, access AR preview through any of the following: 

○ Go to Export > Usage tab > USDZ > Preview in Augmented Reality 
○ Select Share > Export > Export Project > USDZ > Preview in Augmented Reality 

To use AR, simply aim your device's camera to a setting in which you want to visualize your model. 

Use your touch to freely move and scale the model so it fits better in your environment.  

You can also check the rendered model and zoom in on the details by selecting the Object tab at the top. 

Return to the AR tab and select the Shutter button to capture the screen. The exported image will 
automatically save to your gallery.  

Using a smartphone via the Review Link 
This is the easiest way if you are designing on a laptop or a desktop computer without a rear-facing 
camera. 
 

1. Generate a Review link. 
2. Open the link on your smartphone. 

● Apple Continuity, Microsoft Phone Link and Microsoft Edge Sync are features that make it 
very easy. 

● Alternatively, you can open the link in your desktop browser, click the AR button and read 
the QR code on the screen with your phone camera. 

3. Tap the AR icon in your mobile browser. 

Exporting your project and use a 3rd-party application 
You can also export your projects in a suitable format and open it in 3rd-party applications that support 
Augmented Reality previews, such as Microsoft 3D Viewer, Apple Quick Look or Adobe Aero. 
 
The best visual quality can be achieved through the USDZ format, currently only available on Apple 
platforms. 3MF is widely supported but at the moment we don’t include materials or colors set in 
Visualization in the export. 
 
To learn more about exporting in different formats, visit Export. 
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Capture images of your visualized model 
[Article link | Table of contents | Back | Next] 

Visualization lets you present your models with realistic materials, lighting, and finishes. With over 100 
material and finish types available, you can customize how your model appears to reflect the final product 
more accurately. 
 
The Capture tool in Visualization saves high-quality images of your visualized model without gridlines or 
interface elements. In contrast, the Screenshot tool captures the modeling space and gives you the option 
to include visual guides and UI elements. Use the Capture tool when you need clean visuals for 
presentations, reviews, or client discussions. 

To capture images in Visualization: 

1. Go to Visualization. 
2. At the top, select Capture to get snapshots of your visualized models. 
3. In the Save dialog, enter a filename and choose where you want to save your captured image. 
4. Select Save. 

 Read more 
 
To learn more, visit Visualization. 
 
To learn how to capture images of your model from the modeling space, visit Screenshot tool. 
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Screenshot tool 
[Article link | Table of contents | Back | Next] 

You can use the Screenshot tool to take clean snapshots of your model directly from the modeling space. 
Before capturing, you can customize how your model looks by adjusting visual elements like the grid, 
background, and body edges. 

Use screenshots to: 

● Capture quick visuals without UI elements 
● Adjust visibility settings for clarity 
● Save or copy images for presentations or feedback 

How to take a screenshot 
To take a screenshot: 

1. Open your project in Shapr3D.  
2. Go to Export. 
3. From the available list of file formats, select Image. 
4. Under Image file, select Open Screenshot Tool… beside Capture Screenshot. 
5. Use the menu to customize how you want your exported image to look: 

● Grid  – Remove or keep the grid in the background. 

● Transparency – Make the background transparent or filled. 

● Body Edges  – Render your project with or without edges. 
Note: You can also open the Items Manager to choose which items to display. 

6. To capture your model, select Capture . 
7. In the Save dialog, enter a filename and choose where you want to save your captured image. 
8. To finish, select Save. 

Copy and reuse your last screenshot setup 
The Screenshot tool lets you quickly reuse and share the same captured view without setting it up again. 
Here's how it works: 

● The tool remembers your last used settings, including grid, transparency, and edge visibility. 
● Your saved settings are applied automatically when you reopen the tool. 
● You can use a keyboard shortcut to copy your last screenshot without reopening the tool. 
● The copied image is saved to your clipboard, ready to paste into emails, slides, or any document 

tool where you need to present your design. 
 

Read more 
 
To learn how to save images of your visualized models, visit Capture images of your visualized 
model. 
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Import and export 
Supported file types, exporting, and importing 
[Section link | Table of contents | Back | Next] 

Supported file types 
[Article link | Table of contents | Back | Next] 

Shapr3D supports a wide range of file types for easy integration with other CAD systems and collaboration. 
Below are the details of supported file types for importing and exporting, along with subscription-based 
limitations. 

Importing 
You can import a wide range of file formats into Shapr3D, making it easy to bring in designs from other CAD 
software. Whether you’re importing sketches, models, or drawings, you can seamlessly work with various 
supported file formats. 

 Feature availability by plan 
 

● Shapr3D Basic: 2D and 3D industry-standard formats, limited up to 2 projects only. 
● Shapr3D Pro: 2D and 3D industry-standard formats. 
● Shapr3D Enterprise: 2D and 3D industry-standard formats, plus advanced CAD file 

formats from leading CAD software like CATIA, Creo, and Solid Edge. 

2D sketches 

● DWG and DXF 
○ 3D data: No 
○ Annotation (text, dimensions, leaders, and arrows): No 
○ Lines: Yes 
○ Polylines: Yes 
○ Bezier curves: Yes 
○ Arcs: Yes 
○ Circles and ellipses: Yes 
○ Polygons: Yes 
○ Names of entities: No 
○ Visibility: No 
○ Line styles (Line weight, pattern): No 
○ Colors: No 
○ Material and texture: No 
○ Relationship between model elements, and constraints: No 
○ Metadata: No 
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3D bodies 

● X_T or X_B 
● STEP  
● IGES 
● STL (for reference only) 
● SHAPR 
● SLDPRT 
● SLDASM (including external references that are not stored in mesh files)  

Images 

● PNG 
● JPG 
● 2D PDF (single or first page only) 
● TIFF  
● BMP 
● ICO  
● RAW 
● GIF (not animated) 

Advanced CAD file formats (Enterprise only) 

NX 

● Part/Assembly: .prt 

CATIA 

● Part: .catpart 
● Assemblty: .catproduct 

Creo 

● Part: .prt 
● Assembly: .asm 

Solid Edge 

● Part: .par 
● Assembly: .asm, .psm 

JT 

● Part/Assembly: .jt 
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Exporting 
Shapr3D offers flexible exporting options, allowing you to share and collaborate across different platforms. 
You can easily export your designs in multiple file formats, ensuring compatibility with various tools and 
workflows. 

 Feature availability by plan 
 

● Shapr3D Basic: Low-resolution STL and 3MF formats only. 
● Shapr3D Pro: 2D and 3D industry-standard formats. 
● Shapr3D Enterprise: 2D and 3D industry-standard formats, plus advanced CAD file 

formats from leading CAD software. 

 

2D  

● DWG (sketches and 2D Drawings) 
● DXF (sketches and 2D Drawings) 
● PDF 
● JPEG 
● PNG 
● SVG 

Note: When exporting sketches, unsupported drafting elements such as layers, hatches, and 
annotations are filtered out. 

3D  

● SHAPR (the native file format of Shapr3D) 
Note: If you have Sync disabled, you can use our native SHAPR format to transfer models between 
different Shapr3D platforms. 

● X_T or X_B 
● STEP 
● 3MF 
● IGES 
● OBJ (with colors) 
● STL 
● GLB 
● USDZ 

Advanced CAD file formats (Enterprise only) 

JT 

● Part/Assembly: .jt 
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Import 
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You can import a wide range of file formats into Shapr3D, allowing you to easily bring in designs from other 
CAD software. From sketches to 3D models and technical drawings, this article guides you through the 
process of importing supported formats. 

Before you begin 
● Ensure that you’re importing supported file types. 
● Verify that the source file is not damaged or corrupted. 
● Confirm that your device has enough memory to process the import. 
● The source model should fit within Shapr3D’s design space, which is 1 km³. 
● Avoid importing files that include sketches with polylines. 

Note: Some lines and curves from other software may not display accurately in Shapr3D. 

Import your projects 

Windows 

To import a file, follow these steps: 

1. Access the Import tool through any of the following: 
● From the modeling space,  

○ go to File and then choose between Import as a New Project… or Import to 
Current Project… 

○ or, go to the Add menu > Image or File. 

● From the Dashboard, go to Projects > Import . 
2. Select the file you want to import > Open. 

Note: For images, you can use the gizmo to position the image, and the Opacity slider to adjust the 
transparency. Select Done to finish. 

3. Optional: Use the Move/Rotate or Translate tool to reposition your newly imported file. 
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iPadOS 

To import a file, follow these steps:  

1. Access the Import tool through any of the following: 
● From the modeling space, 

○ select Settings  > Import. 
○ or, go to the Add menu > Image or File. 

● From the Dashboard, go to Projects > Import. 
2. Select the method for importing the file from the Import dialog: 

● Files – Select a file from your device or iCloud. 
● Photos – Select a photo from your photo gallery. 
● Camera – Take a new photo with your iPad camera, then choose Use Photo to continue. 

Note: For images, you can use the gizmo to position the image, and the Opacity slider to 
adjust the transparency. Select Done to finish. 

3. Optional: Use the Move/Rotate or Translate tool to reposition your newly imported file. 
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macOS 

To import a file, follow these steps: 

1. Access the Import tool through any of the following: 
○ From the Mac menu, Select File > Import...  
○ From the modeling space, go to the Add menu > Image or File... 

○ From the Dashboard, go to Projects > Import . 
2. Select the file you want to import > Open. 

Note: For images, you can use the gizmo to position the image, and the Opacity slider to adjust the 
transparency. Select Done to finish. 

3. Optional: Use the Move/Rotate or Translate tool to reposition your newly imported file. 

 Tip 
 

● You can also drag and drop a file or image into the Shapr3D icon in the dock on your Mac 
desktop. 

● If you want to import images from the Photos app, you may need to allow Shapr3D access 
to the photos on your device. To grant access, go to System Preferences > Security & 
Privacy. 
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History settings 
To manage the Import action from the History sidebar: 

1. Open History. 
2. Look for the import step you want to edit. 
3. Click or tap Settings (…) to modify the history settings for the import step. 

 Tip 
 
Files you import are automatically added to your Items Manager. If you import a 3D model in 
STEP format, the hierarchical structure of the source model is retained in Shapr3D. Bodies that 
were grouped together in the same unit (assemblies, parts, components, etc.) are organized into 
nested folders.  
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Export 
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You can export your designs to other software, collaborate seamlessly with your team, or bring your models 
into Apple’s AR ecosystem for immersive visualization. Whether you need to gather feedback or prepare for 
production, Shapr3D gives you the flexibility to move your designs smoothly across platforms. 

Before you begin 
● Ensure that you’re exporting supported file types. 

Export your projects 
To export a file, follow these steps: 

1. From the modeling space, access the Export tool through any of the following: 
○ From the file menu, go to File > Export… 
○ Select Share > Export tab > Export Project. 

2. Choose your preferred format from the available format types. 
3. Optional: To export in batches, click/tap Select and select the formats you need. 
4. If applicable, customize your project details. 
5. Select Export. 
6. Optional: Save your favorite formats before exporting to make future exports quicker and more 

convenient. 
7. In the Save As dialog, enter a file name and choose a location where you want to save your 

exported file. 
8. Select Save. 

Exporting with isolated parts 
You can export isolated parts in any file type except the default .shapr format. Isolated exports to .shapr 
are unavailable to ensure the complete design is preserved in this format. 
 
To export isolated parts: 

1. Isolate the part you want to export. 
2. Follow the steps to export your projects. 

 

File format types 
When exporting, you can select from the list of available formats or choose from specific categories: 

● All formats – View all recommended and supported formats. 
● 3D model – Export formats compatible with 3D models, including Shapr3D native format, 

Parasolid, STEP, IGES, 3MF, STL, and OBJ. 
● 3D print – Export formats for 3D printing, such as STL and 3MF. 
● Sketch – Export sketch files, including DWG, DXF, and SVG. 
● Drawing – Export drawing files, including DWG, DXF, and PDF. 
● AR – Export formats for augmented reality, such as USDZ and GLB. 
● Image – Export images in PNG and JPEG formats. 

 

260 

https://support.shapr3d.com/hc/en-us/articles/7874524196764


 

Project details 
You can customize your projects when exporting with the following details: 

● File name – Enter a name for your project. 
● File Format/Output Format – You have several options: AP203, AP214, AP242, text, ASCII, and 

binary. The latter is the default format since it’s more common and compact.  
● Include Dimensions – Any locked dimensions in your project will be preserved. 
● Include Hidden Items – Turn on the switch if you want hidden items to be saved in the export.  
● Include Mesh Bodies – Turn on the switch if you want mesh bodies to be saved in the export. 
● Compress Geometries – Turn on to compress geometries in your projects. 
● Compress Textures – Turn on to compress textures in your projects. 
● Include Hidden Sketches – Turn on the switch if you want hidden sketches to be saved in the 

export.  
● Include Vertex Colors – Turn on the switch if you want to preserve vertex colors in the export.  
● Resolution – Set the quality of the export. If you want to set a custom resolution, you can set the 

deviation and angle tolerances.  
● Save Each First-Level Item Separately – Turn on the switch if you want to export your project in 

separate, organized files. These files are then compressed into a ZIP file.  
● Save Each Sketch Plane Separately – Turn on the switch if you want to export your project in 

separate, organized files. These files are then compressed into a ZIP file.  
● Units – Set the unit of your export to millimeter, centimeter, meter, inch, or foot. 

Save your favorite formats 
You can save your favorite formats during export to make exporting quicker and more efficient. 

To favorite a format, hover over a file format and then select the star symbol. 

 

Learn more by watching the video below: 

 Shapr3D Manual - Export your projects
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Assemblies 
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An assembly lets the user define specific relations between bodies in the modeling space based on 
geometries. For example, if there are two parts that have holes, it’s possible to set one of the holes on each 
part to be co-axial. With an assembly, a dynamic relationship is set between the parts.  

Shapr3D doesn’t support assemblies yet, but as a workaround, you can use the Align tool to position parts 
together. However, when you move the parts away from their point of connection, they become 
independent from each other, unlike in assemblies where the relationship between the parts is dynamic 
where all the connected parts move together.  

Shapr3D supports loading assemblies created in Solidworks, but keep in mind that the dynamic property of 
an assembly will be lost upon importing it.  

Importing a Solidworks assembly file to Shapr3D 
The methods below show you how to save a Solidworks assembly file and import it to Shapr3D. 

Directly importing the main SLDASM file to Shapr3D 

Refer to Solidworks’ File Menu (SOLIDWORKS Visualize Connected) to learn how to export the main 
SLDASM file, and then follow Import. 

The parts that are used in an assembly are regular CAD models called part in Solidworks with a file 
extension of SLDPRT. These parts can be located anywhere in the storage system. The parts have a link 
that helps locate them from anywhere in the folder structure of the given storage system. The link is a 
standalone file, which is the assembly file with the extension of SLDASM.  

To make sure the assembly can be transferred properly, the link (SLDASM) and the parts (SLDPRT) should 
be transferred altogether. 

Save the assembly file as a Parasolid format (x_t) 

Refer to Solidworks’ Parasolid Export Options to learn how to save a Solidworks assembly file as a 
Parasolid format, and then follow Import. 

Save the assembly file as a STEP format 

Refer to Solidworks' STEP Export Options to learn how to save a Solidworks assembly file as a STEP 
format, and then follow Import.  

Save the assembly file as a virtual component 

Saving the assembly file as a virtual component is the most secure method because it stores all 
subassemblies and parts internally in one file. However, this method might require you to change the way 
you organize your assemblies in Solidworks. 

Refer to Solidworks’ Saving Virtual Components to External Files to learn how to save a Solidworks 
assembly file as a virtual component, and then follow Import.  
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Mesh files 
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Mesh models are made up of polygons that are a collection of vertices, edges, and planar faces. Unlike 
CAD models created in Shapr3D, mesh models don’t have curved edges or faces. However, a higher 
number of polygons in mesh models can result in a smoother and more curved look. 

You can create a mesh model of a CAD design by converting the CAD model within a given tolerance. This 
is the maximum allowed distance between the CAD model and the mesh file. Smaller tolerances need more 
polygons and result in a more accurate model. 

Note: In Shapr3D Basic, the tolerance of mesh models is loose with low-quality export which can result in 
reduced modeling details. While in Shapr3D Pro, tolerances are exported in high-quality and you can also 
customize tolerance settings. 

Mesh models are used widely in the manufacturing industry but their editability has a lot of differences 
compared to a CAD model. 

Working with mesh files in Shapr3D 
You can use mesh files as a reference for your project with solid bodies, or modify it with boolean tools, 
transformations, and Visualization.  

To use mesh data, save it in a mesh file such as STL, and import it into Shapr3D. 

In this example, we imported a knob into Shapr3D and used the Extrude tool on guide sketches to cut away 
from the mesh body. We then used the Subtract tool to remove the unwanted extruded bodies, resulting in 
the desired final shape. 

 Tip 
 
You can only use boolean operations with closed (solid) mesh bodies, not open (sheet) mesh. 
Regardless of the type of boolean operation you use with a mesh body, the body will always stay 
a mesh body. 
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STL units 
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The STL file format is a widely used mesh format in 3D printing and rapid prototyping. An STL file only 
contains the geometry as a polygonal mesh model, so it takes up little storage space. However, the 
geometry is transferred in a unitless format, making it necessary to define the expected unit when exporting 
and importing STL files. This characteristic of STL files can cause limitations when preparing models for 3D 
printing or transferring STL files to other software.  

For example, if a model is created in inches and the slicer uses millimeters by default, a possible 
workaround is to scale the model in the slicer or standardize the unit of measurement in the entire workflow.  

In Shapr3D, you can change the unit of measurement of your model to the unit of your slicer during the 
export process. 

 Read more 
 
To learn more about exporting files, visit Export. 
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CNC cutting 
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CNC cutting is a widely used manufacturing method where a certain shape is cut from a sheet of material 
such as wood, metal, or plastic. CNC cutting begins after a set of steps, called toolpath, is generated from a 
group of planar curves. 
 
In most cases, a laser, waterjet, or plasma cutter does the cutting depending on the applied material and 
the desired finishes. The shape the machine will follow can be created in many different ways, each with its 
own set of advantages and disadvantages.  

Export your model for CNC cutting 
In Shapr3D, you can create the contour for generating the toolpath for CNC cutting by creating a layout of 
the 3D bodies of your model. Follow this guide to learn how. 
 

Step 1: Create a copy of your 3D bodies 
Create a copy of the 3D bodies you want to export for CNC cutting. This will be the body you can 
manipulate to create your sketches that can be exported for the toolpath.  
 
To copy a body: 

1. Select the body and then turn on the Copy badge. 
2. Using the gizmo, drag the arrow to create the copied body. 
3. To finish, select an empty area of the grid. 

Step 2: Move the copied bodies to a new Items folder 
For easy visibility, move your copied bodies to a new Items folder. 
  
To move items to a new folder: 

1. Select your copied body. 
2. Create a new folder with your desired name in the Items Manager. 
3. Drag the selected items to the new folder. 

Step 3: Hide your original bodies 
Hide your original bodies in the Item Manager to make it easier to focus on your copied bodies. 
  
To hide items: 

1. Open Items Manager. 
2. Click/tap on the visibility icon beside each body you need to hide. 

Step 4: Create a closed reference sketch planar to the XY plane 
Draw a closed sketch that is planar to the XY plane (Top view). The closed sketch serves as your reference 
for repositioning the bodies. 
  
To draw a reference sketch planar to the XY plane: 

1. Activate the XY planar view by pressing the Space bar key or clicking Top on the Orientation Cube. 
2. Use the Rectangle or Circle tool to draw a reference closed sketch on the offset plane. 
3. To finish, select Exit Sketching. 
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Important 
 
Some 2D tools can only recognize planes that are parallel to the X-Y plane. If the exported curves 
are aligned to a different plane direction, the contour may be distorted or completely missing.  

 

Step 5: Align your bodies to your reference sketch 

Use the Align tool or Move/Rotate tool to lay or align the parts of your bodies to your reference sketch. 
 
To align parts of your bodies using the Align tool: 

1. Select a part you want to align. 
2. From the adaptive menu, select Align. 
3. Select your reference sketch to automatically align the part. 
4. Use the arrows to organize the part to your desired layout. 
5. To finish, select Done. 
6. Repeat the steps for the remaining parts. 

  
To align parts of your bodies using the Move/Rotate tool: 

1. Select a part you want to align. 
2. From the adaptive menu, select Move/Rotate. 
3. Using the gizmo, move the part to align it to your reference sketch. 
4. Organize the part to your desired layout. 
5. To finish, select an empty area of the grid. 
6. Repeat steps 1 to 3 for the remaining parts. 

Step 6: Hide your reference sketch 
 

Once your parts are organized according to the reference sketch, you can hide the reference sketch. 
 

To learn how to hide a sketch or item, visit Items Manager. 

Step 7: Add an offset plane for your repositioned parts 
 

Use the Construction Plane tool to add an offset plane from your repositioned parts. The offset plane will 
serve as a reference for the next step. 

 
To add an offset plane: 

1. Select the top face of any part from your repositioned parts.  
Note: For easy reference, you can choose a part located at the center of your layout. 

2. From the adaptive menu, select Add Plane. 
3. Use the arrows to drag your offset plane upwards.  

Note: In the next step, you will project your parts to the offset plane so ensure that there’s enough 
distance between your parts and the offset plane. 

4. To finish, select an empty area of the grid. 
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Step 8: Project the bodies to the offset plane 
 

Use the Project tool to project the top faces of your parts as sketches to the offset plane. These projected 
sketches will be the reference for your toolpaths for cutting. 

 
To project the top faces of bodies to a plane: 

1. Select the top faces of all your parts. 
2. Select the offset plane. 
3. From the adaptive menu, select Project. 

Note: The selected face to be projected are highlighted in blue while the offset plane where the 
items are to be projected is highlighted in purple. 

4. To finish, select Done. 

Important 
 
Make sure to only select the top faces for the projection. Projecting an entire body results in 
duplicate curves which may not be handled properly.  

 

Step 9: Show your original bodies and hide unnecessary items 
 
Now that you have your projected sketches, you can show your original bodies again and hide items you no 
longer need. 
 
From the Items Manager:  

● Hide the offset plane, your repositioned/copied bodies, and other unnecessary items. 
● Show your original bodies. 
● You can also rename your projected sketches for easy reference. 

 

Step 10: Isolate your projected sketches 
Isolate your projected sketches to prepare them for export. 
 
To isolate your sketches: 

1. From the Items Manager, select your projected sketches. 
2. From the modes menu, select Isolate. 
3. To finish, select an empty area of the grid. 

 
You’re now ready to export your sketches for your toolpaths. 

Step 11: Export your projected sketches 
  
Export your projected sketches in a DXF, DWG, or SVG format. 
 
To export your sketches: 
 

1. From the menu, select Export. 
2. Go to the Sketch tab. 
3. Select your preferred sketch format. 
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4. Save the exported file to your desired location. 

To learn more about exporting, visit Export. 
 
You’re now ready to generate your toolpaths. 
 

Important 
 
You can create a drawing in 2D Drawings to scale your toolpaths to a specific sheet size. 
However, we recommend that you use the Sketch Export tool if you don’t need blueprints. 

 

Step 12: Generate your toolpath from your exported file 
Load your exported sketch file to your CAM software or CNC machine to generate the toolpath. 
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Shapr3D Beta 
Installing, updating, submitting feedback, and opting out of beta 
[Section link | Table of content | Back | Next] 

Shapr3D Beta features 
[Article link | Table of content | Back | Next] 

Shapr3D Beta  is a test version of Shapr3D  that you can install via direct download or Apple 

TestFlight  invite link. With Shapr3D Beta , you can test new and upcoming features and provide us 
feedback about your experience. Feedback we receive allows us to make improvements to these upcoming 

features, ensuring a great user experience once the final version is released to Shapr3D . 
 
Shapr3D currently has the following feature(s) available for beta testing: 

● History-Based Parametric Modeling – Download here 

To learn how to use this beta feature, visit the following articles: 
● Install Shapr3D Beta 
● Update Shapr3D Beta 
● Submit beta feedback 
● Opt out of Shapr3D Beta 
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Install Shapr3D Beta 
[Article link | Table of content | Back | Next] 

You can install Shapr3D Beta  directly from the Shapr3D website download page. Occasionally, 
Shapr3D sends out invite links via email that allows you to directly download Shapr3D Beta. 
 

 Tip 
 
To learn about the current features available for beta testing, visit Shapr3D Beta features. 

 
Follow this guide to learn how to install Shapr3D Beta. 
 

Windows 

Step 1: Download Shapr3D Beta 
 
To download Shapr3D Beta: 

1. Go to the Shapr3D website download page.  
2. Under Windows, click Download for Windows to download the installer. 

3. Once the download is complete, open the installer to install Shapr3D Beta . 
 

Step 2: Start testing features in Shapr3D Beta 
 

Open Shapr3D Beta  from TestFlight to start using it just how you would normally do in Shapr3D . 
 

Here are some tips when using Shapr3D Beta : 
● If you’re using an invite-only beta version, make sure to log in with your email address that got the 

invite to use Shapr3D Beta . 

● The three-device limit includes both Shapr3D  and Shapr3D Beta  so if your account is 
logged in to three devices, the one with the oldest login date will be logged out once you log in to 

Shapr3D Beta . 
● To start modeling with your current projects, export them from Shapr3D and import them into 

Shapr3D Beta . 

● Once you edit a project in Shapr3D Beta , it becomes incompatible when you import it back to 

Shapr3D . To prevent this issue, keep a copy or backup of your projects with the current version 

of Shapr3D . 

● Shapr3D Sync works separately for Shapr3D  and Shapr3D Beta . For example, if you sync 

your projects in Shapr3D , you can only access those synced projects when you log in to 
Shapr3D on another device.    
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iPadOS/macOS 

Step 1: Download TestFlight 
 

Before you can install Shapr3D Beta , you must have TestFlight  installed on your device. 
TestFlight is the service that Apple uses to install beta versions of software and applications. 
 
To download TestFlight: 
 

1. Go to Apple TestFlight to learn about the required platforms and available languages. 
2. Open App Store. Make sure you’re logged in to your Apple ID. 
3. Search for TestFlight. 
4. Tap Get to download. 

 

Step 2: Download Shapr3D Beta 
 

To download Shapr3D Beta : 
1. Go to the Shapr3D website download page. 
2. Under iPadOS & macOS, select Download for TestFlight to get directed to the TestFlight guide 

page. 
3. Under Step 2 (Join the Beta), select Start Testing. 
4. If your browser prompts you to open TestFlight, select Open TestFlight. 
5. From the TestFlight app, select Shapr3D Beta. 
6. Select Install to download. 

 
 

Step 3: (Optional) Turn off automatic updates 

Turning off automatic updates in Shapr3D Beta  is encouraged to ensure that you can keep a copy or 
backup of your projects. 
 
To turn off automatic updates: 

1. Open TestFlight. 

2. Select Shapr3D Beta . 
3. Under App information or App Settings, turn off Automatic Updates. 

 

Step 4: Start testing features in Shapr3D Beta 
 

Open Shapr3D Beta  from TestFlight  to start using it just how you would normally do in Shapr3D 

. 
 

Here are some tips when using Shapr3D Beta : 
● If you’re using an invite-only beta version, make sure to log in with your email address that got the 

invite to use Shapr3D Beta . 
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● The three-device limit per account includes both Shapr3D  and Shapr3D Beta  so if your 
account is logged in to three devices, the one with the oldest login date will be logged out once you 

log in to Shapr3D Beta . 
● To start modeling with your current projects, export them from Shapr3D and import them into 

Shapr3D Beta . 

● Once you edit a project in Shapr3D Beta , it becomes incompatible when you import it back to 

Shapr3D . To prevent this issue, keep a copy or backup of your projects with the current version 

of Shapr3D . 

● Shapr3D Sync works separately for Shapr3D  and Shapr3D Beta . For example, if you sync 

your projects in Shapr3D , you can only access those synced projects when you log in to 
Shapr3D on another device.    
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Update Shapr3D Beta 
[Article link | Table of content | Back | Next] 

Ensure that you have all the latest beta features available by keeping your Shapr3D Beta software 

version  up-to-date. Follow the guide below to learn how. 
 

 Tip 
 
To learn about the current features available for beta testing, visit Shapr3D Beta features. 

 

Windows 
Shapr3D Beta updates automatically on your device and will run continuously until the final version is 
released to Shapr3D. 

iPadOS/macOS 
Before you update Shapr3D Beta, keep a copy or backup of your projects to ensure that you don’t lose your 
previous projects if the new update doesn’t support those older projects. 
 
If you have automatic updates turned on in TestFlight, Shapr3D Beta automatically updates to the new 
version and you don’t need to do anything. 
 
If you have automatic updates turned off in TestFlight, follow these steps to update Shapr3D Beta: 

1. Open TestFlight. 
2. Select Shapr3D Beta. 
3. Select Update. 
4. To start using Shapr3D Beta right away, select Open. 
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Submit beta feedback 
[Article link | Table of content | Back | Next] 

Submitting feedback about your Shapr3D Beta  experience is highly encouraged so we can take note of 
any improvements and fixes to ensure a great user experience once the final version is released to 

Shapr3D . 
 
You can submit beta feedback in the following ways: 

Submit feedback via email 
Send an email directly to beta@shapr3d.com with the following information and/or attachments: 

● Subject line – Enter a relevant subject line relevant to your feedback. 
● Description of the issue or bug – Describe the issue you experienced such as what tools or 

workflow you were doing when the issue occured. 
● Relevant file attachments 

○ Visuals – Attach visual assets such as screenshots (Windows, iPadOS, macOS) or screen 
recordings (Windows, iPadOS, macOS) that visualizes the issue you experienced. 

○ Project file (preferrably in .shapr format) – Export your project with the issue and attach it 
to your email. 

● System or Device information 
○ Windows – Provide the model version, CPU (processor), and GPU information of the device 

to help us identify device-specific issues. 
○ iPadOS/macOS –  Provide the device type, year, and memory information of your iPadOS 

or macOS device to help us identify device-specific issues. 
Note: You can take a screenshot of the device information pages and include them with the 
other attachments. 

Submit feedback via Shapr3D Community 
Go to Shapr3D Community and create a new post or comment to share your feedback.  
 
Note: A Shapr3D Community account is different from a Shapr3D account. If you don’t have a Shapr3D 
Community account, select Sign Up at the top-right to create an account. 
 
To create a new post in Shapr3D Community: 

1. Go to Shapr3D Community, then log in with your account. 
2. On the top-right corner, select New Topic. 
3. From the title field, enter a title relevant to your feedback. 
4. From the category drop-down, choose the topic about the beta feature you’re testing. Other 

common topics you can choose from are: 
● Need help? We are here. – Posts about questions you have about Shapr3D or issues you 

encounter that you need help with. 
● Feature requests – Posts about your suggestions, feedback, or comments about possible 

features that you think Shapr3D should implement in the future. 
5. Enter the following information and/or attachments to your post: 

● Subject line – Enter a relevant subject line relevant to your feedback. 
● Description of the issue or bug – Describe the issue you experienced such as what tools 

or workflow you were doing when the issue occured. 
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● Relevant file attachments 
○ Visuals – Attach visual assets such as screenshots (Windows, iPadOS, macOS) or 

screen recordings (Windows, iPadOS, macOS) that visualizes the issue you 
experienced. 

○ Project file (preferrably in .shapr format) – Export your project with the issue and 
attach it to your email. 

● System or Device information 
○ Windows – Provide the model version, CPU (processor), and GPU information of the 

device to help us identify device-specific issues. 
○ iPadOS/macOS –  Provide the device type, year, and memory information of your 

iPadOS or macOS device to help us identify device-specific issues. 
Note: You can take a screenshot of the device information pages and include them 
with the other attachments. 

● Current Window mode – Let us know if you’re using Shapr3D Beta in a full screen or 
windowed mode. 

6. To add your attachments, simply drag and drop them to your draft. 
7. Once you’re ready to post, select Create Topic. 
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Opt out of Shapr3D Beta 
[Article link | Table of content | Back | Next] 

You can opt out of Shapr3D Beta  at any time. If you decide to opt out, make sure to keep a copy or 

backup of your projects in case you want to access them in Shapr3D  once the beta version is officially 
released.  

Windows 
To opt out of Shapr3D Beta, simply uninstall it just as you would in any normal app or program.  

iPadOS/macOS 
To opt out of Shapr3D Beta: 

1. Open TestFlight. 
2. Select Shapr3D. 
3. Select Stop Testing. 
4. Follow the on-screen instructions to be removed from the beta pool. 

 
Once you opt-out of testing, TestFlight and Shapr3D Beta remain installed on your device. If you no longer 
need them, you can uninstall them (iPadOS, macOS)  just how you would in any normal apps or programs. 
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Get help 
[Section link | Table of content | Back | Next] 

Submit a request 
[Article link | Table of content | Back | Next] 

Depending on your subscription type, you can submit a request or open a support ticket for the following 
issues: 

● Shapr3D Pro: Priority technical support for software, account, subscription, or troubleshooting 
issues. 

● Shapr3D Basic and Shapr3D EDU: Shapr3D issues such as crashes and data loss. 

 Tip 
 
For questions about modeling or creating projects, check out our Help Center or visit our Shapr3D 
Community and social channels. 

Create a support ticket 
Requests you submit automatically open a support ticket that is received by our support team. An available 
support representative will get back to you via email once they receive your request. 

Tip 
 
In case of a project crashing, or completely or partially not opening, the support team can 
try to revert your project if you have Sync enabled. As long as Sync is enabled, your work is 
not completely lost. If you submit a request and provide Shapr3D consent to recover your work, 
will do everything to restore your project(s)our support team can easily help restore your project(s).  

To submit a request, 

1. Go to Shapr3D Support. 
2. Click Log in to view all issue options. 
3. From the dropdown menu, choose an issue type. 

Note: If you’re unable to log in or have password reset-related issues, select the available issue 
type about account access. 

4. Fill out the form with all the required information. The basic information you need to provide are the 
following: Subject, Description, and Attachment. See Information to provide in support tickets 
below to learn what details you should provide depending on your issue. 

5. Once you’ve filled out all the information needed, click Submit. 
6. Wait for a support representative to get back to you via the email you provided. 
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Information to provide in support tickets 

Subject 
In the subject field, enter a subject that best summarizes your issue. 

Description 

In the description box, provide a brief description of your issue or concern. Follow the provided guidelines 
indicated below the description box on what not to include in your request: 

● Your consent that we can take a look at your data. 
● Your Shapr3D app version found under Settings or Preferences. 
● The detailed hardware and software specs of the machine you are using. 
● A detailed description of what leads to the problem. 
● A screen recording of the issue. For more information, see Attachments. 
● The Shapr3D project in .shapr format for which you’re experiencing the issue. For more information, 

see Attachments. 
● The name of the project where you're experiencing the issue. 

In case of a project crashing, or completely or partially not opening, the support team can try to 
revert your project if you have Sync enabled. As long as Sync is enabled, your work is not completely 
lost. If you submit a request and provide Shapr3D consent to recover your work, our support team will do 
everything to help restore your project(s). 

Attachments 

Attachments are optional, but we recommend that you submit a screenshot or screen recording for specific 
issues to help our support team collect information that can help resolve your issue faster. 
Note: Check out Create screen recordings for your request to learn how to attach regular and larger files. 
 

Important 
 
If you choose to provide attachments of your work in your support ticket, please provide an 
explicit line in your description that you are giving Shapr3D consent to look at data related to 
your submitted file. 
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Verify your Shapr3D account 
[Article link | Table of contents | Back | Next] 

To fully access the Shapr3D Customer Support portal, you need to verify your Shapr3D account email 
address. 

Verify your account 
Verify your email address and complete your account registration through your account page:  

1. Go to the Shapr3D website.  
2. Log in to your account. 
3. Select your email address at the top right corner.  
4. In the drop-down menu, look for the alert about your unverified email address. 
5. Select Resend verification email in the drop-down menu to receive an email from Shapr3D to 

complete your account registration. 
6. Open the email and select Verify email address.  

Verification issues 

No email received 

If you haven't received the verification email, try any of the following: 

● Check your registered email address for Shapr3D:  Go to your Account page to confirm the 
email for your Shapr3D account and ensure you're signed in to the correct email address. 

● Check your folders: If you're organizing your emails using folders, the verification email may have 
ended up in one of your folders. Make sure to check all your folders including Spam. 

● Search for @shapr3d.com: An easy way to find an email is through your email search bar. Simply 
type @shapr3d.com and look for the results in all your folders including Spam. 

● Check your spam filters: Your email might be detecting the email as spam. Check your filters and 
make sure @shapr3d.com is not on the list. 

Email detected as spam 

If you find the email in your spam folder, follow these steps: 

1. Move the email to your primary folder. 
Note: If the email remains in the spam folder, the verify email link will not work. 

2. Click the Verify email link to verify your email. 
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Whitelist Shapr3D 

In some cases, you may need to whitelist Shapr3D's domain or IP addresses if your school or company 
implements stringent email security measures. Reach out to your domain provider and request to whitelist 
the domain or IP addresses of Shapr3D: 

● Domain: @shapr3d.com  
● IP addresses: 

○ 149.72.175.150 
○ 149.72.227.206 

Need more help? 

If your email address is still unverified after you've completed the steps above, contact Shapr3D Support at 
loginsupport@shapr3d.com detailing your issue, and a team member will assist you promptly. 
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Create screen recordings for your request 
[Article link | Table of contents | Back | Next] 

When submitting a request to our support team, a screen recording is helpful in collecting information about 
your issue. To ensure that the format of screen recordings you submit is supported by Shapr3D, follow the 
tips below on how to share regular and larger files. 
 

Important 
 
If you choose to provide attachments of your work in your support ticket, please provide an 
explicit line in your description that you are giving Shapr3D consent to look at data related to 
your submitted file. 

 

Windows 
Try these tips on how to screen record on Windows: 

● Follow this guide on how to record your screen on Windows 11. 
● You can also use the free Microsoft app, Screen Recorder Pro. 

iPadOS 
To learn how to screen record on your iPad, refer to this Apple support page: Record the screen on your 
iPhone, iPad, or iPod touch. 

macOS 
To learn how to screen record in a Mac device, refer to this Apple support page: Take screenshots or 
screen recordings on Mac 

Share large cloud files with our support team 
If your screen recording results in a larger file or fails to upload in the request form, you can upload your 
files to Google Drive or WeTransfer and include the shareable link in the description of your request. 

● Google Drive:  
○ Upload your file 
○ Get a link to share with anyone to ensure that our support representatives can access the 

files. 
● WeTransfer: 

○ Upload your file 
○ Get a link to share with anyone to ensure that our support representatives can access the 

files. 
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Find hardware and software specifications 
[Article link | Table of contents | Back | Next] 

When reaching out to Shapr3D support for technical issues, make sure to provide accurate hardware and 
software specifications. This information helps our team diagnose and resolve issues more efficiently. 
Follow the steps below to find the necessary details for your device. 

Windows 
Before submitting a support ticket for technical issues, make sure to provide all information such as CPU 
and GPU details from the DirectX Diagnostic Tool.  

To get the necessary specifications for Windows: 

1. Go to the DirectX Diagnostic Tool 
2. Click Save All Information to export the necessary specifications. 

For more detailed instructions, visit How to Extract Information from the DirectX* Diagnostic Tool. 

iPadOS 
Before submitting a support ticket for technical issues, make sure to provide the following specifications of 
your iPadOS device: 

● iPad Model Name 
● iPadOS Version 
● Model Name 
● Model Number 

To get the necessary specifications for iPadOS: 

1. Go to Settings > General > About. 
2. Take a screenshot of the necessary specifications to include in your support ticket. 

For more detailed instructions, visit Get information about your iPad. 
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macOS 
Before submitting a support ticket for technical issues, make sure to provide the following specifications of 
your macOS device: 

● Mac Model Name 
● Graphics Card (GPU) 
● macOS Version 
● Memory (RAM) 
● Processor (CPU) 

To get the necessary specifications for macOS: 

1. Go to the Apple menu > About This Mac. 
2. Take a screenshot of the necessary specifications to include in your support ticket. 

For more detailed instructions, visit Get system information about your Mac. 
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EDU license email whitelist guide 
[Article link |  Table of contents | Back | Next] 

Shapr3D offers email whitelisting for accredited educational institutions. Whitelisting email domains give 
automatic approval for students, teachers, or faculty members who apply for the Shapr3D EDU license.  

Requirements 
Before email whitelisting can be requested, gather the following requirements: 

● Signed and stamped document from the educational institution with the following information: 
○ Must confirm that the students are currently associated with the institution 
○ Must state that the accounts will be used for educational purposes only 

● Complete list of the email domains used by the members of your institution   

Email whitelisting process 

For the representative making the request 
To request for email whitelisting for your institution, follow these steps: 

1. Contact Shapr3D by submitting a request to the support team. Include and attach the requirements 
you gathered in the request form. 

2. Wait for a response from Shapr3D confirming that the request is approved and the email domains 
whitelisted. 

3. Inform the members of your institution that the email domains are now whitelisted. 

For the members applying for the EDU license 
Follow these steps to get an EDU license automatic approval: 

1. Make sure that your institution email domain is already whitelisted. 
2. Create a Shapr3D account using the email address provided by your institution. 
3. Verify your account. 
4. Apply for an EDU license through the Request EDU license form. 

Note: If your email domain is already whitelisted, you don’t need to attach any documents. 
5. Wait up to 1 working day for your request to be automatically approved. 
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Troubleshooting 
[Section link | Table of contents | Back | Next] 

Installation issues 
[Article link | Table of contents | Back | Next] 

If you're having issues installing Shapr3D, try the suggested steps below to solve your issue. 

Unable to install from the Microsoft Store 
You can download the standalone installer through the Shapr3D website. For more details, visit Download 
Shapr3D. 

If you prefer to install Shapr3D from the Microsoft Store, try these tips:  

● Make sure you're signed in to the Microsoft Store with your Microsoft account.  
If you're not, select the user icon at the top right to sign in.  
Note: Your Microsoft Store account might not be the same account you use to log in to your 
Windows device. If you don’t remember your password, visit Reset a forgotten Microsoft account 
password for tips on password recovery. 

● Check if your Windows version is compatible with Shapr3D. 
Your device should be running a version of Windows 10, version 2004 or later. Refer to Which 
version of Windows operating system am I running? on how to check the OS version and Update 
Windows to update it.  

● Use a different Microsoft Store if you have the Educational or Business license for Shapr3D. 
If your Microsoft account is connected to an educational institution, try installing Shapr3D from the 
Microsoft Store for Education. 
If your Microsoft account is a business account, try the Microsoft Store for Business. 

● Clear the Microsoft Store cache. 
You can run an application, wsreset.exe, as the administrator. For more details, visit How to Repair 
or Reset Microsoft Store or Clear Windows Store Cache in Windows 11/10.  

● Check any error codes in Microsoft Store.  
If the Microsoft Store shows an error code, such as “0x803F6101," check the meaning of the code in 
Microsoft Docs for store operations error codes and common installation-related error codes to help 
give you hints on what to do. 
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Multiple installation issues on Windows 
Installing Shapr3D from multiple installation sources is not supported as it can cause data loss. If you get a 
message about multiple installations when opening Shapr3D, make sure that you only have one Shapr3D 
installed on your device. 

Follow these steps to solve the issue: 

1. From the Windows Start menu, open Settings. 
2. Select Apps > Apps & features. 
3. Sort the list by date. 
4. Look for Shapr3D.  
5. If you see 2 builds of Shapr3D, uninstall the most recently installed one. 

For more details about uninstalling programs from Windows, visit Uninstall or remove apps and programs in 
Windows. 
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Shapr3D stability issues 
[Article link | Table of contents | Back | Next] 

Running Shapr3D on the latest drivers gives you the best modeling experience. If you experience stability 
issues while using Shapr3D, make sure your device software or drivers are up-to-date. 

Symptoms 
Below are the possible issues you may encounter if your device software or drivers are outdated: 

● Shapr3D frequently crashing 
● Unusual graphical glitches 
● Problems launching Shapr3D 

Troubleshooting 

Windows 
Try these steps to solve the issue: 

1. Check that Shapr3D is up-to-date and restart your device. If the symptoms persist, go to the next 
step. 

2. Identify the manufacturer of your GPU. 
3. Choose your GPU manufacturer to learn how to update your drivers: 

● AMD 
● Intel 
● NVIDIA 

Note: Some device manufacturers provide custom drivers for their devices. Visit the website of your 
manufacturer to learn how to update your drivers. 

4. Select the driver component you want to update. 
5. Download and install the latest version of the driver. 
6. Restart your device. 
7. If you continue to experience issues, contact our Customer Support team. 

 
To learn more about updating Windows drivers, visit Automatically get recommended drivers and updates 
for your hardware and Update drivers manually in Windows. 
 

iPadOS 
Try these steps to solve the issue: 

1. Check that Shapr3D is up-to-date and restart your device. If the symptoms persist, go to the next 
step. 

2. Check that your device software is up-to-date.  
3. If you continue to experience issues, contact our Customer Support team. 

 

macOS 
Try these steps to solve the issue: 

1. Check that Shapr3D is up-to-date and restart your device. If the symptoms persist, go to the next 
step. 

2. Check that your device software is up-to-date. 
3. If you continue to experience issues, contact our Customer Support team.  
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Third-party known issues 
[Article link | Table of contents | Back | Next] 

iOS and iPadOS sharing issues 
There's a known issue in iOS 13 and later that prevents users from using AirDrop and other share options 
such as email to share their files with other devices and apps.  

Symptoms 
In reported cases, the Save This File window is blank and doesn’t display any sharing options. This may 
prevent you from sharing your Shapr3D projects. 

Workaround 
Try any of the following workarounds to help solve the issue: 

● Reset network settings: Go to Settings > General > Transfer or Reset iPad > Reset > Reset 
Network Settings. 

● Turn off Siri Suggestions: Go to Settings > Siri & Search > Turn off Show When Sharing and 
then restart your iPad. 
 

If the issue persists, visit Fix Issue of 'Sharing Options Not Showing' on iOS 16/15 for other workarounds 
you can try. 
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Error messages in History 
[Article link | Table of contents | Back | Next] 

When reviewing the History sidebar, you may occasionally notice yellow warning symbols beside certain 
steps. Yellow warning messages may appear for bodies or faces that can’t be created due to missing or 
invalid results for certain steps with incorrect parameters or references. Read on to learn about the different 
History error messages and how to solve them. 

Missing references 
A common error you may encounter is a “missing reference” for affected History steps. These missing 
references can either be for sketch planes, profiles, or edges.  

Plane 
To resolve a missing reference for a sketch plane: 

1. Expand the History card for the step with a missing plane reference. 
2. Select Fix.. 
3. Select a planar face or plane. 
4. To complete the fix, select Done. 

Edge 
To resolve a missing reference for an edge: 

1. Expand the History card for the sketch plane with a missing edge reference. 
2. Select Fix.. 
3. Select valid edges on your model. 
4. To complete the fix, select Done. 

Profile 
To resolve a missing reference for a profile: 

1. Expand the History card for the step with a missing profile reference. 
2. Select Fix.. 
3. Select a valid profile. 

Note: The missing references are usually highlighted in yellow. 
4. To complete the fix, select Done. 

 
 

 
 
 

 

289 

https://support.shapr3d.com/hc/en-us/articles/9741020081692


 

Fix broken dependencies in Design History 
[Article link | Table of contents | Next | Back] 

When you model in Shapr3D, each step that gets recorded in History forms a dependency or connection. If 
a step – such as an edge, sketch, or complete body – is missing, then the subsequent steps can’t properly 
proceed, eventually breaking the history. 

Common causes  
If you have missing modeling elements or broken design history, it could be due to any of the following 
reasons: 

● A reference geometry or step was lost or removed 
● A reference or step was deleted  

Symptoms 
Your design history may have broken dependencies or connections if you experience any of the following: 

● Missing modeling elements 
● Entire model completely gone or missing 
● Several error messages in History 

 

Troubleshooting 
In most cases, you can fix broken connections or dependencies in your model by following these steps:  

1. From the History sidebar, locate the first step with the first error message and then open the 
expandable card. 

2. Select Fix… to see what reference is missing. Missing references are shown as an orange hatch in 
the modeling space.  

3. Proceed with any of the following steps: 
● Recreate the missing reference: 

1. Create the missing reference in the same place as where the orange hatch was 
shown. 

2. Optional: If your newly created reference generates a new step in the History 
sidebar, move the newly created step above the step you’re currently fixing. 

● Select a different reference: 
1. Choose a different reference for the broken step. 
2. To finish, select Done. 

 

 Tip 
 
When encountering multiple error messages in Design History, start fixing the first step with the 
first error message. 
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Example #1: Missing model due to a deleted reference step 
In the example below, we have a model with a properly working Design History. 
 

 

Scenario 
In this scenario, we will delete the Base Sketch step at the very beginning of the History sidebar. 
 

 
 
By removing the Base Sketch step, we eliminate the reference of all the succeeding steps, causing each 
step in the design history to break, and the model to disappear as shown by the yellow warning labels. 
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Troubleshooting 

To fix this issue: 

1. Open the expandable card for the first step with the first error message. In this case, we expanded 
Extrusion 01. 

2. In the card, check the the description of the error message to see what's causing the problem. In 
this case, it states that we have 1 missing reference. 

3. To view the missing reference, click the Fix... button. Selecting Fix...highlights the missing 
cross-section in the modeling space with an orange hatch, which was from where the deleted Base 
Sketch step was originally created. 

4. We can then either use the orange highlight to recreate the cross section, or select another sketch 
that will be used as the new reference. 

 
 

 Tip 
 
Design History maintains a connection between bodies and sketches. If a sketch is in the way, 
you can use the Items Manager to hide it instead of deleting it. Hidden sketches will not be visible 
in the modeling space and will not affect the performance of Shapr3D.  
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Example #2: Missing model parts due to a deleted sketch item 
 
In the example below, we have the same model with a properly working Design History. 
 

 

 

293 



 

Scenario 
In this scenario, we will delete a sketch item that is part of the Handle Sketch step. 
 

 

By deleting a sketch item that is part of the Handle Sketch step, the sketch handle is no longer a closed 
cross section that can be used as a reference, causing the succeeding relevant steps to break, and the 
handle of the model to disappear as shown by the yellow warning labels. 

Note: The steps Shell 02 and Fillet 09 did not break because they were steps for the main container so 
they were not affected by the change. 
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Troubleshooting 
To fix this issue: 

1. Open the expandable card for the first step with the first error message. In this case, we expanded 
Extrusion 02. 

2. In the card, check the description of the error message to see what's causing the problem. In this 
case, it states that we have 1 missing profile reference. 

3. To view the location of the missing reference, click the Fix... button. Selecting Fix... highlights the 
missing cross-section in the modeling space with an orange hatch, in this case, due to the deleted 
sketch item.  

4. We can then either use the orange highlight as a reference so we know where to recreate the 
incomplete cross section. 

5. Optional: If the sketch is automatically hidden, we can go to the Items Manager to show the 
recreated sketch for the Sketch Handle step. 

6. To finish the fix, we can now go back to the Extrusion 02 step to add the missing profile. 
7. After selecting Done, all the broken steps are now repaired and the full model now appears again in 

the modeling space. 
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Rendering accuracy 
[Article link | Table of contents | Back | Next] 

In Shapr3D, rendering accuracy may differ from modeling accuracy. While Shapr3D uses a Parasolid 
modeling engine to create manufacturable solid bodies with exceptional precision, this precision doesn't 
necessarily apply to the display accuracy. 

Depending on the hardware you use to run Shapr3D, you may notice a few display inaccuracies such as: 

● gaps between sketches and their fillings 
● gaps between bodies and their sketches 
● jagged edges  

These display inaccuracies you notice don't affect the precision of your model. 

Read on to learn more about the concepts behind modeling and rendering accuracy, and some 
troubleshooting tips to get the best display accuracy when you're modeling. 

Modeling vs rendering precision 
In CAD, modeling is the process of creating precise geometrical elements while rendering is the general 
term for displaying a precisely computed geometrical element. 

Modeling precision 
When you model, geometric calculations of created sketches and models such as boundaries, intersecting 
lines, intersecting bodies, or super complex splines, are carried out with a precision of at least 0.001 mm in 
the background. 
 
The precision of geometric calculations in the background is easy to maintain for modeling, but this 
precision isn’t always easily carried out in rendering. 
 

Rendering precision 
To ensure the efficiency of the required hardware performance and rendering, the level of precision 
maintained in model calculations goes through a geometric simplification which causes you to only see an 
approximation of your model. 

Complex models accuracy 
Your complex models are still geometrically accurate regardless of reduced rendering quality. 

The reduced rendering accuracy is just a visibility setting to ensure the efficiency of the required hardware 
performance and rendering. 

With a reduced rendering quality, Shapr3D saves performance and can run flawlessly on a broad range of 
devices. 
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Troubleshooting rendering quality issues 
You might experience reduced rendering quality more frequently when you zoom in a lot in the modeling 
space or have hundreds of bodies. 

The scenarios below give you an overview of how zooming affects the rendering quality of the different 
areas in your model and what you can do to make the quality more accurate. 

Reduced rendering accuracy on sketches 

Cause 
When zooming in on sketches, Shapr3D reduces the rendering quality to save on performance. 

Symptoms 

With the reduced quality, you may experience the following: 

● Visible gaps between sketch elements and the sketch profile 
● The camera intersects with the grid  

In the example below the workspace is zoomed in with a grid resolution of 0.005 mm. The level of zoom 
shows an intersection between the camera and the grid and a gap between the sketch and the blue sketch 
profile. 
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Troubleshooting 

Try these steps to improve the rendering accuracy: 

1. Check the grid resolution in the upper right corner, and zoom out to adjust the resolution 
accordingly. 

2. Carefully zoom out to get the right level of detail, or double-tap the Orientation Cube to give you a 
clear overview of the entire model. 

Distance between bodies and sketches 

Cause 
When zooming into the edges of bodies, Shapr3D reduces the rendering quality to save on performance. 
The reduced rendering quality doesn't affect the computational accuracy of the model. 

Symptoms 

With the reduced quality, you may experience the following: 

● Visible gap between the edge of a body and the sketch from which it was created 

In the example below, there is a visible gap between the sketch and the edge of the body. 

 

Troubleshooting 

To improve the rendering accuracy, adjust the level of zoom to achieve your level of desired rendering 
accuracy. 
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Curved edges appearing as jagged edges 

Cause 

● When you have A few hundred bodies in your modeling space and you zoom in on edges, Shapr3D 
reduces the rendering quality to provide a smooth modeling experience. 

● To save on performance, the detail of rendering may decrease depending on your level of zoom and 
the number of bodies in the modeling space. The reduced rendering quality doesn't affect the 
computational accuracy of the model. 

● Zooming in on faceted models consisting of polygons or straight elements eventually appear as 
jagged edges when zoomed in at a certain level. 

In the examples below, the model on the left shows a jagged but continuous edge, showing that it is a 
curved edge. 

The model on the right shows intersecting edges indicating that the upper edge is not a curve but an edge 
consisting of straight elements. 

 
Curved edge with reduced rendering quality  

 
Edge consisting of multiple straight elements  

Symptoms 

With the reduced quality, you may experience the following: 

● Curved edges appear jagged the more you zoom 
● Consider using splines or arcs to achieve smoother edges 

Troubleshooting 

To improve the rendering accuracy, adjust the level of zoom to achieve your level of desired rendering 
accuracy. 

If the troubleshooting steps above didn't improve the rendering accuracy of your model, try these additional 
tips: 

● Make sure that the drivers on your device are up-to-date. To learn more, visit Shapr3D stability 
issues. 

● Create your models near the origin. Check out Move/Rotate (3D) and Move/Rotate (Sketch) to learn 
how to move your models near the origin. 

If the issue persists, submit a request. 
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Password reset issues 
[Article link | Table of contents | Back] 

If you're having trouble resetting your Shapr3D account password or experiencing issues such as not 
receiving the password reset email, try the solutions below to help resolve your issue. 

No email received 
If you haven't received the password reset email, try any of the following: 

● Check your registered email address for Shapr3D: Ensure you enter the correct email address 
associated with your Shapr3D account for the password request. Verify that there are no typos or 
unnecessary punctuation. 

● Check your folders: If you're organizing your emails using folders, the password reset email may 
have ended up in one of your folders. Make sure to check all your folders including Spam. 

● Search for @shapr3d.com: An easy way to find an email is through your email search bar. Simply 
type @shapr3d.com and look for the results in all your folders including Spam. 

● Check your spam filters: Your email might be detecting the email as spam. Check your filters and 
make sure @shapr3d.com is not on the list. 

Email detected as spam 
If you find the email in your spam folder, follow these steps: 

1. Move the email to your primary folder. 
Note: If the email remains in the spam folder, the password reset link will not work. 

2. Click the Reset password link to change your password. 
Note: For the complete steps, visit Reset your Shapr3D account password. 

Whitelist Shapr3D 
In some cases, you may need to whitelist Shapr3D's domain or IP addresses if your school or company 
implements stringent email security measures. Reach out to your domain provider and request to whitelist 
the domain or IP addresses of Shapr3D: 

● Domain: @shapr3d.com  
● IP addresses: 

○ 149.72.175.150 
○ 149.72.227.206 

Need more help? 
If you need further assistance, contact Shapr3D support at loginsupport@shapr3d.com. For a quicker 
resolution, include the following information in your email: 

● Any other email addresses that you might have an account with 
● The date and amount of your latest subscription payment 
● A screenshot of the charge or a section of your bank statement displaying the charge
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Licenses 

Third-party licenses 
[Article link | Table of contents] 

Shapr3D uses several third-party libraries, repositories, and other similar software packages. Thank 
you to the owners and contributors listed below. 
 

● 3Dconnexion 
● abseil 
● Alamofire 
● AppsFlyerFramework 
● Dear ImGui 
● Draco 3D Graphics Compression 
● Eigen 
● FBSDKCoreKit 
● Filament 
● Firebase/Core 
● Firebase/Crashlytics  
● Intel TBB 
● Lib3mf 
● LLVM 
● Meshoptimizer 
● MGSwipeTableCell 
● MKStoreKit 
● MikkTSpace 
● Miniz 
● moodycamel::ConcurrentQueue 
● moodycamel::ReaderWriterQueue 
● mpack 
● pugixml 
● RapidJSON 
● Reachability 
● spdlog   
● SQLite 
● stb_image 
● SwiftLint 
● tinyobjloader 
● TL::expected 
● tree-sitter 
● USD 
● Welder 
● Xatlas 
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